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Introduction

Well, you've gone and done it.

In a moment of weakness, during the wee hours of a Saturday morning, you
called the 800 number on the screen and nervously recited the 16 digits of your
VISA card number. Now, the day of reckoning has arrived because the object
of your techno-lust has just been delivered:

The SEE - Magik Housemaster 2000
All-In-One, Do-It-Yourself,
2000 Piece Home Builders Toolkit

After carefully releasing the kit from its package and checking that all 2000
pieces safely made the journey, you sit down to scan the instruction manual.

It all seems to be there. The function of each piece is meticulously described,
right down to the drill key and the carpenters square. In addition, there's over
100 bonus pages reviewing the history and philosophy of carpentry. Sure,
there's a lot to learn, but now that you have the right tools and information on
what each tool is used for, how can you go wrong? This is going to be a breeze.

There's only one question left in your mind — Where do | begin?

While it is certainly a stretch to compare this scenario to your purchase of LOGIC
Audio, there are enough similarities to make it a workable analogy. Perhaps it would
be more accurate to describe buying the SEE - Magik Window Master, Concrete
Master, and Lumber Master kits as well. At least that would more closely convey the
multi-faceted nature of LOGIC Audio.

In either case, the concluding question - Where do | begin - is exactly the question
this manual endeavors to answer. Instead of just describing a particular features
function — as the User manual does — this guidebook endeavors to provide answers

to questions about when, where and in what order you might use these tools.

So, though you will still some are glossary-like definitions such as:

e The Multi-Instrument

The Multi-Instrument is a special object in the Environment window that
allows you to address multiple channels of one of your MIDI devices,
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Introduction

You'll also find step-by-step instructions on setting up this object under a heading
like:

How to decide what Environment object to use for each of your MIDI devices

This approach is especially useful when the answer to a question cannot easily be
found in one place in the user’'s manual. For example, the question of how to record
an audio track involves: settings in the Audio Extensions Preference window; setting
the Record Path, selecting the proper input on the Audio Object, assigning an Audio
Object to a Track in the Arrange Window, record enabling the Audio Object, and
using the Transport Controls. The an Audio object, might be the question of how to
record digital audio when synchronized to tape and using MIDI Machine Control. The
information about these tools is spread across two or three separate chapters of the
users manual. Here, the basic information you need to perform this task is presented
in one series of step-by-step instructions.

The scope of this manual is limited.

To answer every possible "how to" question relating to the use of LOGIC or LOGIC
Audio would take volumes, and is not the goal of this document. Instead, it attempts
to address the most prevalent question that the majority of users will face during the
initial 30 days of owning the program.

So, don’t throw away your user’s manual — it is still the primary resource for infor-
mation about Logic Audio. If you take the time to read it, it will clarify and enhance
the basic knowledge provided in this guidebook. This will increase your potential for
getting the most out of your investment in this program, and eventually, make Logic
the most powerful creative tool in your musical arsenal. (other than your heart and
brain of course!)
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How to use this Guidebook

As suggested in the Introduction, this guidebook is primarily "application driven”. In
other words, it is more interested in answering questions about how to do some-
thing in LOGIC rather than those about what itcan do. Each chapter will therefore
be dominated by step-by-step instructions leading through specific procedures.

This does not mean the document is completely devoid of simple feature descrip-
tions. Enough reference material is included so that the manual can “stand on its
own”.

In this chapter we address a very important "How to", namely — "How to use this
Guidebook". Taking the time to read it will make it easier for you to find the infor-
mation you need, because you will understand how it has been organized, and what
tools are available for accessing it.

Basic Structure

This handbook is organized into 5 major sections:

Quick Start

A quick test and setup section designed to get you up and running as quick as
possible.

MIDI Setup and Configuration

All about tailoring Logic to match your MIDI system

What Makes Logic Special
Examines unique and indispensable tools found in Logic Audio

Recording

Discusses primary recording procedures and settings. (Although it focuses on
MIDI use, much of this chapter is equally applicable to audio applications)
Editing

Discusses primary editing tools and features

( Although it focuses on MIDI use, much of this chapter is equally applicable

to audio applications )
Working with Audio

Examines those aspects of Logic Audio that are unique to the audio portion
of the program
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How to use this Guidebook

In addition to these sections you will finde a Table of Contents, a a special “How To"
Index and an Index for the on-line Quicktime tutorial files.

Other Conventions

There are a few other little conventions used in each chapter which should help you
find and digest the information you need more quickly.

Menus

In the interest of keeping this guide shorter than the Manhattan Telephone Direc-
tory, we'll abbreviate menu selections by listing the menus and choices in the format
shown below. The first item in the instruction will be the name of the window that
the menu belongs to. Everything that follows will be a menu or sub-menu name until
the last item, which is the selection to be made. If there is no window name at the
beginning of the string, it means the menu is one of the "global" menus always at
the top of the screen. For example, if we were instructing you to setect the "Delete
Unused" track command, it would look like this:

Arrange -> Structure -> Track -> Delete Unused

If there are multiple choices at the end of the menu, they will be separated by the 'l'
symbol.

One further convention regarding menus: In some cases, if the sub-menu may be a
"pop-up" menu rather than a menu on a menu bar, the word "menu" will be
included in the instruction. This is just a code to alert you not to look for a menu by
this name on one of the menu bars — obviously, we'll tell you where to find a pop-
up menu before we ask you to use it. In Windows systems, the sub-menu sometimes
comes in the form of the common Windows “tab". If that is the case, the word "tab"
will be appended to the sub-menu name.

"_ MacOS vs E Windows systems

This handbook covers both the Windows and MacOS versions of Logic Audio. When-
ever there is a key command or other procedural discrepancy, the convention for
each system will be clearly indicated, sometimes identified by the associated symbol
as above. The screenshots used are taken equally from the Mac and Windows
versions. When there significant differences between what you see in each program,
screenshots for both are included.

Abbreviated step-by-step instruction headings

Each step in a set of step-by-step instructions begins with an abbreviated description
in bold, followed by the more detailed instructional text. If you are a more experi-
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How to use this Guidebook

enced user reviewing a procedure you can therefore get through the instructions
more efficiently by just reading these bolded headings.

"What you will Learn" summary

There is a summary at the beginning of each chapter which clearly outlines what
material will be covered in that chapter. This information will assure that you are in
the right place, and prepares you mentally to digest the material to be covered.

dural hints that will help you become a more effective user. They are easily

TIPS
(‘E Tips describe keyboard shortcuts, useful mouse modifiers, or other proce-
identified by the icon like the one at the left.

NOTES

Notes contain supplemental information or procedural reminders regarding
the topic being discussed. They are easily identified by the icon like the one
at the left.

WARNINGS
Warnings are indicated by the icon like the one to the left of this text. They

+ contain important reminders and should be read carefully.

Information Sidebars

Occasionally, you will find a section of text set off from the rest by a darker tan back-
ground. These “sidebars” contain additional information about the procedures
being described on the surrounding pages. They are separated from the rest of the
text only because they do not have to be read in order to complete the tasks at hand.
It is of course still in your best interest not to skip over these special sections.

Special PDF Functions

When you installed Acrobat Reader 3.0 on your machine, it installed a Readme file
describing all of the nifty features that it has to offer. You will do yourself a great
disservice if you neglect to read it, as Acrobat Reader has a lot of nice features which
enable you to get around this document more readily. The three features that we
took special advantage of when creating this document are described below:

Bookmarked Chapters and Sections
You may have already discovered that the chapters and sections of this manual are
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How to use this Guidebook

listed in the column along the left of this text. (If this column is not visible, click on
the (PIC) icon in the toolbar at the top of this window).

Hyperlinked Text

PDF documents allow you to hyperlink text within a document. This means that you
can click on any hyperlinked word and it will take you to the section it is linked to.
In this handbook, all purple words are hyperlinked. Clinking on the word will leap-
frog you to that section. Clicking on the title of that section will return you to your
starting point.

Quicktime Movies
One of the most exciting features of PDF documents is the ability to link
to Quicktime movies. This document contains eight quicktime movies
t.:_': which give you a first hand look at the procedures being discussed in the
| handbook. Whenever you see the icon like the one at the left, click on it
and the movie will immediately open and play. You can use the standard

Quicktime transport controls to rewind, fast forward or locate within a
movie.
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What You Will Learn

This section’s purpose is to get you up and running as fast as possible. In the process,
we'll be able to make sure that the main components in your MIDI and Audio system
are "on-line" and talking to one another as they should. The steps followed will also
provide you with a standard test procedure to use in the future, in the event that
you run into any trouble.

The information is organized into the following sections:

(= Basic MIDI connections and Settings
(@ Program Change Response Check
(@ Record your first MIDI track

(@ Volume and Pan Check

(@ Audio System Check
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1.1 Basic MIDI connections and Settings
Set Interface Preferences
The first task is to make sure that the LOGIC's MIDI settings are  how to:
set correctly for your particular hardware and connections. , «ot prefer-
Before you can do this, you must know a few facts about your e e
system. match your
You must know the type of interface you are using :c\glczl Inter-
There are two basic types of MIDI interfaces:
e select and
e ‘Standard’ single port interfaces which provide for a define
maximum of 16 MIDI channels for each port they are Z“tp““from
connected to (This includes an interface like the Studio 3, Vi;'r\znl?s?ng
which is basically just two interfaces in one, each of which Instrument
gets connected to a separate serial port on your MacQOS) Parameter
Box
e A 'multiport’ interface which provides multiple discrete
(sometimes called “virtual”) ports for the serial port it is * f\?|e|)c|kt:1hat'
connected to. SIS
working
You must know which outputs of the interface each of o check that
your devices is connected to LOGIC's MIDI

If you have a multiport interface, you must know which MIDI
outputs go to which MIDI inputs of your MIDI devices

We are also assuming that you have made all the proper MIDI
and serial port connections as per the instructions that came
with your interface.

“_ MacOS

You must know which MacOS serial port the interface is
connected to

settings are
set correctly
for your

MIDI system

create a new
instrument
from the
Arrange
window

If you are using a multi-port interface such as a Unitor 8, Studio 5, Studio 4,

MIDI Time Piece, MIDI Express, Studio 64, you should know what speed you've
set the interface to perform at. This is generally referred to as Normal or Fast
speed within the interfaces documentation. It is often set simply with a switch
on the front panel of the interface but in some cases, i.e. the Studio 5, this
setting is switched in software. Instill other cases, i.e. the Studio 4, the setting
has to be made in both software AND the front panel.
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S@ Windows

You must make sure the proper drivers are installed for your MIDI interface

If you are running a Windows system then you simply need to have installed the
correct drivers for your MIDI interface. It is also generally a good idea to make sure
that you have the latest drivers since improvements and bugfixes are made to these
drivers all the time. Once you have the answers to these questions, proceed through
the following steps:

Windows users can skip over the next section and proceed to the following
section on page 22, "Check MIDI Thru".

‘: MacOS

1. Open File -> Preferences

Select Preferences from LOGIC's main File menu. The window you now see
should look like this:
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| Communication Euilt-in LOGIC MIG] Drivers in use "l
E FModern Port |:| Printer Port

o v

[ ]check far MTP

(<] MTP Cable Made

|:| Fast Speed

|:| FowerBook Bug Fix rode

|:| RFeleaze Modern and Printer Port in Background if Stopped
E Stop and Feleaze Ports while printing

|:| HMIC Machine Control uses old Fostex Format instead of MG
E External Stop ends Record Made

|:| Ignore Saved Play Status

E Use 4pple MICI Manager if available

[ JUse OMS if available

E Use AUTOLINE with SoundDiver or SoundSur fer if awailable
|:| dllow Song Position Pointer while playing
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2. Activate the Port(s) corresponding to the port your interface is connected to

If your interface is connected to the Modem port then check the box to the
left of Modem Port. If your interface is connected to the Printer Port check
the box to the left of Printer Port.

N O T E If you are using OMS you can simply activate that option and skip

ﬁ steps 3 and 4

N O T E When the Check for MTP option is checked, the options set in the
next 2 steps will be set automatically - at least if all the following criteria is
met:

>

¢ The interface is connected and turned on,
e The interface has been configured properly,

e The interface is a Midi Time Piece or MTP compatible interface. (Essen-
tially, this covers all multi-port interfaces)

¢ The interface is NOT a Studio 5. Although the Studio 5 is a MTP compatible
interface, it does not respond as one over the serial cable like all other
MTP compatible interfaces.

If the Check for MTP option is enabled, you will be unable to perform steps 3 and 4
manually. If you wish to bypass this feature for some reason (for example, setting it
up to use with a Studio 5 that is functioning as an MTP compatible interface) and
make your settings manually, you must first de-select the Check for MTP option

3. Activate the MTP Cable Mode option if appropriate

If you are using a MIDI Time Piece or MIDI Time Piece compatible interface
then make sure MTP Cable Mode is enabled for the Port(s) you activated in
step 2. As just described, this option may already be on as a result of the
Check for MTP option being enabled.

4. If you have enabled Fast Speed on your interface, make sure that option is
enabled here as well

Once again, if the Check for MTP option is on, this feature should already be
set correctly - as long as the above criteria was met.
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TIP You can use the the Check for MTP option as a way to check that your
MTP compatible interface is properly connected and "being seen" by Logic.
Under the port to which your interface is connected:

Disable "Check for MTP"

Disable "MTP Cable Mode"

Disable "Fast Speed"

Enable "Check for MTP"

e Disable, then Enable the Port ( Modem or Printer )

When you enabled the Port, MTP Cable Mode should come on automatically as
should Fast Speed, if that is how it is set on your interface.

5. Close the Preferences Window

That's It! LOGIC should now be setup to properly "talk" to your MIDI interface. Let's
run through the following tests to see if things are now working as they should be.

Check MIDI Thru

1. Open Arrange and Transport Windows

This is the state that LOGIC opens too, but if for some reason you're not sure
that these are the two windows that are open, close all windows, then choose

Windows -> Arrange | Transport

2. Select the MIDI Thru channel and Port

The term "MIDI Thru" refers to where incoming MIDI data is going to be
directed after it passes thru the sequencer. In Logic, this path is determined
by the Instrument that is assigned to the currently selected Track.

When Logic boots, it creates a default set of these Instruments and automat-
ically assigns some of them to a few of the default tracks. If you're using a
standard interface, you may be able to simply select one of these default
tracks to test MIDI thru. Otherwise, you will have to assign an appropriate
Instrument to the selected track.

(Don't fret if this doesn't make sense to you right now. Remember — this is
just a Quick Start chapter. This bit of theory was just thrown in to give you
some idea of what we're doing in this step)
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“ MacOS

If your interface is connected to the

Modem port, select the Track that says
1 Piano 1. If your interface is . FEE 2 Fingered Bs.
connected to the Printer Port, click-
hold your mouse on any track and . = 3 HonkyTonkPno.
choose GM Device Printer 1 Piano 1
from the Instrument List menu that ; MM 4 E. Pianol

pops up.

If you chose to use OMS when asked the first time you booted Logic AND you
are still using OMS, then select a track that contains an Instrument corre-
spondsing to one of your OMS Instruments

‘ﬁ Windows

Select the track that says 7 Grand Piano 1

3. Check for MIDI Activity

Logic's Transport window contains a handy MIDI activity meter that makes it

easy to see if MIDI data is coming in and/or leaving the program. It is located n
in the upper right hand corner of the window and looks like this when there

is no data present:

=[=[ClAl —Tx1l
@y oy G e | 4
EEEEEN IERER

When there is incoming and outgoing MIDI data it looks like this:

|.IMLEL| 01:.00:00:00.00 [[&)| 12000000 | 4/ 4]+ & F4 |
"1 1 1 1 1| 452214 Aells 1 F4 65
| o1t 1@ T Untitle
elsiolal < 0 §l.tesc I
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Your MIDI interface also probably has LED indicators which will help us to
determine if data is travelling the route it's supposed to.

When you strike a note on your controller device i.e., the MIDI keyboard or
other device from which your are entering MIDI data, the following events
should occur:

e The MIDI Activity meter should register data going in and out
e Both the In and Output lights of your MIDI interface should light up

If you are using a generic "single port" MIDI interface, then you may skip to the next
section concerning checking that Pan and Volume changes are working properly. If
you are using Logic Audio Windows and are not getting output, or the output is
going only to your internal sound card, then DO NOT skip the following section.

4. Set LOGIC's Multi-Instrument to address a specific output of your Multi-Port
interface

"_ MacOS

If you are using a multi-port interface, and you've proceeded to this step
succesfully, then you may now be wondering why all of the output lights are
lighting on your MIDI interface, and perhaps as a result, why all or many of
your devices are responding with a cacophony of sound. This is happening
because the default Instrument " that we have selected is setup by default for
a standard, single port interface. When this is used with a multi-port inter-
face, data is sent to All outputs.

To change this so that the Instrument is only addressing a single port:
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¢ Double Click on the Instrument's name in the track window, i.e. on the word
Piano

This will open up the Environment Window and look something like this:

IEDE Untitled Environment g
Mew Edit View Options|

| Click Here

W™, %
MIDI Instr. '-']
= GIM Device Mod (L P R v R R i R R
(Sub Channel ) FMChaZ MCha3 MChad MCha3S MMChad M Cha
By i
Praf] + B LILIL b=
Kol |:| 127 La1L:-2 Drumz Mapped
F'an|:| il ]
Tranzpose
Melocity
Lim C-2 GB
YLlim H 12? rrm'rnﬂ" rrm'rnﬂ" rrm'rnﬂ" Irm'rnﬂ" rrm'rnﬂ" rrm'rnﬂ" |1'm'|1111
Crelay FChal PFPChaZ PCha3 PChad PCha3 PChat F'I:hal
Mo Seq Trp |:| I&P -
Mo Reset |:| ==
Auto =0 (= | =
? 1@ [ 14 E

If you are using the Printer port, The GM Device Printer object will be selected
alternatively.

The object with 16 buttons on it is called a Multi-Instrument.

e Click once with the mouse on the little telephone "modem port" icon (if
you're using Modem Port) or the little "printer port" icon (if you're using the
Printer Port)

The result of this should be that none of the 16 little "buttons" on this object
are selected.
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Now turn your attention to the box in the left hand column
which contains multiple settings and parameters. The box, |=Jv-1080
called the Instrument Parameter Box, will have the name | {Multi Instr.}
GM Device Modem or GM Device Printer at its top (the one ||l "] frmar]
in the picture has been renamed to “JV-1080") and the
word Multi-Inst written in parentheses below that. The .

line that starts out with the letters Cha is where the Port '
and Channel settings are made for the selected instrument.

Click-hold your mouse directly on the '0' character in the ‘MO0’ or 'P0’ entry
and change it's value by dragging your mouse up or down.

The number you choose determines which output of your MIDI interface this
LOGIC instrument will address. Set it to match to the output to which the
MIDI instrument you want to address is attached.

These letters, you may have already deduced, refer to "Modem" and
"Printer" and must be set to match the physical port your MIDI interface is

& W ARNIN G Be careful not to change the "M" to a "P" or vice versa.

set to. If you accidentally change the value, be sure to change them back to
their correct setting.

You should also be careful NOT to change the value after the "/" symbol
which should now read All.

E Windows

If you have an internal sound card and you are not getting MIDI output, it is
likely that the default instrument is currently set to address the on-board
sounds of the card instead of the MIDI output driver. To change the output
driver of the default Instrument:
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¢ Double Click on the Instrument's name in the track window, i.e. on the word

Piano

This will open up the Environment Window and look something like this:

= [aM Device
[Multi Instr_)

lzan 'EE'
Cha All

The object with 16 buttons on it is called a Multi-Instrument.

5y’ B < -3

Orums Mapped

e Click once with the mouse on the little MIDI port icon in the top border of

the Multi-Instrument.

The result of this should be that none of the 16 little "buttons" on this object

are selected as follows:

Now turn your attention to the box in the left hand column which contains

multiple settings and parameters. The box, called the Instrument Parameter
Box, will have the name GM Device or at its top. The text Multi-Instr written
in parentheses below that. As you move down a few lines you will see an the
line where the output driver for this Multi-instrument is selected. Itis the line
just below the line that starts out with the letters Cha. The actual text varies
based on the drivers in your system, but it may contain the text "MIDI Synth"

or "MIDI Out".
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If you click-hold directly on this text, a flip-menu should pop up which lists all
MIDI output drivers currently installed in your system. Select the driver which
identifies the MIDI output you wish to address. (you may need to consult your
MIDIl interface's documentation documentation if the name of the driver does
not clearly identify the device output..)

Ok, that's it. When you now perform the check as per Step 3, you should see the
proper output light on your MIDI interface light up, and you should hear the corre-
sponding MIDI instrument play. Close the Environment Window and move on to the
next section.

Logic Audio Guidebook 1-28



1.2 Program Change Response Check

Now that Logic is communicating with your MIDI interface
correctly, we'll check to see that the MIDI device at the recieving  how to:

end is responding normally to Program Change messages.

e test that
Program
change
messagesare
being sent

N O T E Program Change messages are a special class and received

different patches on a MIDI device. Only the oldest of

ﬁ of MIDI message which allow you to remotely call up properly

MIDI devices do not respond to this message but many  * select

devices allow you to disable/enable the reception of the this patchesfrom

message. You must make sure that the device being tested is set
up properly to receive these messages before proceeding.

1.

the Arrange
window

Find the Instrument Parameter Box

The Instrument Parameter box is displayed in the column
that runs along the left side of the Arrange Window. The
column contains three separate boxes. The Instrument
Parameter box is the one below the box that contains a
series of tool icons.

= [Multi Instr.] |
[Multi Instr ]

leon IEIBI
Cha All
.pe MIDI Dot (2307 |
Prg ] * 1]|
wol [

If the column is not visible, select Arrange Window ->
100 | Options -> Parameters.

If the column is visible, but you don't see all the Parameters in the box such as
in the graphic below, then click once on the small triangle in the upper left
corner of the box.

If you can't see all of the Parameter box because it is extending outside of the
view of the window try either enlarging the window or clicking the on the
triangle in the first parameter box. This will minimize that box and make
more vertical space available for the Instrument Parameter box.
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2. Enable the Program Change box

Towards the middle of the box you should see a line that
starts with the letters "Prg" which is an abbreviation for || = (Multi Instr.]
"Program". Click in the box to the right of those letters. [Multi Instr_] ;

This will enable the transmission of program changes for

that Instrument. lzan L]
Cha All
3. Change the Program Change value SR ]

The number to the far right of "Prg" is the current
program change value. You can change by: val 100

* click dragging it up and down

* double clicking it to open a text entry box, typing in a value, then hitting
"Return" or "Enter"

As you change the value, the sound you hear when you play your controller
keyboard should change. You should also be able to see the patch changing
on the receiving MIDI device. If this is not functioning, watch your interface
as you are changing the Program value. The corresponding output light
should come on everytime you change the number. If it doesn’t, then double
check that you have checked the box to the right of “Prg” as previously
described. If the output does light, then the problem is with the receiving
MIDI device. Review the instructions for that device to make sure it is set up
properly to respond to these messages.
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1.3 Record your first MIDI track

Now let’s check to see that Logic can record and playback MIDI

properly. how to:
e test that
1. Select the track Program
In the Arrange window, make sure you still have the track change
selected that we selected in the previous section messagesare
being sent
and received
2. GotoBar1 properly
Make sure you are at Bar 1 by clicking once on the Stop o select
button on the Transport. It looks like this: patches from
the Arrange
3. Start Recording window

Click the Record button on the Transport and proceed to
play anything you wish.

Click the "Stop" button again when you are through.

There should now be a rectangular object in the main, grey area of the
Arrange window, just to the right of the selected track.

Play back the results

Go back to bar 1 and click the play button on the Transport window n
You should now hear your performance played back to you.
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1.4 Volume and Pan Check

As a final check of your MIDI system, let’s test that MIDI Volume

and Pan messages are doing what they’re supposed to do. how to:
. : . e testthatP
To make this easy, we'll start by turning on Logic’s Cycle Mode. ae:d V;u,::
This will cause Logic to continuously repeat the section you just messagesare
recorded. being sent
and recieved
properly
To enable Cycle Mode:
. . . . e adjust
1. Click the button on the Transport with circular icon 30{3:ne/pan
2. Set the Start and End points to Cycle from Instru-
Adjust the boundaries by click dragging the lower left and ment Param-
. . . - eter Box in
right hand corners of the highlighted poriton of the Bar Arrange
ruler that runs along the top of the Arrange window. Window
e make the
Transport
i play a select
To Adjust Volume and Pan from the Instrument Parameter section
box: repeatedly
. . . (Cycle Mode)
1. Find the Volume and Pan settings in the Instrument Param-

eter box

The Volume and Pan settings are located just below the
Program Change setting in the Instrument Parameter box. They are denoted
as Vol and Pan respectively.

Enable Volume and Pan

Click the check box to the right of Vol and Pan
Start the sequence playing

Adjust the values for Vol and Pan

You adjust the values just as you did for the Program Change setting earlier.
If everything is working properly, you should hear the effect of your changes
immediately.

If this is not functioning, watch your interface as you change the values. The corre-
sponding output light should come on everytime you change the number. If it
doesn’t, then double check that you have checked the boxes to the right of Vol and
Pan as previously described. If the output does light, then the problem is with the
receiving MIDI device. Review the instructions for that device to make sure it is set
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up properly to respond to these messages.
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1.5 Audio System Check

Now let’s run through a quick check of your Audio system. In the

process you'll learn where to tell Logic Audio what hardware how to:
you're using, how to select the desired audio input, and how to
record audio. * set Logic
Audio’s Pref-
1. Open the Audio Extensions window f;i;criz:?h
Logic Audio supports various types of audio hardware so the your audio
first task is to tell Logic Audio what system you're using. this hardware
is done in the Audio Extensions window. To open this o select and
window, choose: File -> Preferences -> Audio Extensions Audio track
menu | tab
e record
. . enable an
N O T E The Preferences and Song Settings windows audio track

each have a flip menu bar at the top of the window.
Click hold on this bar to access the various categories of ~ * select the

options. In Windows, this flip menu is replaced by the dhztlfee
" " . . . Audio input
common "tabs" used in many Windows95 applications. for
recording(Cy
cle Mode)

2. Select the hardware option that corresponds to the system
you're using
Under normal circumstances, Logic Audio automatically recognizes the hard-
ware installed in your system and makes the necessary settings in this
window. If for some reason that automatic system has failed, select the box
to the left of the hardware that you own. Deselect any boxes that are checked
next to hardware you don’t own or don’t wish to use currently.

In the MacOS example below, Logic Audio is setup to use a TDM capable DAE
system (such as Pro Tools Ill), and an AudioWerk8 card. There are other
settings here that will be covered later when necessary.

E Windows Only

If you're using an MME compatible sound card, then select the option marked
PC AV. You must then select both the input and output driver that corre-
sponds to your card in the flip menu selection boxes provided. For now,
ignore the Force Half Duplex, Use Old 2.5 Driver Model and the Delay settings
boxes.
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Quick start
‘E and ‘__

If you had to change the system that Logic Audio will use in this window, you
will have to restart the program before continuing.

3. Select an audio track

An "audio track” is any track in the Arrange - == Audio 1
window which has an Audio object assigned

to it. When you first load Logic Audio, the 5 i Audio 2
first 4 - 8 tracks (depending on your system), E

will already be set up in this way. Select the z . E audio 3

audio track assigned to Audio 1 and proceed
to the next step.

4 0 Bea Audio 4

4. Select the correct Input

Before record enabling the track, you should check that the
input source for the Audio object matches the input to which
you are feeding signal. On systems that allow for this, the input
is selected in the second box above the fader knob on the Audio
object under the figure “1/0"”. To see the Audio Object: double-
click on the track, right where it says Audio 1.

This should open up what is called the Environment window. The Audio
Object is the the object that looks like a fader strip.

If you don’t have this option, it simply means that you have only two inputs,
or that your inputs are “hardwired”, i.e., input 1 always goes to 1, input 2 to
2, etc.

If you have only two inputs, then input 1 feeds all the odd numbered tracks
and input 2 feeds all the even numbered tracks.

5. Record Enable the Track
To record enable the audio track either:

e Click the Audio object Rec button or,
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¢ Click the record enable button on the track

. When you Record enable a track for the first
¢ AF=2 Audio 1 ; i : :
'ﬂ‘..;'—l time, a file selector box like the one below will
open automatically:

This window is essentially asking "where do you want the audio file you are
about to create stored on your hard drive and what do you want it named?"

This procedure is generally referred to as "setting the Record Path". You only
have to do this once. The program will then continue to use this record path
until you decide to set a new one.

Once the audio object is record enabled, the level meters on the audio object
should respond to incoming signal. If they don’t, check then double check
that all of the hardware connections are correct and intact.

. Start Recording

Once you're ready to perform, hit the Record @ button on the Transport,

just as we did previously for MIDI recording. When Logic Audio begins
recording you should see the following window pop up .

The progress bar and time counter keep you informed of the remaining
recording time. The time is determined either by the Maximum Recording
Time value you have pre-defined or, ( if you have disabled that option) the
available drive space.

. Stop Recording

When you've finished recording, hit the Stop [E button on the transport

or your computer’s Enter key. If everything is working properly, a progress bar
window will show up in the upper left hand corner of your screen which says
Creating Overview. \When it is finished, you should see a rectangular object

with a waveform display in the main part of the Arrange window.

. Playback the recording
Click the Stop button (or Enter key) again. This should return you to bar 1 of

the song. Now hit the Play [B button on the Transport (or your

computer’s numerical “0"” key. You should now hear the material you just
recorded. If you don’t, try disabling the Record Enable button and trying
again. If you still don’t hear anything, run through these steps again very care-
fully to try and trace the source of the trouble.




Conclusion

If you've made it successfully to this point, then the basic components of your system
are and running, and you're ready to begin peeling back more of the layers that
separate you from the proficient Logic Audio user we hope you'll be by the time you
finish this guidebook. If you ever get stuck along the way, or your system seems to
be failing, running through the relevant steps in this chapter again may help you to
isolate where the trouble is.
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MIDI Setup and Configuration

What You Will Learn

In this section you will learn how to configure Logic to match your MIDI studio. You
will see how to get Logic to "listen" to your MIDI controllers and to "talk" to your
MIDI sound devices, effects processors and other MIDI "listeners". You will also learn
how to get Logic to: display program names - select the correct program bank - work
with mapped MIDI devices like drum synths - communicate with internal devices like
SampleCell, WaveMaker, QuickTime and Morningstar. Then you will learn about
Logic's on-screen MIDI mixing console. Finally, you will learn how to create a Song
template called "Autoload” so that whenever you start Logic it will be optimally
configured to your MIDI studio and working style.

The information is organized into the following sections:

@ Preliminary Steps

(i Environment Basics

(@ Configuring Multi-Instruments

(@ Configuring Mapped Instruments
(@ MIDI Input Handling

(@ Talking to Internal Devices

(@ Working with OMS

(@ MIDI Mixing

(i Mix Automation
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2.1 Preliminary Steps

Logic's Default Song

For what follows, it will be most convenient to work with the how to:
blank "default" Song that Logic presents you with when you open Logic's
start Logic for the first time. To make sure you've got this song default Song

open, hold the:
® save your

song

‘:. Mac — Option key E Windows — no key needed

while choosing "New" from Logic's "File" menu. (If you get a dialog that asks you
to close currently open songs, choose “Close”) You should also take the time to fill
out the MIDI Studio Inventory sheet you'll find in an Appendix at the end of this
guidebook. Having that filled out and on hand will make the following exercises
easier to complete.

Saving your Song

It's always a good idea to save a Song when you first create it then to save any
changes at regular intervals during your progress.

To save the default Song select: File -> Save as

When the standard dialog box opens, type in the file name, choose a location and
press the Return key. (Choose a name that will make it easy to recall what it is for
such as "JumpStart” or "JS". Later in the manual, will discuss how you can make this
"template song" load automatically when you boot the program.)

N O T E The reason we used Save as in the above procedure is that Logic's
Save command is disabled when you've first created a song or after you've
just saved it—i.e. there must be "new" information for Logic to save. Also,
after you've saved a Song once, you will not have to give it a name and loca-
tion each time you save it—just choosing Save from the File menu or using
the Save key command

will automatically do the job.

‘:, Mac Command + S E Windows - Control + S
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2.2 Environment Basics

The Environment is one of Logic's most powerful features. It can

also be confusing—entire books have been written about it—  how to:
but the basics you will need to configure Logic to your MIDI

studio are quite simple and easy to understand. A little atten- ~* createan
tion spent on the details of matching Logic to your MIDI studio Ll

is well worth the effort. <E>bJ<_%ct in the
nvironment

The first thing to understand about the Environment is that all  * find the
MIDI data starts and ends there—all messages pass through the 'P”St'“mf"t
Environment on their way into and out of Logic. From the Envi- Bz;ame er

ronment they get sent to Logic's Arrange window for recording
and from the Arrange window they get sent back to the Environ- ¢ protect the

ment for routing to the desired MIDI device. You can find out Environ-
more about the Environment and its powerful features in your ment from
Logic manual and the Environment guide that comes along with accidental
it, but in this chapter we're primarily concerned with getting alterations
MIDI messages in and out of Logic. S (MR Gy
the param-

. . eter sections
Beginning Setup to the left of
When you open Logic's default Song, what you see is Logic's most
Arrange window and a floating Transport window. We'll discuss windows
the Arrange and Transport windows in more detail in the + decide what
sections to follow, but right now let's get on with the business of Environ-
customizing Logic's Environment. ment object

to use for
each of your

To start the process of matching the Environment to your MIDI

i i i - MIDI devices.
studio, open the Environment window by selecting : CEMHEES

e Windows -> Open Environment

When the Environment window opens, move and resize it as necessary to fit your
screen.

Controlling the various view options in the Environment

Before we explore the Environment, lets make sure we have the same view. The Envi-
ronment window's "View" menu contains a number of items, each of which may or
may not have a dot (Mac) or checkmark (Windows ) to its left. The marking indicates
that the item is active (turned on).
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To set up our view:

1. Be sure that Protect Cabling/Positions is inactive
We need to deactivate this option in order to make changes and additions to
the Environment. Once your Environment is configured, it's a good idea to
protect it by reactivating this option.

2. Be sure that Parameters is active

This makes the Parameters section at the left side of the Environment window
visible. We will use the little boxes and menus in this section to make many
settings but after your Environment is set up, you may want to de-activate this
option to save screen space.

Options
<3
fromare -
FIDI Instr. L = | [ | &
T === Egt

Mapped Instrurnent

o = | R

= [ nstrument
i Instrument)

12| (| (=) ]

Fulti Instrurment

The Environment Layers

Logic divides the Environment into layers—you can think of these
as sub-windows of the Environment window. The box towards [ [| = Instrument
the top of the left column with the name MIDI Instr. in it is a flip- | || Llnstrument
up menu called the Layers menu. This is where you select which
layer to view. Don’t get confused — there is always just one Envi-
ronment. The purpose of the layers is simply to keep things from
getting too cluttered. Also, the layer an object is on has no affect
on its function.
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There's a special layer called the "Global Objects" layer which we're going to use in
setting up our Environment.

To select this layer choose: Environment -> Layers menu -> Global Objects

The Global Objects layer has a special property: any objects in this layer will show up
in all other layers.

Instrument Objects

The first step in matching the Environment to your MIDI studio will be to create
objects which will talk to and represent each of your listening MIDI devices—a sepa-
rate object for each device. These objects are the centerpiece of your Environment
and having them available on all layers will be very handy in the future.

The Environment objects we'll use for the MIDI devices in your studio are generally
referred to as "Instrument" objects. There are three different types:

e the Single Instrument
e the Multi-Instrument

e the Mapped Instrument

In most cases, you will use the Multi-Instrument for your regular MIDI synth devices.
This is for two basic reasons: A Multi-instrument can address multiple channels of a
multi-timbral device and; it can store multiple banks of patch names, allowing you to
access your patches by name instead of just by number. One exception would be the
choice for drum-type synths which "map" a different sound (rather than pitch) to
each MIDI note. The Mapped Instrument is ideally suited for that type of MIDI device.

Creating Instrument Objects

You must now decide which MIDI devices you need Environment objects for. That
means it's time to consult your MIDI Studio Inventory. The important column is the
"Listen Chans" column. You will want an Environment object for each item (i.e. row)
where there is an entry in the "Listen Chans" column. These are the MIDI devices in
your studio that receive data (i.e. the "listeners" in your studio).

Creating an instrument object in the Environment is simple:

1. Choose Environment ->New -> Instrument | Multi Instrument | Mapped Instru-
ment

(remember, the slashes, "I", indicate alternatives to choose from)
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2. Name the Instrument via the
Parameter Box

A

To the
pointing either to the right or downward—when
it is pointing right, the box is minimized .

Here's how it's done:

1.

Rename the object by clicking on
its name at the top of its Param-
eter Box and typing in a name
that will help you remember the
listening MIDI device.

Cha MB /A1l

F'r'g|:| + §]

vol | 1688
Fan |:| b

N O T E An Environment object's Instrument Parameter Box is displayed
in the Environment window's parameter settings column whenever that
Environment object is selected. The one thing that is always visible is the
object's name. The rest of its parameters will be hidden if the Parameter Box

has been "minimized".

= J¥-1080 1
%—aéh Channel)

lzon
Cha =

Prg [ = 0
val [ 100
Pan [ 6
Transpose
Melocity
Lim C-2 ©G&
MLirn o 1z7
Crelay
Mo Seq Trp |
Mo Reset W
Auto

1

11 Instr.)

left of the object's name is a triangle W— 1080 |

When it is pointing down, all parameters are visible. Click the
triangle to switch between these two views (minimized and
expanded).

After you've created an instrument object for one of the
listening devices in your studio, follow the instructions in the
following sections for that particular instrument type (i.e.
Multi-Instrument or Mapped Instrument).

Cleaning up the Instrument Menu

Logic’s default song contains a basic set of Environment
objects which you really don’t need once you’ve configured
the Environment to match your MIDI system. To keep these
objects from causing any confusion and needlessly cluttering
the Instrument menu, let’s delete them now before moving
on.

Go to the Environment layer named MIDI Instr.
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2. Select Environment ->Edit ->Select All
Select Environment ->Edit ->Clear
4. Repeat this process for the Layer named MIDI Faders

This removes unneeded objects from your Environment since you have
already created Instruments and mixers matching your Studio.

=
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2.3 Configuring Multi-Instruments

The Multi-Instrument is really 16 instruments rolled into one—

one instrument for each MIDI channel. The little squares with  how to:
numbers (1-16) in them correspond to these 16 "sub-channels".

Clicking one of these sub-channels activates its corresponding ~ * accessall
Instrument Parameter Box channelsofa

multi-
timbral
instrument
1. Select the whole Multi-Instrument o connect a
If you click on the Multi-Instrument outside of the Multi-Instru-
numbered squares, i.e., in the top border or on its name, ment to the
you will select the Multi-Instrument as a whole and its corre- right MIDI
sponding Parameter Box. This is where you will globally set port
the output Port for the Multi-Instrument which in turn e select icons
governs the output port for all of the sub-channels. i
Multi-Instru-
ment and its

= v-1080
i Multi Instr.)

sub-channels

¢ choose
programs by

Cha MB SA11 . name rather

Pra[ ] = B Click Here than by

Vo D 188 number

Pan |:| 6 e enter and
editprogram
names

E 2. Select the correct Output Port 7 R et

send the

correct bank
_ select
E Windows messages

; il The port setting is changed by click-

= [Multi Instr.) | holding in the space just below the the word Cha in the
(Multi Instr.] Parameter Box. If you click-hold in the correct spot, a flip
e &2 | menu pops up with the currently available MIDI drivers.

—pe MO Ot [220] |
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Choose the one that corresponds to the MIDI output to which the Instrument
you are creating a Multi for is connected.

‘:_ Mac

The current port setting ("MO0" for a newly created Multi-Instrument) is indi-
cated next to the word Cha in the Parameter Box. In this case the "M" stands
for "Modem Port" and the "0" stands for "output 0" which is an established
way of saying "All Outputs" If MO is not the correct port for this Multi-Instru-
ment, click and hold on the Port Indicator and scroll it until the correct port
comes up.

1. Select the correct output Channel

"_ Mac

The number after the slash indicates the MIDI channel output.

ﬁ Windows

The number after the abbreviation Cha is where you select the output
channel for the object.

“_ All Systems E

For "normal" single channel type
Instruments, you would set this to the -
desired value. In the case of a Multi- = [Multi Inzstr_]
Instrument however, DO NOT change [Multi Instr_)
the channel setting. Instead, leave it o
set to "ALL". The reason, is that in this '
special case, the channel output is
determined by which of sub-channels is
selected in the Arrange window. If you
were to change this to a specific value,
all the sub-channels would be forced
onto that channel ("re-channelized" if
you will), thus defeating the purpose
of the Multi-Instrument.

Frg D
ol [] 100
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2. Hide the global Multi-Instrument icon from the Instrument menu

Generally, there is no need for theglobal Multi-instru-
ment to be accessible from the Arrange Window's = [(Multi Instr.]
Instrument menu, so, for the sake of saving space, we'll Multi s g
"hide" it from that menu. (Typically, you will be
assigning the sub-channels of the Multi-Instrument to
Arrange window tracks and it is unlikely that you will

want to assign the whole Multi-Instrument to a track.) ~pe MIDIDut [330]
To hide an Instrument, simply uncheck the box nextto fJrrg 0 2 0
the word "lcon" in the Multi-Instrument's Parameter

Box ol [] 100

3. Enable the desired number of sub-channels

You must "enable" a sub-channel before it will appear in
el the Instrument Menu in the Arrange window. You do this
Azl al ] by simply clicking the numbered square that corresponds
seel 75 Lo the channel you wish to enable. Set up sub-channels
=1 for each of the MIDI channels on which the associated
MIDI device is listening. DO NOT attempt to choose a port
= === or channel for the sub-channel. The port is set by the
(MultiInstr.) whole Multi-Instrument and the channel is the same as
the sub-channel number. This cannot be changed.

4. Choose an icon for the sub-channel

You choose an icon for the Multi-Instrument or any sub-channel by clicking
on the icon to the right of the Instrument menu checkbox. The main purpose
for the icons is to make the object easier to recognize on the Arrange
window's track list and Instrument menu so choose an icon (s) that best repre-
sents the listening MIDI device. Logic also has a preference for ordering the
Instrument menu by icon—a option we recommend you enable.

5. Set the other parameters

Below the channel settings are parameters for controlling the program,
volume, pan, transpose, velocity adjustment, pitch & velocity input filter and
playback MIDI delay. If you know that you want particular settings, go ahead
and fill them in. Otherwise, leave them alone—you can always change them
later (even from the Arrange window) if the need arises.
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6. Enabling program selection. .

= [Multi Instr.]
[Multi Instr_]

Izon | ﬁ

Cha All
pre MWD ot 330

The one parameter you DO want to set is the "Prg"
checkbox. This will allow you to select programs by name
and see their names in the Arrange window's track list.
To enable it, ensure the checkbox is X'd.

A

Program Names and Bank Select messages

Once you have set up the Multi-Instrument and its sub-channels, you're ready to deal
with program names and banks. This is one of the main advantages of using Multi-
Instruments—they can store up to 15 banks of program names (128 per bank) to
match the programs in your MIDI device. Once these are set up, the names of
selected programs will appear in the Arrange window's track list (if the sub-channel's
"Prg" checkbox is checked) and you will be able to select programs by name in
several convenient ways.

wol

100

N O TE Setting sub-channels has no affect on their
intended MIDI device listeners—these devices still need to be enabled and
set up to respond to the standard MIDI messages.

Entering program names

You enter program names in the window which opens up when you double click the
Multi-Instrument.

=@ JU-1080
Cewice Name Short Dewice Name
J¥-1050
[ * Mo Bank specified. Hames of Bank 0 used) || Bank Messzage: Control 32
Prograrn Mames
Organi dcoustic Bs| Strings Soprano Sa| Square was| lce Rain | Tinkl
Piano2 OrganZ Fingered B:| Slow String Alto Sax Saw Wave | Soundtrack | Agogo
Piano3 Organd Picked Bs. | Syn. 3tring| Tenor Sax | Syn. Callio|| Crystal Sieel
HonkyTonk | Church Org| Fretless Bs| Syn. String| Baritone S:| Chiffer Lea| Atmosphere| Wood|
E. Pianol | Reed Organ | Slap Bass 1| Choir &ahs [ Oboe Charang EBrightness | Taiko
E. Piano2 |Accordion F| Slap Bass Z[ Yoice Oohs | English Hor| Solo Yox Goblin Melo
Harpsichor| Harmonica | Synth Bass | Syn¥ox Baszszoon Sth Saw 'w:| Echo Drops| Synth
Clawinet Bandneon | Synth Bass | OrchestraH| Clarinet Bazz&Llead | Star Theme| Rever
Celesta Mylonstr. G ¥iolin Trumpet Piccolo Fantaszia Sitar Gt Fre
Glockenspie| Steelstr. Gt Yiola Trombone | Flute warm Pad | Banjo Breat
Music Box | Jazz G1. Cello Tuba Recorder | Poluysynth | Shamizen | Seash
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Initially, this window contains one bank of names which are set by default to the GM
standard program names. You can change a program name by double-clicking on it
and typing in a new name, but this can become tedious for inputting long lists of
names. Fortunately, there are several alternatives presented in the Names menu
which pops-open when you click the downward pointing triangle at the upper far-
right of the window.

Shortcuts for entering program names

There are two convenient ways to work with program names—in any convenient text
editor and in Emagic's Sound Surfer/Diver. The "Cut, Copy & Paste" choices are for
moving name banks (all 128 names at a time) between Logic and any text editor or
Sound Surfer/Diver. The "Update using AutoLink" is for automatically drawing
names from the Sound Surfer/Diver instrument with the same MIDI port and channel
assignment —check your Sound Surfer/Diver manual for details.

Using bank select messages

The pop-up menu to the left of the Names menu is for choosing the type of bank
select message that the Multi-Instrument will send (when a program bank is indi-
cated). If you don't see the name of your particular MIDI device here, try the first few
choices (in top-down order) to see if they work. If not, you will need to delve further
into custom bank select messages—a topic well covered elsewhere in your Logic
documentation.

Initializing and using program name banks

The flip-up menu to the left of the Bank Message menu is the Bank menu. This is

where you set up separate banks of program names. When you create a Multi-Instru-

ment, there is only one bank of names. If your MIDI device has more than one bank,
E use this menu to create additional name banks.

TIP Do not create additional name banks unnecessarily. They use up
memory and may cause confusion.

TIP Logic's support files contains a special song file whose Environment is
stuffed with pre-configured Multi-Instruments for many of the most popular
synths. If you open this Song file, you can then easily Copy/Paste the Multi's
you need from there into the template song you are constructing.
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Accessing Patch Names

Once your Multi-Instrument program names are in place, there are a few different
ways to access them. This is always done from the Arrange window because that's
where MIDI gets routed from your MIDI controller, through the Multi-Instrument
then on to the listening MIDI device.
So, return to the Arrange window and select the first track—the one whose instru-
ment is currently set to "No Output.

To use a sub-channel and select presets by name:

1. Choose the Instrument and desired channel from the Instrument menu
Choose Arrange -> Instrument menu -> sub-channel (for the Device you wish
to "talk to"). The number just after the Instrument name indicates the

channel.
Check the box to the right of Prg in the Instrument Parameter Box.

2. Choose the desired bank

= ¥-1030 1

(Sub Channell W8 solect the desired program bank using the numerical adjacent to
the Prg checkbox. If there is no bank currently selected this posi-
tion will have a little division symbol as a place marker. If there
is only one bank, leave this numerical set to "+".

Transpose

: Fianail

3. Select the desired Program/Patch Piano2

Click & hold on the program number to Piano3
the right of the bank indicator. A menu Honiky TonkPro.

will pop-up from which you can select a E. Pianoi
program by name, OR; T

Click on the name of the Multi-Instrument at the top of the Parameter Box.
This will open up the Multi-Instrument's window and any program name that
you click will be sent to the sub-channel for auditioning. The corresponding
program number will also be set in the Instrument Parameter Box.
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TIP If you hold the Mac — Control + Option; Windows — Control + Alt
keys down and double-click the icon in the Track list, it will open the Multi-
Instrument window

your computer keyboard (up, down, right & left all work) to scroll through
the programs in the current bank. You can even do this while Logic is using

C § TIP Once the instrument window is open, you can use the arrow keys on
the Instrument during playback.
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2.4 Configuring Mapped Instruments

The Mapped Instrument is designed for use with MIDI drum
synthesizers, but it's equally appropriate for any MIDI sound
device that maps each note to a different sound—different
sound effects in a sample bank you've set up, for example. The
primary advantage of the Mapped Instrument is that you can
name each note so that when you're working in one of Logic's
editors, the note is identified by that name instead of by its
pitch.

Mapped Instruments also make it possible to individually assign
a note its own channel and cable output, which allows you to
spread notes among several MIDI devices or Environment
processes.

The first thing that happens when you create a Mapped Instru-
ment is that a new window called the "Mapped Instrument"
window opens up and becomes the active window. This is
where you set up the individual note parameters. Before we use
this window however, let's look at the Mapped Instrument's
parameters.

1. Close the Mapped Instrument window

Close the Mapped Instrument window by clicking the close
box in its upper left hand corner

2. Select the Mapped Instrument
Select the Mapped Instrument by clicking on it.

3. Setits port and channel

You set the port and channel for the Mapped Instrument
just as for a Multi-Instrument (see steps 1 thru 4 under
Configuring Multi-Instruments)

4. Select its icon just as for a Multi-Instrument
See step 6 under Configuring Multi-Instruments.

5. Open the Mapped Instrument window

how to:

open & close
the Mapped
Instrument
window

set the
Mapped
Instruments
parameters

re-map MIDI
notesusing a
Mapped
Instrument

name indi-
vidual notes
to match
your drum
synth

set a velocity
offset for
each note

control the
destination
of individual
notes

control how
notesappear
in a drum
score style

Double-click the Mapped Instrument object in the Environment window to
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open it.

The Mapped Instrument window has a keyboard along its left edge. This is where
you select a note or group of notes for working on. When a note is selected, its name
to the right of the associated key will be reversed (gray letters on a black back-

ground).

Selecting Notes

IOne or more notes can be selected at the
same time in the Mapped Instrument
window. Whenever you make a selection,
you will hear the selected note (assuming
there is a MIDI device listening at the other

]

[ |initialize|

Dutput MNote

[} BB Wr e

i

end). Here are several ways to select notes: g h Ii:g Fo3H
e Click on the Mapped Instrument L CONGA
window's keyboard to select a single g_ OH CONGA
note. MH CONGA
e Shift-click on the Mapped Instrument !— L BONGO
window's keyboard to add another H BONGD
note to the selection. RIDE 2
® (Mac Only) Click & drag along the !— UVIBRA
Mapped Instrument window's CRASH 2
keyboard to "rubberband" select B CcowBELL
groups of consecutive notes. SPLASH
e Play the note you wish to select onyour g THMEB.
MIDI controller keyboard (it doesn't RIDE BELL
make any difference what track is CHINR
selected in the Arrange window) g_ RIDE 1
High TOM
Once you have selected a note or notes, use  [IlllJ— CRASH 1
the mouse to make changes to their param- High TOM
eter settings in the other columns of the Mid TOM 1

Mapped Instrument window.

£

N O T E Any changes you make to a selected note will also apply to all
other selected notes but they will not appear in the Mapped Instrument
window until the note selection is changes.
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Naming notes

High TOM D2l

You can name an individual note by double- !l— CRASH 1 ct2ll

clicking on its name to the right of its key. (When Hiaoh TnN™ |

you do this, the note becomes the only selected Mid TOM 1 ﬁ
note—you can not name multiple notes at the

same time.) BY  Open HH GESL |

Mid ToMm 3 A1

BE - prn HH ri 1

When a Mapped Instrument is created, the notes corresponding to keys D#0 through
D#5 have the standard GM note names. The notes corresponding to the remaining
keys have the ordinary "pitch" names. At the top of the keyboard is a menu named
"Initialize" (the only menu for the Mapped Instrument window) where you can reset
the names for all selected notes. There are only two choices (for names) here: the
standard note names and the GM drum names. Any other names must be entered
manually.

Re-mapping note pitches

Re-mapping a note means setting the pitch that is output to something different
then the pitch that is input. The note will be re-mapped whenever it "passes
through" the Mapped Instrument, i.e. when the Mapped Instrument is the current
thru instrument or, when it is on a track assigned to the Mapped-Instrument. The
output note is set in the Mapped Instrument window's Output Note column. This
column contains both a pitch name and a horizontal bar.

Input MNarme Dutput Mote Melocity Cha Cable [Head RelPos
------- = ] THEE ] T =

L CONGA 1 |=
B) oH congA | DHIEEE | | ol IBase 1 |« i

You can use either to select the output note—the horizontal bar scrolls right and left
while the note name scrolls up and down. You can also double-click the note name
to type in a new value.
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Setting a velocity offset

A Mapped Instrument allows you to add or subtract a set amount of velocity for each
note individually. The velocity offset for each note in the map is set in the Mapped
Instrument window's Velocity column.

Input MNarne Qutput Mote Velozity Cha Cable |[Head Rel.FPos
------- = e aa— TEE— || e =
|| G/ 1| 83 | [jBase 1 |-
1

L CONGA
BlY  od concA | DS ]

The value set here (which is 0 by default) is added to the incoming note's velocity.
The range of possible values is -127 to 127. As with the output note, there is a numer-
ical display as well as a horizontal bar and changes can be made with the mouse or

by typing.
Setting a different channel and output cable for each note

The Mapped Instrument allows you to select both the channel and the output cable
on a note-by-note basis. This means that you can divide the notes among:

e Several channels of a multi-timbral MIDI device

e Several MIDI interface output ports connected by cables from the Mapped
Instrument

e Several Environment processes connected by cables from the Mapped Instru-
ment

A note's output channel is set in the Mapped Instrument window's Cha column by
scrolling or double-clicking with the mouse. A setting of Base means the channel set
in the Mapped Instrument Parameter Box will be used.

A note's cable is set in the Cable column. Mapped Instrument output cables are
numbered counting from the top down and choosing a number higher than the
number of cables results in the note's not coming out anywhere.

The last three columns in the Mapped Instrument window determine how individual
notes are notated in the Score window when a drum-type Score style is used. The
Head column controls what the note head will look like. The Rel.Pos column
measures how many lines (whole numbers) and spaces (halves) the note head will be
above or below the top staff line. The Group column sets which polyphonic voice
the note will be assigned to. (For more details on score styles consult the users Logic
manuals.)
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N O T E All the settings in the Mapped Instrument window apply to the

ﬁ input note.
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2.5 MIDI Input Handling

The "Talk Chans" column of your MIDI Studio Inventory indi-

cates which devices in your setup are MIDI talkers, i.e., those that  how to:
send MIDI data into your MIDI interface. This includes all your _
MIDI controllers—keyboards, hardware fader surfaces, drum * avoid
pads, breath controllers, etc. It might also include MIDI devices doubled

that can send SysEx information about their internal setup— notes

patch dumps, panel settings, etc. * avoid MIDI
feedback
loops

Logic's default Environment setup—the one we're working with
here—listens to all MIDI talkers at the same time and sends the
incoming MIDI data to the one selected track in the Arrange
window. From there it is sent to the Environment object
assigned to that track, and if that object is assigned or is connected to an output port,
the MIDI data is sent back to your MIDI interface. If Logic is recording, the data gets
recorded.

In most cases, this means everything will work smoothly without your doing
anything. If there are any problems, they typically fall into two categories: doubled
notes or MIDI feedback loops.

Avoiding doubled notes

Doubled notes typically result from MIDI devices that are both controllers and sound
devices such as workstations and controller keyboards with built in sounds. If these
devices are connected to Logic as both talkers and listeners while at the same time
"talking to themselves" (Local Control Mode) the result is doubled notes. (In these
situations, doubled notes will only occur when an Arrange window track is selected
whose Instrument is set to the port and channel of the MIDI device.)

The best way to solve a doubled notes problem is to make the MIDI device stop
talking to itself. This is called local control. There is usually a device setting called
"Local" which can be set to "On" or "Off". You always want it set to "Off".

TIP A quick way to check this is to assign Logic's "No Output" Instrument
to the currently selected track. If playing MIDI keyboard still produces a
sound then local is "On".

If you don’t have Local Off control

Some older MIDI devices don't allow you to turn local control off. If you have only
one such device and have created an Instrument for it in the Environment, then Logic
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provides a way to block MIDI "thru" to this Instrument:

1. Choose Arrange -> Options -> MIDI Options
2. Re-define the "no MIDI thru" instrument

Select the Instrument you have set up for this MIDI device from the pop-up
menu labeled "Instrument without MIDI Thru function”.

N O T E If the MIDI device is multi-timbral and you have set up a Multi-
Instrument for it in the Environment, you can only block MIDI thru for one
sub-channel. This is an unlikely scenario however as most offending MIDI
devices are older and not multi-timbral.

If you can't solve your doubled notes problems this way, check the Environment
guide that came with Logic for a more complete set of options.

MIDI feedback loops

MIDI feedback is what happens when a listening MIDI device re-sends the data it
receives. If the Instrument assigned to the currently select ed track can send and
recieve anything played on the track, will be returned and resent ... and returned ...
and resent ... and returned. This is called a MIDI feedback loop.

If you have a MIDI feedback problem on a particular port, you will quickly find out—
the first time you select a track using this port and play a note, you will hear the note
repeating very rapidly. You will also see constant input & output in the MIDI output
section of Logic's Transport window.

The "quick fix" solutions include:

e Select another Arrange window track.

This should be a track assigned to a different Instrument or to "No Output".
This may leave notes "hanging" but it will at least, break the feedback loop.
Of course, what you really want to do is prevent MIDI feedback from
happening. There are several alternatives:

e Stop your MIDI device from resending the data.

Most modern MIDI devices have a setting for this—two common names for
these settings are "MIDI Thru" and "MIDI Echo"

e Set the Environment object for this device as the "Instrument without MIDI
Thru function”

See previous section.
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e Disconnect the MIDI device from your MIDI interface's input port.

This removes the device as a talker in your setup but that's better than MIDI
feedback.

If you can't solve your MIDI feedback problems in any of these ways, check the Envi-
ronment guide that came with Logic for a more complete set of options.
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2.6 Talking to Internal Devices

From the viewpoint of Logic, an "internal device" is any hard-
ware or software MIDI device inside of the same computer that

is running Logic.

Mac examples include: Digidesign's SampleCell card; Kurzweil's
Wavemaker card; or Apple's Quicktime Musical Instruments soft-
ware. On a Windows system, this could be the synth sounds on
your Soundblaster or compatible sound card, or the a sample
card like the Terratec E64.

Dealing with these systems on a Windows system requires no
further knowledge, since their Windows drivers will be acces-
sible in the same way as the drivers for your MIDI interface. On
the Mac however, Emagic has had to include special Environ-
ment ports to accommadate these systems. The rest of this
section therefor applies only to Mac based systems

N O T E If the card or hardware supports it, another

how to:

e get Logic to

communi-
cate with an
internal card
or software

e set up Logic

to use
Apple's
Quicktime
Musical
Instruments

e set up Logic

to access a
SampleCell
card

way to access these internal systems is via OMS. However, if Logic has an
internal port for the object, it is better to use that port. If you need to use
OMS, see the instructions on OMS in the following section, "Working with

OMS (Open Music System)"

To set up Instruments and Mixers that access these special internal ports:

1. Select Environment -> New -> Internal -> Digidesign's SampleCell | Apple

Quicktime | Morningstar Wavemaker | Autolink

N O T E The Autolink port is used to send Sysex data back to SoundDiver.
ﬁ The main purpose for that is if you wanted Diver's edit knobs to update

according to Sysex data recorded in Logic.

S

Create a Multi-Instrument and enable the sub-channels as needed
Cable the Multi-Instrument to the new port object

Choose to "Remove" cables and ports from the resulting dialog box
Create a GM Mixer

See in the following section, "Creating a Virtual Mixer"
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6. Cable the Mixer to the port object
7. Choose to "Remove" cables and ports from the resulting dialog box
You can now access the Instrument just as you would a "normal” MIDI instrument.

TIP A good place to put these internal objects is on the Environment's
"Clicks & Ports" layer since all the real MIDI ports are represented there.

SPECIAL NOTE FOR SAMPLECELL USERS

If you are using Logic Audio Mac with a Sample Cell card, please make sure the follow
settings are made:

In Logic
1. Open File -> Preferences -> Communications Menu
2. Uncheck "Release Modem and Printer Port in Background when stopped"

This ensures that Logic retains hold of the port when switching over the the
Sample Cell applications

3. Check "Release Audio port in background when stopped*

This ensures that Logic allows Sample Cell to use the audio port when
switching over to the Sample Cell software

In Sample Cell

E e Disable all MIDI in/out options in Sample Cell Preferences

Since Logic is talking to Sample Cell directly, SampleCell does not need to
communicate via MIDI. Having these options on can also lead to problems if
Sample Cell tries to access the Port while Logic is using it.

Logic Audio Guidebook 2-62



MIDI Setup and Configuration

2.7 Working with OMS (Open Music System)

This section applies only to Mac based systems

When you boot Logic or Logic Audio for the first time, it checks

to see if OMS is installed. If it detects its presence, it will ask  how to:
whether you want to use it as your MIDI driver. Unless you really .

need to use it (see below) it is probably best to click "Don't Use"  ° decide when
as Logic's own drivers can talk to any existing MIDI interface on to use OMS
the market. Furthermore, Logic's own drivers will communicate o enable Logic
more efficiently as there will be one less "layer" between the to use OMS

program and your interface. _
¢ set Logic up

to switch
There are only three basic situations that require you to auﬁomaﬁ'
run OMS: e
etween
. : M
e You need to send data between two OMS compatible appli- gon?g,?,l%
cations running on the same computer. For example, if you operation
were trying to internally sync Logic and Pro Tools using MIDI ¢ o Logic!
H ® setup LogicC's
Time Code. OMS "map"
e You want run two OMS compatible applications simulta- ;c/(c)n:?aEtr(\:Ci—
neously, such as Logic and Opcode's Galaxy. onment
setup

* You are running multiple Studio 5 MIDI interfaces
connected to a single port

If you meet one of these three criteria, (or simply have a strong personal compulsion
to use OMS), then either select Use when Logic prompts you at startup, or; if you have
already opened the program and chosen Don't Use initially, enable the Use OMS if
available option found in the File -> Preferences -> Communications window.

N O T E All of the following instruction assumes that you have already
read the documentation that came with your OMS software — generally
included with your MIDI interface — and have properly configured and
"made current" and OMS Studio Setup. If you have not done this yet, you
will need to before proceeding.

Once Logic is enabled to use OMS there are two basic ways to go about accessing
your OMS Instruments. The first method is to use specially created Environment
objects which Logic can create for you automatically. These are referred to as "OMS
Equivalents". While this is the most convenient option, the second option is more
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flexible. It uses a global output map to remap instruments based on their "MTP
Style" Environment cable settings. Though you could use a mix of both methods,
they are essentially mutually exclusive, i.e., only one is required. Here are the two
methods described in more detail:

Using OMS Equivalents

When OMS is enabled, anytime you create a default song (by choosing File -> New,
or, if you have an Autoload, by holding the Option key while selecting File -> New)
Logic creates a set of "OMS equivalent" Environment objects and places them in a
special layer of the Environment named "OMS Objects". The objects will be either
multi-instruments or "regular" instruments, depending on how they were defined in
your OMS Studio Setup. These instruments will show up in the Arrange window's
Instrument menu just as any Environment object does. This make it by far the
quickest way to get up and running immediately with access to everything in your
studio. There are however a few limitations.

You still have to get the patch names into the Multi-instruments in some fashion.
You still have to define the proper MIDI bank select message for that MIDI device
All of the sub-channels of the Multi-instruments are generally enabled (if that's the
way that they were defined in your OMS Studio Setup) which, if you have a fair
number of instruments, can lead to an inordinately long and somewhat clumsy
Instrument Menu in the Arrange window. (You can of course go back and "disable"
some of these channels by hiding the icons as described earlier)

Creating new Instruments under OMS

You can create new Instruments in a similar fashion to the way described earlier. The
only difference is in the method used to set the output port. You can directly assign
the outputs of Instruments and Multi-Instruments by click-holding in the space in the
Instrument Parameter Box just below the line containing the Icon. The line defaults
to saying "(OMS Map Used)". A flip-menu will pop up that displays all your OMS
Instruments, as defined in your OMS Studio Setup. Simply select the appropriate
Instrument.

N O T E Unless you use the OMS Output Map option (described next), you
must cable all other object types, i.e., the Mapped Instrument, GM Mixer, the
Metronome, faders, etc, to an Instrument or Multi-Instrument assigned to an
OMS output to enable them to communicate with OMS. In this case, you are
essentially using the Instrument or Multi-Instrument as a port object.

Using the OMS Output Map
As mentioned briefly in the beginning of this seciton, this option allows you to set
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up a global map which routes all output to OMS Instruments based on their Environ-
ment "cable" setting. In other words, you can tell Logic to take the output of a
device defined to, say, Modem Port 3 (M3) and re-map it to a particular OMS Instru-
ment. This approach has some distinct advantages:

e It allows you to easily adapt an Environment that was created w/o OMS to
work with OMS

e It allows you to switch between using OMS and not using OMS with relative
ease.

e It allows you to globally reconfigure Logic to work with a new OMS Studio
Setup — for example, if you were to bring your song files to another studio.
Without using this option, you must reconfigure songs on a song to song basis
rather than globally.

e |t meansthat all of the functionality of the Environment window are available
to you with the same flexibility as when not using OMS.

Configuring the Output Map is relatively painless.

1. Open File ->Preferences -> OMS Output Map Modem | OMS Output Map
Printer

Choose the Printer or Modem option which corresponds to the serial port to
which your interface is connected.

2. Assign Cable outputs to OMS Instruments

In either window you will see three columns of numbered pop-up menus. The
numbers correspond to the modem port numbers. For example, the "0" pop-
up menu is for the "MO0" port, (shorthand for "All Ports"), the "1" pop-up
menu is for the "M1" port, etc. For each of these ports that your MIDI inter-
face uses, select a corresponding OMS Instrument

That's it!

And don't forget, since this is a Preference, the map affects ALL of your songs, not
just the one currently open. That means you are free to open or create a song file
and, when you are using OMS, all output will be re-directed based on its settings.
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2.8 MIDI Mixing

One of the things you'll want to start doing as soon as you begin

making multi-track music with Logic is controlling the mix. In  how to:

the MIDI world, this means sending pan and volume MIDI

messages to your various MIDI sound devices. While you canset ~* createan on-
basic Pan and Volume levels from the Instrument Parameter Box ?free” hm'xer
in the Arrange window, the Environment window provides or each port
various on-screen fader and knob objects which provide a more e set up the

graphic way to perform this function. This section focuses on on-screen
using one of those objects — the GM Mixer. mixer
Creating a Virtual Mixer 0 c0_nne§ctthe
Here are the steps for creating an on-screen mixer for one of xﬁfﬁn;ru_
your Multi-Instruments. Since on-screen mixers get fairly large, ment objects
you probably won't want to put several of them on the Global

Objects layer, so create an empty layer by selecting: * use the on-

. screen mixer
Environment ->Layers menu ->"**Create!**".

and record

the results
This creates a new layer named "(Unnamed)" which you can _
rename by double-clicking on the name. This new layer will at ~* Move Envi-
first look exactly the same as the Global Objects layer, but when ;cl’)r.‘e”c'fsnt
we start adding things to it, they won't appear on the Global befcween
Objects layer or any other layer than their own. layers

Create a GM Mixer

Create Logic's on-screen, 16-channel mixer by selecting:
Environment ->New ->GM Mixer

A large mixer object will appear. (You may need to scroll or resize your Environment
window to see the whole GM Mixer.)

Logic's on-screen GM Mixer has 16 columns—one for each MIDI channel. Each
column has a vertical slider, a mute button, and a stack of four knobs. Below this
array of controls are two rows of numerical controls and two rows of boxes with MIDI
GM preset names in them. To the left of the mixer columns is a "legend” column
containing labels for the controls.

N O T E The names for the four knobs are actually pop-up menus that
ﬁ allow you to define what the knobs actually send.
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The GM Mixer has has only a few parameters to set. Here's how to set them:

G Hixer -

=G Mixer Pri

':GM Mi:-:E:r':' |'lr- |lr- 1 |'lr- 1 |lr- |’-
Chatrus Depthl . . L . 5
|"rr |rr |"r: |rr |rr
Cutoft Fr'equ.l
|"’ |lrr |'lr-r |lrr |”
Fan | A
Mute U_I U_I U_I U_I U_I
Yalurme g g g g g
— | — | — | — | — |
i 2 3 4 3 & T a2 |
Prograrn Fianol | Fianol | Fianal | Fianal | Fianal
Fianoi | Fianoi | Fianod | Fianoi | <

1. Assign the Port

Select a port exactly as you do for any of the Environment's Instrument
objects. The port should be the same as the port you chose for the associated
Multi-Instrument.

2. Select a "base channel” for the mixer.

The "base channel" is the lowest mixer channel and is set in the same way a
channel for any of the Environment's Instrument's channels is set. Typically

you will keep the default setting of "1" but if you select a higher number, the
columns for the lower numbers will disappear making the mixer smaller. (The
"All" setting is the same as "1".)

3. Choose an icon for the mixer
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Select an icon for the mixer as you do for a "normal" instrument. There's
actually a little mixer icon you can use if you wish, but any icon is OK . Leave
the icon checkbox checked so that the mixer can be selected in the Instrument
menu. You will need to do this in the future when you start exploring auto-
mated mixing.

4. Disable/Enable the mixer's legend

Choose whether to have the mixer's legend (described above) visible. Making
it invisible makes the mixer that much smaller but for now, leave it visible as
it helps in setting & remembering what the top four knobs do.

5. (Mac Only) Choose a Style for the mixer.

The default style, "Style 1" is the most "modern looking" but it is also the
slowest to refresh. On slower computers, you may prefer one of the other
two styles. (They're also smaller).

You're done! Your on-screen mixer is set up and ready to use.

To try it out, go to the Arrange window and select or create a track for one of the
sub-channels of the Multi-Instrument corresponding to the mixer. Select a program
and play your MIDI keyboard. Assuming you hear something, return to the Environ-
ment and change the volume and pan settings for the corresponding channel on the
mixer. You should hear the volume and pan changes when you play your MIDI
keyboard again. (If you can do this while still playing your MIDI keyboard, all the
better. If not, just switch back and forth.) You can also try the other controller
knobs. They may or may not have any affect—it depends on the settings and capa-
bilities of the MIDI device receiving the MIDI data.

Connecting your Mixer to the Instrument Parameter Box

There is one enhancement we'll make to this mixer setup and that is to put the mixer
in the MIDI "signal path" between its associated Multi-Instrument and the output
port. This is the first (and only) cabling we'll be doing and it is completely optional.
The advantage of doing this is that any mixer-type data recorded on tracks using the
Prg, Vol or Pan settings in the Instrument Parameter Box for a Multi-Instrument's sub-
channels will be displayed by the mixer. The mixer will therefore, always reflect the
current state of the listening MIDI device (at least to the extent that this was set by
Logic in the first place).
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To re-route this signal path
1. Click-hold the Multi-Instruments's "outlet"

e — Click and hold the mouse on the top outlet of
T ] - the Multi-Instrument. The "outlets" are the
= e s _il ri?h};c-pls/linlti_nlg triangles alg_ng the right edge
== of the Multi-Instrument object.
;;gj ﬂi‘f_a.l ’
R EEN RS RS
JY-1020

2. Cable Multi-Instrument to GM Mixer

Drag the cable that appears into the body of the GM Mixer and release the
mouse button. When you release the mouse button, the cable will remain
"attached" to the GM Mixer and a dialog box will pop-up with three buttons
labeled "Cancel”, "No" and "Remove". Click the "Remove" button.

Cable and Channel Port is set!
0o you want to remove

the channels port settina?

roneer ) o (emave )

This breaks the automatic port connection of the Multi-Instrument. It is no
longer needed because the Multi-Instrument is now connected to its port
through the GM Mixer. In other words, the GM Mixer is now also functioning
as an output port. Leaving both connections would result in doubled notes!

To see the fruits of this labor, select one of the sub-channels of the Multi-Instrument,
enable its Prg, Vol, and Pan parameters by checking their checkboxes, then mouse in
different settings. You should see these changes reflected on the GM Mixer panel.

N O T E Unfortunately, this is a one-way connection. Changing the mixer

settings does not result in a change to the corresponding Instrument Param-
eter Box setting
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T 1P When you change programs on the Multi-Instrument you will probably
notice that the Multi-Instrument names do not match the GM Mixer's names.
The GM Mixer ONLY uses the standard General MIDI preset names. This is
unfortunatly just a limitation of the GM Mixer right now. Just disregard the
GM Mixer's program display in this case. Mac only - If it is too distracting,
just resize the Mixer (using the box in the lower right hand corner ) so that
the program names are not visible.

Setting Up Mixers for all of your instruments

The simplest approach for a mixer setup is to create a GM Mixer for each of your MIDI
ports that have listeners on them. You have already created Instrument objects for
each listener on each of these ports. The only further step necessary is to repeat the
above steps for each of the ports and Instrument objects.

If you have more than one Instrument object for a certain port, cable ALL of the
Instrument objects for the port into the same GM Mixer. l.e. even though you may
have more than one Multi-Instrument or Mapped Instrument for a port, you only
need one GM Mixer per port.

Because of the size of the GM Mixer, you will probably want to put each GM Mixer
on its own layer. (There's no need to do this, it's a matter of whether you prefer
scrolling the Environment window or changing Environment layers.) You may also
prefer not to keep all of your Instruments on the Global Objects layer so that they
are visible (and perhaps in the way) on all other layers. One place to move them is
to the same layer as the mixer you create for them.

TIP To move Environment objects between layers simply select the
object(s) to be moved, then hold down the Windows — Control;, Mac —
Option ; key on your computer keyboard while selecting the destination
layer from the Layers menu.

Logic's Environment provides all the tools for building completely customized mixers
and control panels one object at a time. You'll find a simple example on the Envi-
ronment layer named MIDI Faders.

With the advent of the GM Mixer (new in Logic 3.0), straight forward mixer panels
like the one on the MIDI Faders layer are kind of pointless, but when it comes to
customization, the possibilities are limitless. To learn more about building your own
Environments, consult your Logic manual and the Environment guide that comes
with it. There is also a third party manual available which is dedicated to plumbing
the depths of the Environment. It is called E.g., a Complete Guide to Logic's Environ-
ment. You can find information about the book by visiting the companies website.
The address is www.swiftkick.com
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What You Will Learn

In this section you will learn about the special features that allow you to customize
LOGIC to your working preferences. In particular, you will learn how to use "Screen
Sets”, "Link Modes", and "Key Commands" to tailor Logic's use of your computer's
monitor and keyboard.

The information is organized into the following sections:

(. Working with Logic's Windows
(@ Using Screensets
(@ Understanding the Link Modes

(@ Working with Key Commands
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3.1 Working with Logic's Windows

Windows are an important part of Logic—they have a lot to do
with Logic's "look & feel". In this section we'll be dealing mostly
with windows like the Arrange and Environment windows which
we'll call "working" windows to distinguish them from windows
like the Preferences and Song Settings windows which we only
open briefly to change settings. All of the working windows are
listed under the main Windows menu.

Here are some things that all working windows have in
common:

e There is a "Title Bar" across the top with the name of the
Song in it.

Information about your current selection is also appended
to the Song name under certain circumstances. If this bar
Mac — has gray, horizontal lines running through it,

Windows — is highlighted,;
itis the "active" or "topped" window. If the bar is all white
except for the Song name then some other Logic window is
active. We'll deal more with this very important concept as
we go on.

¢ Just below this bar there is a menu bar.

The menus and their contents vary from window to

window. When you do something within the window, the
menus temporarily disappear and information pertinent to
your actions appears here. For example, if you alter a note

how to:

open & close
windows

change
active
windows

open & use
floating
windows

work with
Logic's Trans-
port

use the Catch
button

make your
window
display stay
current with
the current
song posi-
tion

in the Matrix (piano roll) window, this area will display the type of event
(Note), it's position, velocity, and current length. This line of information is

referred to as the Control Line.

e There are two "zoom controls" to the right of the menus in the menu bar.

These look like telescopes—the first one zooms the display
Selm b | S=mmw| yertically (indicated by the downward pointing triangle)

and the second one zooms the display horizontally.
Clicking on the big end makes things bigger and shows less territory and
clicking on the little end makes things smaller and shows more territory.

e Multiple windows of a given type can be open simultaneously

This is a very helpful feature which is unique to Logic. It means you can, for
example, have two different Matrix windows open simultaneously, each

viewing different sequences.
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TIP (Mac Only) Holding down the Control key and pressing the arrow
keys also controls zooming if you haven't changed Logic's default key
commands.

* There are "scroll bars" along the bottom and right edges of the window.

The bottom left corner acts like a double scroll bar —just click-hold your
mouse on the square and the window will follow your mouses up/down and
left/right movements as you move in the main body of the window.

= | Structure Edit Functions Yiew Oplions

) o)1) »)mep)

= MIDI THRU In the upper left hand corner there
Qua off {35400 may be two buttons—one with a
: : little man in it and the other with a
chain link.

00:00:32:17.34
12 3 3 1

Along the top there may be a
time line. This is refered to as
the Bar Ruler

Loop

Transpose

Yelosity + 1 These are called the "Catch Man" The Arrange, Matrix, Score
. and the "Link Button" and we'll and Hyper Edit windows all

Dynarnics describe them in detail below. have a time line, referred to as

Gate Time the Bar Ruler, which runs hori-
zontally along the top of the
window. The Event and Envi-
ronment windows do not dis-
play this Bar Ruler; the Event
window because it's time axis
runs vertically , and the Envi-
ronment window because it
doesn't deal with time. Where
there is a Bar Ruler, the View
menu allows you to view or

hide SMPTE time display. E

Next to the Catch Man and Link
Button there may be an array of
Transport buttons together with
two boxes of numerical displays.

Crelay

kSl
% EIES

- Pé: Pop 1
{Mapped Instr.)

lzon E?ﬂ
i8

Cha =

PrgE 1 i)
vl 127

PanE b1

Ma Seq Trp E

Mo Reset |:|

duto Style

Whether these components are
visible depends on a View menu
option as well as whether there is
enough space. To create more room,
grab the corner where the Track list
and the Bar Ruler meet and drag it
down and to the right. If the Trans-
port buttons still don't appear, select
Arrange -> View -> Hide/Show Trans-
port.

Along the left side of the window there is a parameter settings column.
The window's View menu allows you to hide or show this column.
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In this guide we will not spend a lot of time on the details of how each of these
displays works—you can find that information in chapter 4 of your Logic manual.
Our object here will be to become familiar with how Logic's windows work.

Arrange and Transport Windows

If you haven't done so yet, close the Environment window. There are two ways to
close a window:

* Click the Close Box at the left end of the Title Bar.
* Press the definable key command for closing the window.

The defaults are; Mac — Command-T Windows — No default

Be careful to make sure that the window you wish to close is active. This is indicated
by;

‘:_ Mac — horizontal lines in its Title Bar

E Windows — a highlighted Title Bar.

If it is not the active window you will need to make it active by clicking anywhere in
the window.
Now the Arrange window should be the only remaining window.

Normal vs Floating Windows

Logic has two kinds of windows—normal and floating. The Arrange window is an
example of a normal window. Logic's standard Transport window is an example of
a floating window.

To open a Transport window choose: Windows -> Open Transport

Two things distinguish floating windows:
e Floating windows are never the active window.

* Floating windows are always visible over normal windows.

The only window that can cover a floating window is another floating
window.

The Transport window is just one example of a floating window. We'll see others as
we go along.
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TIP (Mac Only) Any of the working windows can be opened as a float
simply by holding the Option key down while opening it from the main
Windows menu (alternatively, hold Option while using the key command to
open the window)

Take a look at the Transport window. The left half looks a lot like the Transport
display in the upper left corner of the Arrange window. Both contain the same
buttons and information.

Here are some guidelines to understanding what each of those buttons do:
e The top row of buttons control Logic's "transport” functions:

Record @ Pause @ Play [B Stop [E Rewind @ Forward [E

e The bottom row of buttons control Logic's record & playback options:

Cycle Autodrop Replace
Solo Sync Metronome

e Next to the buttons is the position and locators display.
The top line is Song Position in SMPTE, the 2nd line is

the Song Position in bars-beats-divisions-ticks, the 3rd 01: 00: 00: 00. 00/ ()
line is the left locator and the 4th line is the right LA N B |
locator. L R B ||

| =

e The tiny buttons move the current Song Position

The Song Position is indicated, when visible, by a vertical line running through
the Arrange window. This line is often referred to as the Song Position Line
or "SPL" for short. When a song is playing, these tiny buttons will set the loca-
tors according to the current SPL.

This box displays the tempo, memory remaining, time | esaa HE

¢ Next to the tiny buttons is an info box
(| 1200000 | 44 4|
signature and the Display Format value. |
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e At the right end is the MIDI activity indicator; the Song

name; a small pop-up menu called the "Display” menu — EE |I.-I|-I|.I‘t
for altering the Transport window's appearance; and a toload
Song length indicator (in measures). p— =a

You will find a detailed explanation of the function of each
button and display in chapter 5 of your Logic manual. For
now, let's make a couple of changes to the Transport window, then move on to other
things:
1. Select Transport -> Display menu -> Legend

The Legend labels each portion of the Transport making it easier when you're
first learning Logic to remember what each button does. You probably won't
want it permanently displayed as it makes the transport bigger .

2. Select Transport -> Display menu -> Position Slider

The Position Slider allows you to move the Song Position (see above) around
quickly either by clicking or click-dragging.

The Transport's Position Slider is very handy for making large position moves in any
of Logic's time-oriented windows. The following little exercise demonstrates how it
works and in the process, show the purpose for Logic's Catch button.

3. Click & hold at the left end of the Position Slider and drag back and forth.

You will see Logic's Song Position change in the Transport's Position display;
the gray section of the Position Slider will expand and contract and the
Arrange window's vertical Song Position Line will move in and out of view.

T 1P Ifyou have a hard time seeing the Arrange window's Song Position Line
("SPL"), check the "Wide Song Position Line" checkbox in: File -> Preferences
-> Display.

4. Click on the Catch button

The button is located in the top left-hand corner of the Arrange window. If
the SPL is out of view the Arrange window's horizontal view will immediately
change to show where the SPL is.

5. Repeat step 3

Notice that the SPL now always stays in view. This is the whole point of the
Catch button —it ensures that you're always viewing Logic's current position
in the song.
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TI1P The important thing about the Catch button is that it is independent
for each of the currently open windows so that you can keep some windows
at the SPL position and others fixed where you've set them.

Now that you are familiar with the various types of windows in Logic, you should
know about two important tools that are available to help you organize them, and
control how they interact. These two tools are known as Screensets and Link Modes.
We'll start with Screensets.

Before going on, please record or otherwise create two sequences in the Arrange
window and name them "Seq1" and "Seq2". (If you do not know how to do this,
please consult the Quick Start section of this guide.)
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3.2 Using Screensets

Screensets provide a very simple and convenient way for you to

manage Logic's various windows. They allow you to call up a  how to:
pre-configured set of windows with just a keystroke. Using them

is essential to realizing Logic's full potential. Not using them * openand

would be like never using your car's 4th gear. @o5e Ee ]
windows

The Event List provides a list view of your song's data. The list *® viewa
can be of the objects in a Sequence (e.g. notes and other MIDI sequence in
data) or of the Sequences in the Arrange window or in a Folder Se."e(;al
(more later). Select the sequence named "Seq1" and open the ‘c')vr'l:eows at
Event List by: Windows -> Open Event List.

e create and
move
between
screenset-
salleviate
screen
clutter

The window can also be opened using the:

"_ Mac — Command + 2 key command;

‘E Windows — definable key command .

lock/unlock
Screensets

An important thing to note about the Event List is that time is  ® copy Screen
represented vertically. Sets

e The events in the list are in chronological (time) order.

e Each column displays different information about of each entry.

At the moment, your screen should contain an Arrange window, a Transport window
and an Event List window. Move and size these to fit your screen and personal taste.

Congratulations! You have just created a Screenset.

In fact, whatever is currently on your screen is a Screenset. Logic will remember up
to 90 of them—numbered from 1 to 99 except that no numbers with "0" in them are
allowed.

Here are the most important facts about screensets:

e The screenset number is displayed next to the word Windows on the global
menu bar.

e Screensets can be "locked".
When a screenset is locked, you can still make any changes you like. The only
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difference between locked and unlocked screensets is that changes to locked
screensets are lost as soon as you change screensets. A locked screen set is
indicated by a:

‘: Mac — black dot; E Windows — "#" symbol;

to the left of the screenset number.
N O T E You can only lock and unlock screensets by using the definable
ﬁ key command. The default Logic key command on a Mac system is

"Command+L". The Windows version of Logic does not have a default key
for this — you must define it before using it.

N O T E Windows Only You cannot lock the screenset if Logic's main title
bar is the one highlighted. You must make sure one of Logic's "normal"
windows is the active window before locking a screenset.

the state it was in when you selected it but you must assign a Logic key
command to do this (it is not assigned by default). You can also assign key

' § TIP If you unintentionally change a screenset you like, you can "revert" to
commands to step forward and backward (by number) through screensets.

You change screensets by typing any number on your computer keyboard. On
Windows system, you must use the QWERTY keyboard numbers, i.e., not the
numbered keyboard. Either will work on Mac systems.

To select screens higher than “9”, hold the:

‘:, Mac - Control key; E Windows —Shift key;
while typing in the number.

To copy Screen sets hold the:

‘:, Mac — Shift key; EE Windows — Control key;

while selecting the new number.

Logic Audio Guidebook 3-79



What makes Logic Special

3.3 Understanding the Link Modes

The Link Modes control whether selections in one window affect
the view in another window. When windows are linked, making
a selection in one will cause that selection to be viewed in the
other window. For example, you can choose whether or not an
Event List window should update its view when you select a new
Sequence in an Arrange Window.

N O T E Linking works between all windows—even
windows in different Screensets. Putting a window in
Link Mode means that it will always display the cur-
rent selection and there will always be only one selec-
tion.

Your screen should now have an Arrange window and a Event
List window in it. (The Transport's there too, but it doesn't
concern us at the moment—close it if you like.) The Event List
should be showing the notes and other MIDI data in the
Sequence "Seq1". In the upper-left corner of each window is a
button with a chain-link icon on it. This is the Link Mode button.
For the following exercise, the button should be gray in both
windows—if it's not then click it until it is.

how to:

e link windows
& keep the
song posi-
tion in view

e force an edit
window to
follow the
selections
made in
another edit
windows

e keep the
view of an
edit window
fixed on a
particular
sequence

There are two different link modes: Link and Show Contents modes. The easiest way

to help you understand how they work is to demonstrate.
1. Go to the Arrange window
2. Select the Sequence named "Seq2" (by clicking on it once).

Observe that the Event List still shows the MIDI contents of "Seq1"

3. Select the Sequence named "Seq1".
4. Click the Link button in the Event List window.

With a:
‘:. Mac — it will turn red.

3@ Windows system— it will turn light blue I%
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5. Select “Seq2” again.

Observe that the Event List now lists what's in the Arrange window—namely,
Seq1 and Seg2 and that Seq2 is selected. (Remember there is always only one
selection.)

6. Double-click the Link button in the Event List window.

"_ Mac — it will become blue with a black square in the middle

f@ Windows — it will turn dark blue

7. Select Seq2 again.

Observe that the Event List now changes to list the contents of Seq2. This is
why it is called "Show Contents" mode—the linked window will always
change to show the contents of the current selection.

TI1P The Link and Catch buttons can work together to keep the contents of
what's playing always in view. To enable this feature choose:

File -> Preferences -> Global -> Allow Content Catch by Position if Catch and
Link enabled.

This is just one simple example of how Logic's windows can work together to make
your life easier—we'll see a few more in the Editing chapter . If Logic is managing
what your windows display, you don't have to. As you work, keep the Link and Catch
buttons in mind. You'll find it saves a lot of clicking.
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3.4 Working with Key Commands

One of Logic's most beneficial features is the ability to set up key
command equivalents for the vast majority of Logic's operations.
This includes most menu functions as well as many tasks that
only available as key commands. In this section we'll explore
Logic's Key Command window.

To open the window select:
Windows -> Key Commands

Like the Event editor, the Key Commands window contains a list
and only a vertical zoom tool which changes the print size.
There is the usual parameters column at the top of which is a
collapsible window showing the details of the currently selected
key command row. Below this are several buttons. The first four
buttons are used when assigning key commands and the last
three are used when trying to find key commands. (You'll
quickly discover that with so many possibilities, these last three
buttons are extremely helpful.)

Key command window's views

Here are some ways to change what is viewed in the Key
Commands list:

1. Click the Hide Unused button

how to:

find out to
what task a
key is
assigned

find out
which key is
assignedto a
task

assign your
on keys to
tasks

trigger key
commands
from your
MIDI
keyboard

print a list of
your key
commands

Now only the tasks that have been assigned key

| Hide Unused I

commands appear in the list. Typically, this makes the
list considerably shorter.

2. Click the Hide Used button

Now you should only see a single item in the list—the |

Hide Used |

item that's currently selected.
3. Click the Hide Unused button again

Now you will see all the possible Key Commands that are not assigned to
anything (plus the currently selected line because that's always visible).

4. Click in the box next to the word Find: and type Open

Then click the Find button. This will show you a list of all unused
Key Commands with the word Open in their description. Notice

that Open Key Commands... is one of the items on the list.
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TI1P These buttons—Find, Hide Used, and Hide Unused, are the first things
to check when you can't find something in the Key Commands window.

Assigning a key command to an operation

In this exercise, we'll assign the "k" key to the operation Open Key Commands
1. Find and Select the Open Key Commands... option
2. Click the Learn Key button

Now Logic is ready to assign the next key you type to Learn Key
this command. Type "k" to make the "k" key open the
Key Commands window.

3. Click the Learn Key button again

This is necessary for your keyboard to become usable again—otherwise, Logic
will just keep changing the key for this command as you type new keys.

TIP Windows Only — Key commands won't function if the main menu
window bar is active. Use the F9 to activate one of the other windows (or
click on one) if a key command doesn't seem to be working. (F10 re-activates
the main menu window bar.

Finding the function a particular key is already assigned to

1. Make sure the Learn Key button is NOT selected
2. Press the key or keys whose function you're searching for
In this case, press the Space Bar on your keyboard. You will see the line for

"eRecord Toggle" selected. (Note also that the "Hide Used" button automat-
ically gets turned off.)

N O T E The "e" next to the command "eRecord Toggle" indicates that this
process can ONLY be done using a key command. To see a list of the things
that can only be done this way, use the "Find" function for "¢". (You type
"e" on your keyboard by holding the Option key and typing "8".)

For your convenience, at the end of this guide there are lists of all the default key
commands, all the remaining unused key commands and all the "¢" key commands.
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TI1P You may have noticed that the Key Commands list is divided into cate-

gories: "Global Commands", "Various Windows", "Arrange Window", etc.

You can use the same key in different categories so that what it does will

change from window to window. This can be a useful option, but if you use

it, use it sparingly. It can be difficult to remember and easy to thwart some

global key command that you really want to use. For example, if you assign
"k" to some "local" process in the Arrange window, you won't be able to use it to
open the Key Commands window from the Arrange window.

Logic has a few fixed key commands that aren't listed in this window (or elsewhere).
In particular, the characters: Q; W; E; R; A; S; D; B; N; M; are used for MIDI Step-Input.
If you assign these to other tasks, they will no longer function their fixed task so be
sure you aren't going to need those key commands before reassigning them.

Here are a few other useful things to remember about key commands:

. ‘_ Mac Only Keys that appear twice on your keyboard can be assigned

separately. Do this by using the "Learn Sep. Key" button instead of the
"Learn Key" button. ("=" and "-" are examples of such keys.)

. ‘: Mac — Any of the "modifier" keys;

. ‘E Windows — the Shift and Control keys;

can be used to assign alternate processes to a key. For example, you could
have Shift+"k" or Control+"k" open the Key Commands window instead of
just plain "k". You can also use multiple modifiers such as Control + Shift + k
for example.

e Any MIDI message can also be assigned to a key command

This is assigned similarly to computer key commands.
Just use the Learn MIDI button (instead of Learn Key) to Learn MIDI I
assign the next incoming MIDI event to a command.

TIP For MIDI commands to work, MIDI Remote must be on. Rather than
leaving this on permanently and subjecting yourself to unwanted MIDI
commands, assign the Toggle MIDI Remote and Disable MIDI Remote
commands to MIDI events. (A note-on and the same note-off make good
choices for these commands.) Then you can turn MIDI remote on and off
from either your computer keyboard or your MIDI controller.
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In this chapter you will learn the various ways to get MIDI data into Logic. Recording
is the most common of these, but there are other, non-real-time methods, which also
have their uses. Many of the procedures are applicable for recording audio as well,
so even if you are primarily interested in using the audio side of the program, don't
skip this section.

The information is organized into the following sections:

(@ Getting Setup for Recording
(. Basic Recording
(@ Punch-in Recording

(@ MIDI Step Time Recording
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4.1 Getting Setup for Recording

In the Quick Start section, we made a simple recording by
selecting a track in the Arrange window and pressing the record
button on Logic's transport. As the focus was on testing, we
didn't necessarily pay attention to Logic's tempo and meter
settings. In this section, we'll treat the process more seriously by
setting up, and following, Logic's metronome. This will ensure
that what we end up with is synchronized to Logic's tempo &
meter.

(The section explores various ways to take a freely recorded
sequence — i.e., not following the metronome — and synchro-
nize them after the fact.)

It's a good idea to have something in mind to record as we go
through this set up procedure. Choose something fairly short —
say 32 bars or so — and plan to record several different parts
(e.g. piano, bass & drums).

Here are a few things to decide before setting up:

e The song's time signature
Keep it simple, like 4/4 without meter changes.

e A rough tempo for the song.
Choose a comfortable playing tempo.

e Which Environment Instruments you'll use.

Make sure the required Instruments and Multi-Instrument
sub-channels appear on the Track list's Instrument menu.

Setting up the Metronome

Logic provides two ways for you to hear a metronome click;
either through your computer's speaker or via MIDI. We will
focus on using the MIDI click since it is the most accurate option
and provides functionality not possible with the speaker click.

Therefore, we'll start by turning the Speaker click off.

how to:

set up the
Metronome

make the
Metronome
click for
recording,
playback or
both

turn off the
Speaker Click

set the
count-in

make the
Metronome
click only
during
count-in

set & change
Logic's time
signature

set & change
Logic's
tempo

choose a
Track and
Instrument
for recording

make a
single-pass
recording

re-do a
single-pass
recording
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To Turn the Speaker click off:
1. Open Arrange Window -> Options -> Recording Options

2. Disable Speaker Click option

Findingl/Selecting the Metronome Object

Logic's MIDI Metronome can be set to sound at bars, beats and/or the current Display
Format setting. The Metronome is an Environment object, so its settings are selected
in an Object Parameter Box, just as you have learned to do previously for Logic's
other Environment objects. Once it's settings are defined, you can turn it on and off
from Logic's Transport display. You can also control aspects of the metronome's
activity in the Arrange Window ->Recording Options window .

The MIDI metronome normally resides in the Clicks and Ports layer of the Environ-
ment, so you can access it by opening the Environment window and going to that
layer. There are however, two simpler alternatives for accessing its parameters:

e Alternative 1

From the Transport Window, click-hold [1:1:"[;: P::E:E]k

on the Transport button and choose
Locate MIDI Metronome from the flip
menu The result of this action will be
that the Environment window will
open to the proper layer and the MIDI
metronome will be selected.

100 Click
loon
Ear
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¢ Alternative 2

You can select the Metronome from the Arrange Window just as you do a
"regular" instrument, — by click-holding in a track and selecting it from the
Instrument flip Menu.

Regardless of which method you use, once you have selected the Metronome object,
you are ready to alter its settings.

Altering the Metronome’s Parameters

1. Set the Metronome's parameters in its Parameter Box

The metronome's settings allow you to assign different sounds to the bar,
beat or sub-division clicks. You could, for example, have a bell sound at the
top of every bar and a rim shot sound on all other beats.

2. Set the output port and channel settings.

Like Logic's Instrument objects, the Metronome output
can be set directly in it's Parameter box . ( via “Direct
Port assignment” ) In other words, it is not necessary to
cable it to some other Environment object such as a MIDI
port object or other Instrument.

| = MIDI Click

(The Figure at the right shows the settings on a
Windows system. Output definition for MacOS is
handled the same way it is for “regular” instrument
objects. See the relevant section in the MIDI Setup and
Configuration chapter.)

There is a separate channel setting for each of the Dlivi=ion
possible clicks (bar, beat and division), but the port Cha
setting is set globally with the bar-click setting. The Rlote
checkbox to the left of each of the possible click options
enables/disables that option from clicking.

N O T E The most common setting is probably for the Bar and Beat to be
ﬁ enabled but the Division disabled.

3. Set the click pitches & velocities

The bar, beat and division clicks can each have their own pitch (i.e. their own
sound if you're sending the Metronome to a drum-style MIDI device) and
velocity. As long as an option is enabled, the Metronome emits a test click
whenever you make changes, making it easy to find the sound you wish to
use.
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To configure when the Metronome should sound
1. Open Logic's Song settings by choosing:
Arrange Window -> Recording Options

2. Enable/Disable Click while
recording

This checkbox. near the
middle of the Recording
Options window. deter-
mines whether the Metro-
nome will click while Logic
is recording.

3. Enable/Disable Click while
playing.
This checkbox determines
whether the Metronome
will click while Logic is
playing back.

4. Enable/Disable Polyphonic
Clicks.

When this box is checked,
the beat click will sound on
the bars and the division
clicks will sound on the
beats and bars. When it is
unchecked, only one click
sounds at a time.

5. Enable/Disable Speaker
Click.

Check this box to have your i Biar BhubEn #
computer speaker sound
the Metronome's clicks. | : :

6. Set the count-in.

The "count-in" is the
number of bars or beats
that Logic will play before
the record start-point.
(There are several ways to
set the record start-point
which we'll deal with below.) You can set the Metronome to only click during
the count-in by checking the box just below the count-in menu. NOTE: This
option is only available when Click while recording is enabled.

|
[
=
u
!l..
D
- oie
[ 15}
ol

Logic Audio Guidebook 4 -89



TI1P Don't overlook the "Wait for note" count-in setting. Using this with
"Click while recording" enabled causes Logic to start clicking but not start
recording until you play your first note. (i.e. you don't have to make it across
the studio to your keyboard by the end of the count-in.)

Setting Logic's Tempo & Time Signature

Logic's time signature (the number and type of beats per bar) can be set in the
Tempo/Signature Display of the Transport window. It can also be set directly on the
staff in the Score editor. The Transport window shows the time signature as a frac-
tion "# / #".

Whenever you make a change to either the "numerator" (left # setting for the
number of beats per bar) or the "denominator" (right # - setting for the type of note
that is a beat), the new time signature takes effect at the closest barline to the left
of the Song Position. This will be indicated by a small time signature on the Bar Ruler
of any window that has a Bar Ruler such as the Arrange window, the Matrix editor,
etc. (The initial time signature — at beat 1 of bar 1 — is not shown on the Bar Ruler.)

To insert a new Time Signature

Using the Transport Window...

1. Set the Song Position to the position at which the Time Signature is to begin.

If there is to be only one Time Signature throughout the song, then go to the
first bar.

2. Adjust the time signature setting on the Transport panel

Click-drag on the numerator (top) and denominator (bottom) of the Time
Signature on the Transport panel to change the value

7 ] 9 10 |11

e | | s P : 192.0000¢ 3/ 4 Moln

5 ERZ29G = P Dt
Lemmon_t.mid
mumunm E
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& W ARNIN G /tisimportant to know where you are in the song before

changing the value, otherwise you might accidentally insert a Time Signature
change where you didn't intend to. If your song has the same Time Signature
throughout, then simply make sure you are at Bar 1 before changing the
Time Signature.

From the Score Window...

1. Make the Time Signature palette come to the top of the Part Box
In the pallette box below the Tool box,

click on the box with the "4/4" icon. This - : 9:lfp|§‘: g Ehﬂ" '
will bring the Time Signature pallette : m| g |iﬂ's.| % |'| |
group to the top of the Symbol Pallette. gl =

2. Insert a “standard” Time Signature

If you're inserting a 2/4, 3/4, 4/4, 6/8,
"common time", or "cut time" Time signature, click-drag that selection onto
your staff at the desired measure. If you' need to insert something other than
those selections skip to step 3.

( Otherwise, skip step 3)

3. Insert a “non-standard” Time Signature

If you're inserting a time signature other than 2/4, 3/4, 4/4, 6/8, "common
time", or "cut time" ; click-drag the "A/B" option to the desired measure.

| Insert Time Signature

s N e s i 1
e

Change the values for the Nomi-
nator and Denominator in the
resulting settings window by
either:

| Mominator: 4
Denominator: 4

- | Beat Grouping: |
o EJ;ampuund Signature
- L1 Hid "'.Ei.'griatme
R :

| Cancel | Ok |

e Click-dragging on the existing
values or;
e Double-clicking on the values,

then typing in the desired
number

the Pencil Tool by selecting the desired symbol, then clicking once at the

N O T E You may also insert a Time Signature in the Score Window using
) ‘ beginning of the measure in which you want the new signature to appear.
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To modify an existing Time Signature

Using the Transport Window:

1. Set the Song Position to the same bar position as the Time Signature you
wish to alter.

2. Adjust the time signature setting on the Transport panel

Click-drag on the numerator (top) and denominator (bottom) of the Time
Signature on the Transport panel to change the value

From the Score Window:

Edit Time Signature

1. Double-click directly on the Time
Signature on the staff

2. Change the values for the
Nominator and Denominator

Change the values by either
click-dragging on the existing

| Mominator:

i:Eﬂ Eeat Grouping: |
T 7
v i D’:ﬂ':ml; Compound Signature

g,Hﬂ:IE Signature

et

values or; double-clicking on the T
values, then typing in the ,;J‘ DE|EtE il Cancel Ok I
desired values. L

TI1P You can control the default beam and tie grouping of notes displayed
in the Score by inputting a simple equation in the "Beat Grouping" box. The
simple addition equation must simply add up to the value of the Nominator.
For example, if you are in 6/8 time, and you wish to have notes defualt to
being grouped in pairs, then you'd input the equation; 2+2+2. If, alterna-
tively, you wanted notes grouped in 3's, you'd type "3+3". If your equation
doesn't properly "add up", then Logic Audio will automatically change the
Nominator value to reflect the new sum. So, in the above example, if you
had accidentally typed 2+2+3, the Nominator would have changed toa 7 —
rendering the Time Signature as 7/4.

To delete a time signature

From the Transport Window...

1. Set the Song Position to the position of the time signature you wish to delete
2. Change the time signature in the Transport Panel to match the preceding
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time signature.
From the Score Window...

1. Go to the measure containing the Time Signature you wish to delete.

Remember, there must be at least one sequence in the song in order to view
a staff in the Score window

2. Click once on the Time Signature being deleted to select it
It will flash off and on when it is selected
3. Press the Delete key on your computer keyboard
You may also delete a Time Signature by clicking on it with the Eraser tool.

Setting the tempo

Logic stores tempo information as a series of Tempo events. These events can be
viewed and edited in the Tempo List editor window. The format of the window is
essentially the same as the Event List Window. The current tempo is what is displayed
in the Transport window.

If your song has only one tempo throughout, then simply input the tempo in the
Transport window's Tempo/Signature display. If you need to input mulitple tempos,
you will have to open one of Logic's tempo editing windows. The most common is
the Tempo List Editor. It can be opened from two different locations

* Arrange -> Options -> Tempo & Synchronization -> Tempo List Editor

e Transport -> Sync Button -> Tempo List

Once it is open, the current tempo setting will be listed as an event at time position
"1T111".

To input tempo change here:
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1. Select the Pencil Tool
2. Click once on the existing event, right on the word Tempo

This creates a new Tempo event with a text entry box for the 'Position' auto-
matically open.

3. Type in the desired position for the new Tempo event
Use either a Space or '.' in between the bar, beat, division, and tick values.

ﬁ N O T E Logic will insert '1' for any missing positions to the right of the
values typed so typing "5.3" for example, will render "5 3 1 1.

Other Tempo Event edit Windows

Their are two others edit windows that can be used to insert or alter Tempo Events:
the Tempo Graphic Editor and Tempo Operations windows. These are covered in
detail in your Logic manual — here we'll only be using the Tempo List editor.

TIP Logic 3.0 now allows for 10 different and completely independent
tempo lists. These are called Tempo Alternatives and are selected from the
Tempo List editor's Options menu. There is also a definable key command
that opens a small window for selecting the current Tempo Alternative.

Preparing the Arrange Window for Recording

Now that you have set up Logic's Metronome, time signature and tempo settings, all
that remains is to select a Track and Instrument for recording. This is done in the
Arrange window exactly as it was in the Quick Start section. Here is a quick review
of the steps:

1. Set up a recording Track and Instrument

Top the Arrange window and select a Track. For simplicity in following this
example, delete any Sequences and Folders already in the Arrange window
and delete all but the top track. To do the latter step, simply choose:

Arrange -> Structure -> Tracks -> Delete Unused

2. Select an Instrument from the Track List's Instrument menu

Once you've selected the instrument, check that it is responding to your MIDI
controller.

3. Set the Song Position to the beginning of the Song.
The easiest way to do this is to hit the "Stop" command key twice
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Recording

4.2 Basic Recording

You're ready to start recording. You can start Logic

recording in several ways — how to:
® prepare to
record a
e using a key command on your computer keyboard, second part
e using a MIDI remote key command (handy if your keyboard e create a new
is not close by) track
e using the Transport window's Record button. e practice with
the first part
You stop Logic recording the same way you stop playback — :\r/\léiggle
with the Transport window's stop button or a key command (the
Enter key by default). e record
multiple
takes in
Cycle Mode
TIP If you click and hold on the Transport's record without
button, a menu will pop-up with several recording re- stopping

lated choices. Please Note that the "Punch on the fly"
option is only relevant when recording audio.

Chances are you made a perfect recording the first time, but just
in case you didn't, a handy way to re-do the recording is by using
the Record Repeat option. This option is enabled by selecting:

Transport -> Record Button menu -> Record Repeat

This will delete the previous recording, return the Song Position to the start point
and begin recording again. You can repeat this process until you are satisfied with
the take.

to assign a key command and/or MIDI key command to this very useful

N O T E Unless you're a "one take Charlie", you'd probably be well advised
) ‘ option.

Let's now record a second part on a new Track with a different Instrument.

Creating a new Track

e Double-click on any empty spot on the Track list or;
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e Choose Arrange -> Structure -> Track -> Create

TI1P If you double-click an empty part of the Track list with the:
Mac Option key held down;  Windows Control key held down;
Logic will create a new track and assign the next Instrument from the Instru-

ment menu to it.

Rehearsing over a repeated section (Cycle Mode)
i\? Before recording you may want to practice playing against the part you
-

just recorded. The easiest way to do this is to:

1. Set the cycle locators and playback in Cycle Mode.

Turn Cycle Mode on by clicking the Cycle button at the left end of the bottom
row of buttons on the Transport. Alternatively, you can just click in the upper

part of the Arrange window's Bar Ruler.

2. Set the cycle start and end points to the Sequence borders.
To do this, select the Sequence you just recorded and choose:

Arrange -> Functions -> Set Locators by Objects

3. Select the new recording Track.
4. Start Logic playing

10 11
1200000 | 4 ¢ 4 Mo In
314852 ME Mo Qut
o Untitled
LooQic
ALUD I g hd 201

Click the Transport's Play button or use a key command ("0" by default).

TIP If you think you missed a great take while practicing, there is a key
command called "Capture Last Take as Recording" (Shift+Return by default)
which can recapture it for you. Aslong as you hit this key command BEFORE
STOPPING, Logic creates a new sequence containing everything you played

from the point at which you last started the sequence.

You can record the second part one pass at a time just as you did the first part, but
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if you think you'd like to record multiple takes, there's an easier way. Logic can auto-
matically create tracks and record multiple takes without stopping and restarting

each time. Here's how:

1. Open Arrange Window -> Options -> Recording Options

This opens the Recording Options window, the same window you used for
setting the Metronome click and count-in options.

2. Check Auto Create
Tracks in Cycle
Record

This causes Logic
to create a new
track for each
repeat of the Cycle
rather than
recording all takes
into the same
track. This makes
it much easier to
see and select
from your takes
once your done.

3. Check Auto Mute
in Cycle Record

This ensures
previous takes do
not play while
you're recording
new ones.

4. Start recording

Use the Transport
button, key

I
[I=———— Sonq Settings =—

\

Recording Options

[ |Merge New Recording With Selected Sequ
Mew Sequences in Cycle Recon
] Auto Mute in Cycle Record (m)

] Auto Create Tracks in Cycle Record (c)
Allow Tempo Change HE::urding
[«]Data Reduction

<] Click while recording (e)

[ ] Click while playing (p)

] Polyphonic Clicks

(] Speaker Click

1 Bar count-in -

[ ] Click only during Count-in (Record)

command or MIDI key command to start recording. Play as many takes as it
takes — when you have one you like, stop recording.

You should now have multiple tracks, each with a different take. The "Auto Create
Tracks" option pushes the older takes down, so the latest take will be on top. Logic
also automatically numbers the takes so you can see which is the latest. All but the
most recently recorded sequence will also be muted as a result of having the "Auto
Mute in Cylce Record" option enabled. You can now go back and unmute/mute the

various takes to determine which was the best of the lot.
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N OTE Ablack dot (MacOS), or “null” symbol (Windows), next to the
name of a Sequence indicates that the Sequence has been muted. You can
mute or unmute Sequences with the Arrange window's Mute tool (square
icon with an "M" in the middle) or with the Mute Track key command (no

default assignment).

Muted Sequence in Windows:

aPiano

Muted Sequence in Mac:

I
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Recording

4.3 Punch-in Recording

Even if you were able to find that "magic" take from all those
that you recorded, for the sake of this exercise, let's suppose  how to:
there are a couple of bars in the middle of the best take that

you're not quite happy with. A common remedy in this situation ~ ® Punchina

is to "punch in and out" of the offending area and replace it Eo"edi‘;"
with a new performance. ©apar
e punch-in
- - automati-
Manual Punch-in/out with Replace cally
e Use Punch
1. Position the song either at bar 1, or anywhere prior to the mode with
area to be punched in on. or V\II/O
2. Select the track you are punching in on Eﬂe(fdaecgn

3. Enable Replace Mode

Replace mode determines whether previous events will be
erased while you are recording. To enable it either: Click
once on the Replace Mode button on the Transport; or use
the definable key command.

Windows default is: Control + R

Mac default : not defined

0 0000 00,00 L:J 12000000 [ 4/ 4| Moln
LI 1 [:I 2148193 A6 No Dut
5 1 1 1| gl g Untitled
2 1 1 1 nunll?glc v 201

4. Start the sequencer

5. Punch in to record

You Punch in to record either by clicking on the Transport's record button or
hitting the Record Toggle key command.

Mac and Windows default key is: Space Bar

6. Punch out of record

You punch out of record either by clicking the Play button on the transport,
or hitting the Record Toggle key command again, or simply stop the
sequencer.
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If you are working alone, then it would probably be easier to perform the previous
task if you let Logic punch in and out of record automatically for you. Logic refers to
this function as Autodrop

Automatic Punch-in/out with Replace

1. Turn Cycle Mode off
Use the Transport's Cycle Mode button or a key command

the first pass when Autodrop and Replace Mode are on. You can Autodrop

N O T E The reason we turn Cycle Mode off is that Logic will only replace
) ‘ through many cycles but you can only replace the first time.

2. Turn Autodrop on

Use the Transport's Autodrop button (to the right of the Cycle Mode button)
or a key command.

| IMLELI 01 |:n:| |:u:| 0000 ([&)| 1200000 | 44 4| Moln
-\ 1 1| 514215 A6 Mo Qut
1 1 Untitled
(dluslslelsl 1 18 edic P
3. Turn Replace Mode on
Use the Transport's Replace Mode button. ( The button with the"X" on it)

4. Set the Song Position to any place before the start of the Autodrop region
5. Start Logic recording.

Logic will playback up to the start of the Autodrop region then start recording auto-
matically. Because Replace Mode is on, Logic will delete any existing Sequence mate-
rial on the record Track.

TIP There is a set of definable key commands labeled "Set Drop Point by
Song Position" which allow you to set the left and right drop points based
on the current Song Position. This allows you to set infout points on the fly
— a useful option for those "tight" punches.
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Punch in/out and add data without Replace

If you wish to add material to your performance using Punch in/out recording, follow
the previous procedures but without enabling the Replace mode option.

How Logic handles the new material is determined by the following setting:

File -> Song Settings -> Recording Options -> Merge New Recordings with Selected
Sequences

When Merge New Recordings with Selected Sequences is enabled, Logic will merge
the new data in with the old and no new sequences will be created. Generally, this
is the more desirable option.

If Merge New Recordings with Selected Sequences is disabled, Logic will create a
new sequence containing the new material and place it on top of the old sequence.

TIP You can automatically move these "overlapped" Sequences to their

own tracks using: Arrange -> Structure -> Track -> Create for Overlapped
Objects.
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4.4 MIDI Step Time Recording

Now let's create a third part using Logic's MIDI Step-time

Recording mode. MIDI Step recording allows you to input Notes  how to:

with your MIDI keyboard while the sequence is stopped. The

position and lengths of notes are pre-determined by selections * creaie an
you make before striking each note. This is often a good solu- seer?ngnce
tion for busy melody or percussion parts that are difficult to play oS e
in real time. It's also handy for entering notes from a compli- Recording

cated written score.

e start & stop
Step-time

With Step-time Recording, you "record" by setting the Song Recording

Position to the desired start point, then playing notes one-step-

at-a-time from your MIDI keyboard. Each time you release ALL  * control the

notes, the Song Position jumps ahead by the step amount. size of the
steps while
. . . . enterin
The step amount is determined by Logic's Display Format value. notes o
This value is set in the Transport Window, just below the Time .
Signature. It is displayed in the format "/#" * use Logic’s
special
— shortcutkeys
= [ forStep-time
00: 00: 08: 00, 00 1920000 Me I Recording
B o1 1 1 2O HE () Mo Our

Lemmon_t.mid 1

— [ n

W ARNIN G The Display format value dictates two other important
functions in Logic.

(=
]
11 1 1|l
(=

B 1 1 A

e |t defines what the division value is wherever an Event's bar/beat/divisio/tick
position or length information is displayed alpa-numerically -- such as in the
Event List, Tempo List or Event Float windows. For example, a note displayed

at 11 1241 with the Display Format set to "/8", will be displayed at 112 1
when it is set at "/16" (240 ticks = 1/16th note)

e |t determines the display quantize setting in the Score window when a
sequence's Score Parameter Box "Qua" setting is set to "Default"

Since changing the Display Format value can radically alter the way things look in
these windows, it is generally a good idea to leave the Display Format alone accept
for MIDI step editing purposes. It is also wise to make sure that you return it to its
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Recording

original value when you're through using MIDI step input.

You can add notes to any Sequence using Step-time Recording but if you starting
from scratch, you must create a new Sequence before you begin.

Here are the steps:

Create a new (empty) sequence:

Create a new Track

Select the Instrument for this part.
Select the Arrange window's Pencil tool.

To select the Pencil tool, click on it in the Toolbox in the parameters section
of the window.

5. Create the Sequence

Click in main part of the Arrange window, to the right of the new Track, at
the desired start time for the Sequence. The should create a new sequence
object inthe Arrange window.

6. Select the Pointer tool.

It's a good habit to always reselect the Pointer tool after using another tool.
This keeps you from making changes you didn't intend to make. A quick way
to do this is to simply hit the Esc key twice.

R

TIP You can bring up a "floating" Tools palette at the cursor position by
typing the Show Tools key command ( Esc by default). Then you can choose
a tool by clicking on it or by typing the tool number. (The Pointer tool is #1,
the Pencil tool is #2, etc. counting clockwise around the palette.)

TIP (Mac Only) You can have two tools easily available at one time by
assigning an "alternate" tool which will be active whenever you hold down
the Command key. To assign an alternate tool, just hold down the Command
key and select the desired tool.

7. Lengthen the new Sequence

Newly created sequences default to being only one bar long so you'll usually
want to lengthen them after they are created. You can do this with the
Pointer tool by clicking on the lower-right edge of the Sequence and drag-
ging. You will know you're ready to drag when the cursor turns into a:

Mac pointing finger Windows Left and Right arrow symbol
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In this case, make your new sequence about the same length as the
Sequences you've just recorded.

To enter notes using Step-time recording, you need to be in one of Logic's three
main editor windows: Matrix, Score or Event. For this example we'll use the Matrix
Editor.

Open the Matrix editor window for the Sequence by selecting the Sequence and
choosing: Windows -> Open Matrix Edit.

Step-time Record notes into the Sequence

1. Set the Song Position to the beginning of the Sequence.
2. Turn on Step-time Recording

Click the MIDI In button — the button labeled "IN" just below the Catch
button. This enables Step-time Recording.

3. Set the Display Format value to the smallest note you'll need.

If you're only entering quarter-notes, use division 1/4. If you'll be entering
quarter-notes and 8th notes, use division 1/8. You can change the division any
time you want (even while holding down notes), so you needn't be too fussy
about the choice.

4. Play notes on your MIDI keyboard.
The notes will appear in the Matrix editor as you enter them.
5. When you are finished turn Step-time Recording off.

This is another good habit to get into. If you leave it on, anything you play
on your MIDI keyboard while in this Matrix editor window will be recorded.

To Create Chords

Logic doesn't "step" until all notes are released. Until that time, Logic records any
new notes at the current Song Position, i.e., creates a chord.

To Lengthen a note as its being input

If you step on the MIDI sustain pedal (MIDI controller #64) or hit the TAB key while
holding a note, the note is lengthened by one Display Format value. For example, if
the Display Format setting is "/8" for 8th notes and you want to enter a quarter note,
step on (and release) the pedal once before releasing the note.

To input rests

If you step on the MIDI sustain pedal (MIDI controller #64) or Hit the TAB key without
holding a note, the Song Position will advance by one Format value, leaving a rest
equal to that value.
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Special MIDI Step key Commands

In most cases, Logic gives you the option of defining your own key commands, but in
the case of MIDI Step input, there is a set of fixed key commands which cannot be
altered. Furthermore, if you assign these keys to other functions in the Key
Command Window, it defeats their special Step-time function.

commands in the Score Window which select different note values from the

Partbox. While these key commands were designed for speeding up mouse

entry of notes in the Score window, they can also be used for MIDI step entry
since they alter the Display Format value. The restriction is that they will only func-
tion from within the Score Window.

E N O T E There is one special acception to this rule . There are definable key

The following special keys on your computer keyboard affect Step-time settings:

Key Selects the division

A Quarter note

S 8th note

D 16th note

Q 32nd note

W 64th note

Key Changes the division

E Next higher division (e.g. from /8 to /12)
R Next lower division (e.g. form /12 to /8)
Key Moves the Song Position

N Next beat

M Next bar

B Back one division and delete what's there

Also remember that the standard Forward and Rewind key commands can be used
during Step-time Recording.

division manually, quantizing, etc. are still available during Step-time

N O T E All normal activities like moving notes, using the tools, setting the
) ‘ Recording.
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TI1P You can change the pitch or velocity of an existing note, using your
MIDI controller.

1) Double-click the MIDI IN button in the Event, Score, or Matrix Windows;

IM

On a Mac, the button will then look like this: E|

In Windows, like this: Ii
Ik

2) Select the note you wish to alter and play the correct pitch with the desired
velocity on your controller keyboard. The selected note will take on the pitch and

velocity of the note you struck. Be careful not to forget to de-select the MIDI IN
button when you're through.
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What You Will Learn

In this section you will learn the various ways you can edit the MIDI data you've
recorded. We will see how to organize and move Sequences around in the Arrange
window. Then we'll work with Logic's main editor windows and examine the unique
features of each. In the process we'll take brief looks at Logic's quantization and
reclocking features.

The information is organized into the following sections:

(i Working in the Arrange Window
(@ Working with Folders

(i Working in the Event List

(@ Working in the Matrix Editor

(i Working in the Score Editor

(@ Mix Automation

(@ Other Useful Editing Tools
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5.1 Working in the Arrange Window

At this point you should have the short three-part piece that you
recorded in the MIDI Recording section. Set the left and right
Locators to the beginning and end of the piece and turn Cycle
Mode on. This will allow you to cycle the piece and hear the
changes you make as you make them. There are a number of
things you can do with Sequences and groups of Sequences in
the Arrange window so that's where we'll start.

Sequence Parameters

Each Logic Sequence has its own, individual set of parameters
which affect the way its MIDI data is played back. You can alter
many aspects of the notes including their overall loudness
(Velocity); rhythmic accuracy (Quantization); or average dura-
tion (Gate Time).

The basic set of parameters are shown in the Sequence Param-
eter Box at the top of the Arrange window's parameter settings
column. It is important to understand that these are playback
parameters only, i.e., their effect is non-destructive. This means
that the actual MIDI data is not changed, only the way it is
played back.

how to:

® use Sequence
parameters
to affect
playback

e lock in the
Sequence
parameters

® quantize
while
recording

e guantize
multiple
tracks/seque
nces at once

e guantize
non-destruc-
tively

Logic's various parameter boxes can be "minimized" or "expanded" by

N O T E Ifyou don't see the complete Sequence Parameter Box, recall that
} ‘ clicking on the triangle in their top-left corner.

When a Sequence is selected, the parameters in the Sequence Parameter Box update
to reflect the settings for that sequence. The name at the top of Sequence Parameter
Box changes to reflect which sequence or sequences are selected.
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Here is what will be displayed and how the data will be affected for each of
the possible states of selection

e When no Sequences are selected

Transpose

Welocity
Oynamic=
Gate Time

Oelay

= MIDI THRU}[ The words "MIDI THRU" are displayed and all incoming
gua off [3840) || MIDI data is effected by the settings. This is the way to

define a set of default settings for the Sequence Param-
eter Box. It is how you would, for example, "quantize
on-the-fly". When you record, the resulting Sequence
take on these parameter settings Don't forget however
that since these settings are non-destructive, you can still
alter the values later or return them to "blank" to hear
the original MIDI data as it was performed.

e When one Sequence is selected

The name of the Sequence is displayed and all settings
apply only to that Sequence. (If a setting is "blank", it _
means it is off or set to a value of "0") Welosity

= 4 selected
aua off [3840]

Transpose
Welocity
Oyriamics

Gate Time

Delay

= Seq. 1
cua off [3840]

Transpose

Oynamics
Gate Tirme

Oelay

¢ When multiple Sequences are selected

"# Selected" is displayed and all selected Sequences are
effected by the parameter settings. If the Sequences already
have some parameter settings and they are not all the same, a
"*" will appear next to that parameter. Changing a *'d setting
causes relative changes in all the selected Sequences.
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The meaning of many of the Sequence parameters should be self-evident to most,
others may require a little experimenting to reveal their effect. (For a detailed discus-
sion of all the Sequence parameters consult your Logic user's manual.) The best way
to experiment is while Logic is playing so that you can hear the results as they
happen.

Let's try it:

1. Start Logic playing
Click the Transport's play button or use a key command ("0" by default) to

start Logic playing. If you turned Cycle Mode on as suggested, your short
piece will playback over and over.

2. Select one of the Sequences that should be "in time" like a drum, bass or
rhythm guitar part and change its Qua parameter setting.

ST When you click to the right of the word Qua in the Sequence
16E Swing Parameter Box, a menu pops-up with various choices. These are
160 Swing || time divisions and quantizing "snaps" all notes to the closest
division of the selected type, i.e., if you choose 1/8-Note, every
=M note in the Sequence will play at an 8th-note time division. This
16B 3wind M means it is important to choose a quantize setting that properly
— corresponds to what was played. If you choose 1/8th-Note but
you played notes of a shorter duration like 8th-note triplets or 16th notes,
many of the notes would end up "clumped"” on top of one another in an
undesirable fashion..

160 Swing

Logic offers very powerful and complex quantizing choices - including the ability to
quantize one sequence to another. These are beyond the scope which are beyond
this "getting started" guide so for now, just experiment with the basic settings.
Consult your users manual once you are ready to explore the other options available
for quantizing.

3. Experiment with the other parameters

Spend some time experimenting with some of the other parameters except
"Loop" , which will have no audible effect. (We'll discuss looping a little
later.)
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The users manual contains a complete description of what each of the Parameters do.
Here is a basic description for a few of the parameters that you are likely to use most
often:

¢ Transpose

The name says it all. This parameter allows you to transpose notes up or
down, one half-step at a time. The range is +/- 96 half-steps

e Velocity
Adds or subtracts a set velocity to/from all notes

e Dynamics
Expands (louder notes get louder, softer notes get softer) or Compresses (all
notes approach the middle of the range) the overall range of note velocities.
Can be a very useful tool, especially when used in conjunction with the
Velocity parameter.

e Gate Time
Shortens or lengthens all notes by a given percentage. The range is from 25%
to 400%. At one end of the range you also have the option to "FIX" all note
lengths to the same length and at the other to make all the notes play
"Legato", i.e., to continue to sustain right up until the next note.

e Delay
Shifts the positions of all events within the sequence by the selected value.
The values are represented in ticks by default. If you wish to adjust the value
using the milliseconds, select Arrange -> View -> Delay in ms

N O T E The Quantize settings are the only Sequence Parameters which
ﬁ will have an effect on the display of events in the various event windows.

TIP If you click-hold just to the left of where the value is input for the
Transpose and Delay settings, a flip-menu opens with an abbreviated selec-
tion of the most "musically useful" options for that parameter. For Trans-
pose, the menu contains only perfect octaves — for Delay, only perfect note
values, i.e., 1/32, 1/24, 1/16, 1/12, 1/8, etc.
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Converting Sequence Parameter settings to destructive edits

At some point you may decide you want to you like and want to "lock" in your
Sequence parameter settings, i.e., turn them into hard edits to your data. This is
necessary in fact when your are preparing a song to be exported as a MIDI file.

The way to do this is to:
1. Select the Sequence or Sequences to be affected.

2. Choose Arrange -> Functions -> Sequence -> Instrument Parameter ->
Normalize Sequence Parameters

The actual Sequence data will be changed according to the parameters and the
settings in the Parameter Box will be returned to their zero setting. Remember
though, you can only undo this type of edit once — just after performing it. After
that, the edit cannot be reversed.

event channel to match that of the current Instrument. This can be a
problem if you are using a polyphonic score style in the score window, since
in that case, the event channel is being used to differentiate between voices.
To avoid this potential problem, select the optional menu selection: Arrange -> Func-
tions -> Sequence -> Instrument Parameter -> Normalize wilo channel

@ W A R NI N G Selecting this option will also change the internal MIDI

There is one other option as well — Normalize wio channel and delay. This option,
as the name implies, will also ignore the current Delay setting when Normalizing.
Normalizing does not apply to the Quantize setting . Quantize values can be
"locked-in" using a separate option: Arrange -> Functions -> Sequence -> Instrument
Parameter -> Fix Quantize

TI1P If you double-click on any of the parameter names on the left side of

the Sequence Parameter Box, a floating window version of the Sequence

Parameter Box opens which includes an extended set of parameters.

Amongst other things, these extended parameters give control over the

Range and Strength of the Quantize settings. They also give you the ability
to quantize the velocity and lengths of notes.

Moving Sequences and changing their Boundaries

Sequences can be conveniently manipulated within the Arrange window. With
simple and intuitive mouse movements you can move, copy, or change the duration
of a musical phrase.
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Moving a Sequence to a different position or track

‘ t"f \ 1. Click hold on directly on the sequence you wish to move until the

cursor turns into a;

Mac — grabbing hand

Windows — cross-hair tool |

Drag the mouse to a new location or track

As you move the Sequence, notice that the area where the window's menus
normally reside changes and now display current information about the size
and position of the Sequence you are moving.

==

Copy I]hjen:ts 19 2 4 1 5eql 4 3 8

button
Windows — hold the Alt + Shift keys down AFTER click holding the mouse
button
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This display is referred to as the "Control Line".

N OTE A Control Line also appears in the Hyper, Matrix and Score
windows to indicate similar information about MIDI events as you edit them

$ there.

TIP Logic normally snaps your movements to the nearest beat. To tempo-

rarily defeat this grid and move by the sub-division of the beat:
Mac — hold the Control key down AFTER click holding the mouse button

Windows — hold the Alt key down AFTER click holding the mouse button

To temporarily defeat this grid and move by the ticks:

Mac — hold the Control + Shift keys down AFTER click holding the mouse



TIP Logic by default allows you to freely move objects both horizontally
and vertically. Some users prefer to work with a little less freedom of motion
in order to reduce the risk of making unintentional changes. If this idea
appeals to you, select File -> Preferences -> Global menu | tab -> Limit drag-
ging to one direction in Arrange.

Notice there is a similar option for limiting your movements in the Matrix
and Score Windows. In either case, when this option is enabled, Logic will
automatically sense which direction you first travel in, and then restrict your
movements to that direction.

Changing Sequence Boundaries

Another useful option you may perform in the Arrange Window is to
change the left and right boundaries of a Sequence. If you think of the
Sequence as a box of data, this amounts to making the box bigger and
smaller. You can move either end to the left or right but you can't move
the beginning to the right past the first note. Shortening a Sequence doesn't destroy
any data—it simply keeps it from playing back. If you expand the Sequence again,
the data is still there and will play.

Let's give it a try:

1. Click-drag the lower right hand corner of the Sequence

Select one of the Sequences in your piece and click the pointer on the lower
half of its right edge. When the pointer;

‘:, Mac — changes to a hand with one pointed finger,

E Windows — changes to a left and right pointing arrow;
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drag to the left until the sequence is roughly half of its original length.

TIP The same Control Line mentioned previously will display updated
length information as you make this edit. This allows you to know precisely
what you're doing.

2. Check the effect of the edit

Start the song and take notice that nothing plays after the newly edited right
hand boundary of the Sequence.

TI1P If you hold the; Windows — Control key Mac — Option key ;

while changing a Sequence's length, the position and length of the notes

changes in proportion. In other words, if you shorten the Sequence to half

of its original length, it will play twice as fast and all notes will be half as
long. Remember to use the Control Line to ensure that your length edit is precise.

We'll see next that changing Sequence boundaries is a very handy feature when used
in conjunction with Loops, Aliases and Folders.

Making Aliases, Copies & Loops

In Logic, there are three basic types of "copies" of a Sequence. Each type has its
advantages and uses. Here is a brief description of each:

e Standard Copy

A completely independent copy of the original. Once a copy is made there is
no relationship between the copy and the original. You can create this type
of copy in three different ways:

¢ using standard Copyl/Paste functions
e Mac — Option drag sequence; Windows — Control drag Sequence

e using the Arrange -> Edit -> Copy MIDI Events window(see User's
manual for details on this feature)

e Alias
A freely movable place holder that tells Logic to play the original Sequence at
a new location. Any change in the original also applies to all its Aliases, but
Aliases have their own Sequence parameters and can be moved around the
Arrange window freely.

¢ Loop

A place holder that tells Logic to continuously repeat the original sequence
until it "runs into" another object on that Track.
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Let's look at an example of how these three kinds of copies might be used in your
three-part piece:

1. Loop one Sequence:

Select one of the Sequences, say the bass part, and click to the far right of the
word "Loop" in the Sequence Parameter Box. You will see a strip of gray
"ghosts" of the Sequence extend continuously to the right. The horizontal
dividing lines indicate the points at which the sequence is reiterated.

i e veeee S S e

ER Seq.1

BTN | e e e B

2. Alias one Sequence:

Select another Sequence, for example, the melody part, and choose:
Arrange -> Structure -> Alias -> Make

Drag the Alias so that it starts at the same position as the beginning of the

third Loop of the first sequence (i.e. until there is a "one Loop" gap between

the original and the Alias.)

TIP You can also make an alias of a Sequence by simply holding the
Windows — Control + Shift keys; Mac — Option + Shift keys;
while you drag it to a new location.

3. Copy the remaining Sequence

Select the Sequence and choose: Arrange -> Edit -> Copy
Position the SPL at the end of the original and paste the copy there by
choosing: Arrange -> Edit -> Paste

TIP You can also make a copy of a Sequence by simply holding the ;
Mac — Option key ; Windows — Control key ;
while you drag it to a new location.

Before we hit play to hear the results, let's try our hand at the previous tip which
described a way to Time Stretch or Expand the contents of a sequence. With the
recently Pasted Sequence selected:

1. Hold down the;
Mac — Option key ; Windows — Control key;
and stretch the copy to (exactly) twice its length. The following warning box

Logic Audio Guidebook 5-116



will show up:

Time Stretch Sequence
contents?

(Expand or Compress)?

[ Cancel ]

2. Click 'OK'

N O T E "Time Stretching" doesn't work with Aliases—that's why we used
ﬁ; a real copy.

3. Playback the Song

If all went according to plan you will now have a song that is three times as
long as the original—let's call this three choruses. The looped Sequence
(presumably bass) plays for all three choruses. The aliased Sequence plays for
the 1st and 3rd choruses only and the copied & stretched Sequence (presum-
ably drums) plays for all three choruses but plays at half-speed for the last two
choruses.

Stopping a loop

As stated earlier, a Looped Sequence continues until the end of the song, or until it
"runs into" an object on the same track. There is in fact two other ways to stop a
Looped Sequence from continuing to play. Here they are:

e Block the Loop with and empty sequence

Create an empty Sequence with the Pencil tool at the exact place you want
the looping to stop. Alternatively, you could also place a Copy or Alias at the
same location where you want the last Loop to play.
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e Pack the Looped Sequence into a Folder

If a looped Sequence is inside a Folder it will not play beyond the limits of the
Folder. To learn about creating folders, read in the following section,
"Working with Folders"

Changing Aliases & Loops into Real Copies

After you've used Loops and Aliases to repeat and restructure your Sequences, you
may want to turn some or all of them into "real" copies for further editing. This
would, for example, allow you to edit the MIDI events in the Sequence, something
you can't do with a Loop or Alias. (at least not without effecting the "original”)

Fortunately, Logic allows you to easily change both Loops and Aliases into real
sequences. Open the Folder with your three choruses in it by double-clicking on it (if
you're not inside it already). Then follow these steps:

1. Select the Alias and choose:
Arrange -> Structure -> Alias -> Turn to Real Copy
2. Select the looped Sequence and choose:

Arrange -> Functions -> Sequencel/lnstrument Parameter -> Turn Loops into
Real Copies

TI1P You can also choose to turn Loops into Aliases. This allow you to freely
reposition and edit the Sequence parameters of the Loops ( once they are
Aliases) but without add extra MIDI data to your Song.

Since we no longer need the Folder to "contain" the three Loops, move out of the
Folder and for simplicity, unpack it (by selecting it and choosing: Arrange -> Struc-
ture -> Unpack Folder.

Merging and Cutting Sequences

Merging Sequences

A common function you will likely need to perform at some point is to "glue" two
or more sequences together. Logic generally refers to this as "merging" sequences.
There are few different ways to perform a merge operation, all of which are quite
simple to do.
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To Merge selected sequences together

1. Select the sequences you wish to merge

You can do this either by shift-clicking or lassoing them. Selecting a track will
select all the sequences in the track, unless Cycle is on, in which case it will only
select those sequences within the boundaries of the Cycle.

2. Click on any one of the sequences using the Glue Tool
OR, select

Arrange -> Structure -> Merge -> Objects/Digital Mixdown
OR,

use the definable key command called Merge Objects
( Mac default — Shift + M Windows — no default)

To merge all sequences on a per track basis E

It is sometimes more convenient to have all sequences in a track merged into one.
This is generally a good idea for example, when preparing the score for printout.
Fortunately, there is a dedicated feature for performing this task on all selected
sequences.
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To perform this operation on your whole song:

1. Select all the Sequences in the Arrange window

bas=1.1

1 |2 |3 |4

i keystcomped merged il

wiclin up*merged

| baz=1.1"merged I

trumpet 2.1 merged

If you only want to merge the Sequences on a selection of Tracks, select only those
Sequences before performing this operation.

Using the Merge function to add controller or other data to an existing
sequence

While it may be more common to use the merge operations horizontally, i.e., to
append sequences to one another, there are times when you may wish to merge
Sequences that are playing at the same time and by the same instrument. A good
example is when you have added controller or other data to a track and the new
recordings are in new sequences, perhaps even on separate tracks.
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Imagine that when you recorded the parts or your piece, you were concerned with
the notes and didn't bother with the other MIDI controllers (foot pedal, modulation
wheel, pitch bend, etc.) It's often easier to add this information after the fact, espe-
cially for Sequences that were step-time recorded. Let's add some controller data
and pitch bend to one of the Sequences.

1. Select the Track of the part to add controllers to and choose:

Arrange -> Structure -> Track -> Create

This creates a new Track just below the selected one. Another way to create
a new track is to simply double-click in the space at the bottom of the Track
list, just below the last initialized track.

2. Record some modulation wheel movements into the new track

Use the procedures described in the Recording chapter to record modulation
wheel changes into the new track.

3. Record pitchbend changes into another new track

Create another new Track as in step 1 and record some pitchbend changes
into it.

Merge all the sequences together

1. Use the procedure described under To Merge selected sequences together to
merge the new sequences together

2. Delete the now unused tracks

Logic provides a nice menu option/key command that makes it easy to delete
any tracks that no longer have sequences in them.
Select any track that does contain sequences, then select:

Arrange -> Structure -> Track -> Delete unused

(Logic will not delete the currently selected track, even if it is empty. That is
why we instructed you to select a used track before selecting this operation)

Selected Sequences option described in the Basic Recording chapter. With

that option enabled, your new recordings are automatically merged as you

record. However, an advantage to recording without that option enabled
is that you are able to take multiple takes, then audition each to find he one you like
before merging it into the original sequence.

E N OTE You could also have used the Merge New Recordings with
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Cutting Sequences

Now that we've looked at putting sequences together, let's explore the features
available for taking them apart. You will use these features whenever you wish to
remove a portion of a Sequence, or when you want to take a portion of a Sequence
and move or paste it to another track or location in the composition. All of these
features can also be used on a group of Sequences as well. All you have to do is select
them before starting the operation.

Using the Scissors Tool

Perhaps the easiest and most intuitive method for cutting sequences is to simply use
the Scissors Tool

1. Select the Sequence or Sequences you wish to cut
2. Select the Scissors Tool from the Tool box
3. Cut the Sequence at the desired location

Click-drag directly over the top of the Sequence, in the general location
where you wish to cut the Sequence.

The Control Line discussed previously will become visible, allowing you to see
where you are about to cut. . You will also notice that the MIDI data "under"
your current position is transmitted as you move, creating a "MIDI scrub"
effect. This let's you use your ears to find the location for your cut.

Wisi 1 Pianol Seq. 1 divided

As with moving Sequences, movement is initially snapped to a beat grid. You can
defeat this grid using the modifier key options described under the previous section,
"Moving a Sequence to a different position or track"
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Using the Song Position

1. Select the sequence or sequences to be split

2. Locate the Song Position to the spot at which you wish to cut

Probably the fastest, most efficient way to do this is to use the Goto Position...
definable key command although you can alternatively: click and drag the
song position values in the Transport window, or click and drag the Song Posi-
tion Line to the desired location.

‘ keyz/comped ‘ keys!c:umped'ditride

You can alternatively use the key command equivalent for this function.

Using Locator values

This option allows you to make two cuts with one operation.
1. Select the sequence or sequences to be split

E 2. Set the Left and Right Locators to the beginning and ending points of the
area you want to split off.

The most direct and intuitive way to this is to click-drag your mouse in the
upper portion of the Bar Ruler, the same way you do to define the boundaries
for Cycle mode. (Yes, this will also enable Cycle mode, but it's easy enough
to disable it once the operation is finished) You can alternatively "dial in"
the desired locator values directly on the Transport Panel

Logic Audio Guidebook 5-123



3. Select Arrange -> Functions -> SplitiIDemix -> Split Object by Locators
You can also use the definable keyboard equivalent.

A :|1 4 5

1 ﬁ (AT (] | keyz/comped™divided 2T

TI1P Ifyou use the key command for Split Object by Locators in conjunction
with the key commands for Set Left Locator by Song Position and Set Right
Locator by Song Position, you can very quickly and easily split off portions
of Sequences "on the fly".

TI1P Mac Only If you hold down the Command Key while click-dragging in
the Bar Ruler to define Cycle boundaries, all selected objects will be split by
those locator settings when you release the mouse button.

You should now have a pretty good idea of how to get around the Arrange window.
Before we move on to looking at the other edit windows, we’ll examine a useful
organizational tool called Folders.
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5.2 Working with Folders

If you get to a point where your composition contains a large
number of Sequences, you may begin to wish for an efficient
way to organize them all. This is the function of Logic's Folders.
By "packing" your Sequences into these Folders, it's easy to orga-
nize them vertically into instrumental groups, and/or horizon-
tally, into musical sections.

N O T E Don’tfeel that you have to use Folders. While they are
an excellent organizational tool, be aware that they introduce
an extra level of hiearchical complexity to your song. Before you
begin using them, be absolutely sure that you have a firm grasp
of Logic's hierarchical nature and the various Link Modes which
were covered in the "What Makes Logic Special" chapter.

Let's create a Folder for the three choruses of your Song:

1. Select everything in the Arrange window.
You can do this in several ways:
e Shift-Click each object (except the Loops).
e "Rubber-band" select all the objects.

how to:

e combine
Sequences
in Folders

* move in and
out of
Folders

¢ use Folders
to repeat
song struc-
tures

e Choose Arrange -> Edit -> Select All (or use a key command for this).
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2. "Pack" everything into a Folder by choosing:

Arrange Window -> Structure -> Pack Folder

A Folder is a container just like a Sequence except that Folders can only contain
Sequences or other Folders. In other words, Folders cannot contain actual MIDI
events.

When you "pack" a Folder, Logic puts it on a Track whose Instrument is "Folder".
This is NOT an Environment object — it is one of two things on Logic's Instrument
menu that is built into Logic. (the other is the "No Output" object — a special Instru-
ment generally used to disable MIDI Thru ). If there is no Folder Track in your Arrange
window, Logic creates one when you pack a Folder.

Some important points to remember about Folders:

e You can unpack Folders any time you want.

To see this, select the Folder you just created in step 2 above and choose:
Arrange -> Structure -> Unpack. Your Song should return to its original struc-
ture. Now pack the Folder again and we'll explore Folders some more.

e You get "inside" of a Folder by double-clicking on it.

This is called changing levels because it doesn't open a new Arrange

window—it just moves "down a level" to the inside of the Folder. When you

move inside the Folder, it appears that you're back to your original view—the E
way things were before you packed the Folder.

If you look in the Arrange window's Title Bar, you'll see the name of your

Song followed by a colon (":") followed by the name of the Folder you're
inside of.
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N O T E You can always tell where you are in any of Logic's windows by
looking at the Title Bar. Each level is indicated by a colon—no colons for the
top level, one colon for the 2nd level, etc.

* You get outside of a Folder by double-clicking on any empty space in the
window's workspace.
You can also click the level button at the left end of the Menu Bar. (This

button looks like a black square within a gray square.) Finally, there are key
commands available for going between levels. (These key commands have no

default assignment.)

e Folders have their own parameters.
The Sequence Parameter Box becomes the Folder Parameter Box when a
Folder is selected. This means you can transpose, loop, quantize, etc. every-
thing in a Folder at the same time.

* You can Loop Folders and make Aliases or copies of them.

For example, you might wish to loop the three-chorus structure you created
above, then record "melody" Sequences spanning several Loops.

As you spend more time with Logic, you will find many powerful uses for Folders but
for now, we'll simply perform a few edits while inside our folder then unpack it. That
way, we can continue to explore Logic's editing features without worrying what
"level" we're on.
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5.3 Working in the Event List

The Event List window displays events in an alpha-numeric list.
It is the oldest type of edit window used in a sequencer, and is
still perhaps the most efficient. It is also the only edit window
in Logic where you can effectively view and edit any level of your
composition, i.e., not just MIDI events, but Sequences and
Folders as well.

Select the Sequence you just added mod-wheel and pitchbend to
and open the Event List by choosing:

Windows -> Open Event List

The Event List window will open up and you will see a list of all
the MIDI events in the Sequence.

Here are two important points to remember about the
Event List window:

e Time is represented vertically.

The events in the list are in chronological (time) order. The
various event information is organized into columns

e The left column shows the position of each event in the list.

The four numbers indicate bars, beats, sub-division and
ticks. The sub-division value is variable and is defined by
the Display Format value which was discussed in the
Recording chapter. Keep in mind that changing this value
does not change the actual position, only the way the it is
represented.

N O TE Normally, an event's position is measured

£

tion.

how to:

open the
Event List
editor
window

edit event
parameters
in the Event
List

add events to
the Event
List

select events
in the Event
List

change the
format of
the Event
List's posi-
tion display

quantize
selected
events in the
Event List

Select events
of just one

type

from the beginning of the Song. If you wish to have the positions measured
from the beginning of the Sequence, select Event List -> View -> Local Posi-

You can edit the values in this column either by scrolling any of the four digits
or double-clicking and typing in a new position. In the latter case, use a Space

or .

to delineate between the bar, beat, division, and tick values.

Remember that Logic will insert '1' for any missing positions to the right of
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the numbers typed in. Typing "5.3" for example, will render "53 1 1.

= |Edit Functions 'iew S

STATUES —HA MUM L)AL LEMGTH/IMFOQ
1 1 2 1] FitchBd 1 o 48 = - 2043
1 1 3 21 Note B ae 47 - - 1 12
1 1 3 169) MNote B G2 47 — _ _ 212
1 1 4 221) Mote B a2 56 — _— 1 124
1 2 1 1§ P-Press 1 EZ 0
1 2 2 1| Prograrmn 1 [ - 38 ROOMY-0ORGAN

e The Status column shows the type of MIDI event.

= | Edit Functions Yiew] S
FOSTITION STATUES —HA MUM L)AL LEMGTH/IMFOQ
s 1 1 2 1§ PitchEd 1 0 45 = - 2043
E 1 3 21 HMote B g2 47 - - 1 1z
r 1 1 3 169 Hote B G2 47 - — 212
1 1 4 ZZ21] Hote B &2 o6 — — 1 124
1T 2 1 1} P-Press) 1 E3 0
1 2 2 1) Program 1 [ - 38 ROOMY-0ORGAN
M

The Status is only for display. You can't transform one type of MIDI event into
another — at least not here.

e The Cha, Num and Val columns show the event parameters.

All three of these parameters can be edited by scrolling or double-clicking and
typing in new values.

= | Edit Functions Wiew| | C=
FOSTITION STATUE EHH MM UALE LEMGTH/TIHFO
A 1 2 1 PitchBd 1 0o 43) = - 2043
E T 1 3 & Mote B A2 47 - - 1 12
T 1T 1 3 169 HNote B G2 47 - - - 212
1T 1 4 221 Note B [CPER Y - — 1124
1 2 1 1 P-Press| 1 E3 0
1 2 2 1 Programj 1 [J - 38} RO0OMY-ORGAN
M

Cha is the MIDI channel. This is the channel that was the event "came in on".
In other words, it was the channel your controller was transmitting on when
you initially recorded the data. Normally, this value will not effect the
channel the data is being played back on because it is overridden by the
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channel of the Instrument currently assigned to the Track.

is when handling polyphonic (multi-voiced) parts in the Score window
because Logic uses this "event channel" to differentiate between poly-
phonic voices.

E N O T E The only time you will probably ever be concerned with this value

Num displays something different depending on the type of event. For notes
it displays the pitch, for controllers, the controller number and for pitchbend,
the data LSB (don't be concerned if you don't understand what that means).

Val also depends on the type of event. For notes, it's velocity, for controllers,

it's the controller amount and for pitchbend it's the data MSB (again, don't
be concerned if you don't understand what that means).

e The "Length/Info" column shows the length or duration of notes and gives
pertinent information about all other types of events.

= | Edit Functions Yiew| E==u|

FOSTTICON STATUES ZHA HUM  L'ALR LEMSTH/THFO
s 1 2 1 PitchBd 1 0 48] = - 2048
E 1 1 3 2 Mote B A2 47 - - 1 12
i 1 1 3 169 HNote B G2 47 - - 212
1T 1 4 221 HNote B A2 LB — — 1 124
1 2 1 1 P-Press 1 E3 0
1 2 2 Program 1 : ROOMY -0RGAN

For registered Continuous Controllers it displays the actual controller name,
i.e., for mod-wheel (cc#3) it displays Modulation and Pan (cc#10) it displays
Pan. For Pitchbend events, it shows the amount as a single value (between -
8192 and +8192).

* You can select events in all the usual ways (clicking, shift-clicking, rubber
banding, etc.).

Always make selections in the Status column area or else you may accidentally
change the data. The Edit menu also provides many useful selection options.

TI1P To view the event positions and lengths in SMPTE units, select Event
Window -> View -> Position & Length in SMPTE Units. The same menu also
has another useful option — Length as Absolute Position. \When this is
enabled, the value in the Length column represents the end position of the
event rather than actual length value. This is an especially useful mode
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when editing Folders, Sequences, or Audio Regions.

Other Event list objects

The left side of the Event List window contains two columns of buttons. The top two
in the left column are the familiar Catch and Link Mode buttons. Beside them are
scroll buttons for moving the displayed events up and down in the window. The
black wedge in the middle of the left border of where the events are displayed is the
Position Arrow. If Catch Mode is on, this will correspond to the Song Position. The
two buttons labeled In and Out toggle Step-time recording and MIDI output, respec-
tively. When MIDI output is on;

Mac — blue button | | Windows — Red button u

selecting an event in the Event List will cause it to be played.
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Filtering the display of Events

Below the In and Out buttons you'll find two columns of “Event Type Buttons”.
These buttons serve two purposes. The first is to determine what event types will
appear on the list .

1. Click the button with the note icon so that it is gray.

101 Contral 41 Fodulation
28 Control 0 FModulation
32 PitchBd 59 - &40

T& FitchBd a5 -  Te3
1531 PFitchBd 2 - 1280

When a button is gray the corresponding events are suppressed from the list.
They are not erased, they simply aren't displayed. You should now only see
two types of events: mod-wheel (controller #1) and pitchbend ("PitchBd").

2. Click the button just below the note button.

The icon is a slider with its position mark in the middle and this represents a
pitchbend wheel. You should now see only mod-wheel events.

= “adld s ]
22 Control & O Modulation
End of Lizt

3. Select all events using the Edit menu or a keyboard command.
All visible events should now be selected (i.e. all the mod-wheel events).
4. Click the note button again.

1 MNote = EZ &9 - — 212
323 Note =) EZ &9 — — 1 148
Control = & MModulation

T Cantral S 10 Maodulation

Z Modulation
dulation

dulation
0 Madulation

[N _, PEMRNY .
— B Bod Ok DOTR O Ok TR
—= ] W P k] R DR ]

—— 2 F 4 1 n+.:. = [ 20 1 =
You should now see all the notes and mod-wheel events with only the mod-
wheel events selected and all the notes not selected. This is a handy way to
select events of just one type in the Event List.
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5. De-select everything in the Event List by clicking in the thin border between
the list and the Event List window's Parameters Column.

Another way to do this is to use the "Select All" then "Toggle Selection" key
commands.

6. Select the first mod-wheel event in the list.

You may want to hide the notes again to make this easier to find. If its value
is not 0, change it to 0.

7. Choose: Event List E Edit ->Select Equal Objects.

You should see at least two mod-wheel events selected, the first one and the
last one. (Otherwise, the mod-wheel on your synth is not returning to 0
correctly.) "Select Equal Objects" means the same type of event and with the
same value.

8. Choose: Event List -> Edit -> Select Similar Objects.

You should see all the mod-wheel events selected. "Select Similar Objects"
means the same type of event with any value.

Adding Events

The Event Type buttons can also be used to add events in the Event List. You can do
this clicking the button with Logic's Pencil Tool, or by:

‘: Mac — holding the Command key while clicking

@ Windows — Right clicking
the appropriate Event Type Button.
In either case, the event will be add to the list at the current Song Position. Unless

Catch Mode is on, this will probably not be the position indicated by the Event List's
Position Arrow.

Copying Events
You can copy events in the Event list using at least three different methods:

Using the standard Copy/Paste operations;
1. Select the events to be copied

2. Select Event List -> Edit -> Copy or use the common key command
3. Select Event List -> Edit -> Paste or use the common key command
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Type in the start position at which you'd like the events to be pasted
Once you hit paste, all of the events in the clipboard are pasted and a text entry box
is automatically opened. Type in the starting position at which you'd like the events
to be inserted then hit Return or Enter.

Using the Copy MIDI Events window
1. Open Event List -> Edit -> Copy MIDI Events

=[1== Copy ™MIDI Events §|
2. Input the Left and Right
boundaries of the area you wish to
Left Locator 1 1 1 1 copy
Input the Left and Right bound-
Right Locatar 5 1 1 i | aries of the area you wish to copy in
the boxes labeled Left Locator and
Destination 1 1 1 Right Locator respectively.
: 3. Input the location where the
Murnber of Copies 2 events are to be pasted in the box
labeled Destination
Create New Sequence Input the location where the
events are to be pasted in the box
Made Lopy Replace ¥ labeled Destination
— 4. If you wish to paste multiple
|m| copies, input the number of copies
you wish

5. If you want the copied data to
be put into a completely new
Sequence, click once the right of "Create New Sequence" so that it says "ON".

If this option is not enabled, the events will be pasted into the originating
sequence.

6. Select the "Mode" you wish to use for the operation.

The mode dictates various aspects of what happens when you paste the data,
for example whether it will merge the events into any events that might
already exist at the destination, or whether it will replace those events with
the new. Please consult the user's manual for a detailed description of each
mode. For now, we'll use the mode, Copy Merge.

T1P The Left and Right locator settings are initially set to match the global
Left and Right locators, so a convenient way to define them is to set Cycle
boundaries by click dragging in a bar ruler BEFORE opening the Copy MIDI
Events window. (of course, this requires that a window be open that
contains a Bar Ruler)
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Using the Repeat Objects function

If you want to repeat a phrase or progression then this may be the best option to use,
especially if you want to repeat it more than one time

1. Select the events to be copied

2. Select Event List -> Edit -> Repeat Objects

==

Murnber of Copies

Repeat Objects =—
10

dd justrent Beat

[ Dot ]

3. Input the number of times you want the events repeated

4. Select the appropriate "Adjustment" setting

EE= Repeat 04 Auto
NMone
Murnber of Copies Bar
&d justrnent
Format
1/96
u Second
Frames
OFrames

This setting controls the exact position at which the events or objects will be
repeatedly pasted. If "None" is selected, the events or objects are pasted
exactly end to end. All of the other options will "round off" the paste posi-
tion to the nearest value selected. The "Auto" selection selects the most
logical selection based on the position and length of the material being
repeated. A little experimentation with this setting will make it clear how
each option effects the outcome.
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N O T E Both of the previous two copy options are available in all edit
windows. In windows in which you can view more than one Sequence at a
time — the Arrange, Event List and Score Windows — the operation will be
carried out on all selected objects.

Other Buttons/Menus

Below the Event Type Buttons, you'll find the standard Toolbox, a Quantization
menu and a little display for changing Logic's Display Format value. As mentioned
previously, changing the Display Format value changes the way in which event posi-
tions and lengths (for notes) are displayed because it defines the value of the sub-
division column. It is also dictates the step value when using MIDI Step Input. The
Quantization menu allows you to quantize only the selected events—we'll talk more
about quantization later in this section.

While the Event list is very useful because it allows you to see a lot of data in a rela-
tively small amount of space, sometimes a more graphic view of the events is more
conducive to certain types of editing. The next section examines one of the more
graphic oriented editors — The Matrix window.
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5.4 Working in the Matrix Editor

The Matrix editor provides a piano-roll view of MIDI note events.

(It is called "piano-roll" because it's a similar view to the paper how to:
rolls that used to be used in the old player pianos )The Matrix

Window is an especially useful window for adjusting Note pitch, ~ ® oPen the

duration and position. Matrix editor
window

Select the same Sequence you were viewing in the Event Editor ~ *® viewandedit

(the one with some mod-wheel and pitchbend in it) and choose: ;Z:‘*ir:’iLc;Ci'
Matrix editor
Windows -> Open Matrix Edit
e change the

=0 Hutuluad:nhuefﬁ =———oo[u g I\/(Ijatrix
. . . editor's
= .Eu:ht Functions Yiew | S F display grid
(Aol ————
e —— L i e select the top
-;irq: | . or bottom
— voice of a
== = multi-voice
— Sequence
| —
¢ select notes
% | o by other
: : i criteria in
@% _— |?-" the Matrix
?!1"]! II]_i]i]_i editor
% |i' * quantize
Y selected
% =E ﬁJiJi.Ii notes in the
Matrix editor
m— et
LY SR L T L it
|l i

E Here are some important things to remember about the Matrix editor:

* Notes are the primary MIDI event type shown in the Matrix editor.

We say "primary" because you can also see other event types by using the
Hyperdraw feature now accessible from within the Matrix Editor. You can
open and close this from the View menu—consult your Logic manual for
details.
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* Notes are represented by horizontal bars.

Their time position can be measured by the Bar Ruler and the vertical gridlines
that extend down from the Bar Ruler. (see below)

Their pitch is indicated by the keyboard graphic.
Their duration is represented by the length of the bar.
Their velocity is denoted by the color of their bar and also by a thin line within

their bar. (The length of this thin line relative to the length of the whole bar
is what indicates the velocity.)

e There is a Bar Ruler across the top (just like the Arrange window) which indi-
cates the time position.

e There is a keyboard graphic down the left side which represents note
pitches.

e There are vertical "gridlines" through the editing part of the window.
e Solid lines indicate bars.
e Fine dotted lines indicate beats.
e Coarse dotted lines indicate "divisions".

e There is a Display Format setting and Quantize menu to the
left of the time line.

These serve the same function as in the Event List discussed
previously.

TIP If you want to know how many "divisions" there are per quarter note,
divide by 4. (For example, "/12" = 12 divisions per whole note = 3 divisions
per quarter note = 8th note triplets.)
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e The "In" and "Out" buttons serve the same purpose as in the Event List.

TI1P You can use the computer's left and right arrow keys to move the selec-
tion back and forth within the Matrix editor. If you hold down the Shift key,
notes will be added to the selection. If the "Out" button is on (Mac— blue
Windows — gray) you will hear each note as it is selected. (If you keep
holding an arrow key, the whole Sequence will play back on a note-by-note
basis—forwards or backwards!).

e You can move selections around within the Matrix editor window
Moving the objects around changes their pitch and/or position.

e You can change the length of all selected objects by clicking at the right edge
of any of the selected objects and dragging.

Mac —The pointing-finger cursor indicates length change. The full hand
cursor indicates position change.

Windows — The left/right arrow indicates length change. The cross-hair indi-
cates position change)

Quantizing selected notes

At some point you may wish to quantize only a selection of notes rather than all the
notes within a sequence — which of course is what happens when you quantize from
the Sequence Parameter Box. There is a Quantize menu which allows you to do this
within each of the edit windows including; the Event List, Matrix, Hyper and Score
windows.

Let's take a look at how to use this feature within the Matrix. In the process we’'ll
check out a few other special selection options, including one which allows you to
select specific lines in a multi-voice part.

We’'ll need to be looking at one of the Sequences you recorded earlier in this section,
or, if you're just jumping in at this point, any Sequence contain notes you performed
along with the metronome.

1. Choose a Display Format value which puts grid lines close to the beginning
of all notes in the Sequence.
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Since you recorded in time with the metronome, this should not be too diffi-
cult. Start by increasing the zoom then change the value until you get the
desired result. (Unless you're Chick Corea, /8, /12 or /16 will probably do it.)

2. Turn Cycle Mode on and set its boundaries to match the beginning and end
of your piece’s three choruses.

3. Choose the lowest voice by choosing:

Matrix -> Functions -> Note Events -> Select Bottom Line.
If you did not record a multi-voice part, this step will just select everything.

4. Limit the selection to the first chorus by choosing:
Matrix -> Edit -> De-select Outside Locators
5. Quantize to the same value as the Display Format setting.
e Click on the "Q" button to pop-open the Quantize menu.

* Select the same setting as is displayed in the Division box above

1/ 6-Haote
1/ 3-Mate
1/12-MNote
1/16-MNote
1/24-Mote
1/32-Mote
1/48-Mote
1/64-Mote

Edit Fu

You should now see the notes in the bottom voice, within the Cycle Locators,
adjust slightly to line up exactly with the grid lines.

6. Playback this chorus of your song.

How this sounds will depend on the kind of material in the Sequence and how
close your playing was to the metronome in the first place. The important
points to have learned are: you can quantize a selection of notes; the Matrix
editor makes it easy to see the results; and there are various useful selection
techniques. The more you use Logic, the more you will appreciate these extra
little features.

TIP You can use the Matrix editor's "Q" tool to selectively quantize notes E
or selections of notes. You can also assign key commands to quantize and
"quantize again".
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De-Quantizing Notes

You can perform the opposite of the above described feature, i.e., you can defeat the Se-
quence Parameter Quantize for the selection of notes. Logic refers to this as De-quan-
tize. The procedure for applying this option is easy.

1. Select the notes you wish to De-Quantize

2. Select Matrix -> Edit -> De-Quantize.

The selected notes will no longer be effected by the Quantize value selected
in the Sequence Parameter Box.
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5.5 Working in the Score Editor

Logic's Score editor provides the most traditional view of your
music—standard musical notation. While the subject of Score
Layout and Printing is too extensive to cover here, we can
examine the basics of getting around this window for the
purposes of editing note events.

We will also look briefly at the settings which govern how Logic
interprets your MIDI performance and turns it into a readable
score.

Close the Matrix editor and select two Sequences on separate
Tracks in the Arrange window (avoid a drum part if possible).
Then open the Score editor by choosing:

Windows -> Open Score

The Score editor will open up displaying separate staves for each
selected part.

EI_E Autoload#4 EEEI
Layout Edit Functions Attributes Text YWiew Oplions| =

how to:

e open the
Score editor

e control what
Sequences
aredisplayed
in the score

e view the
score a line
or page at a
time

* move
between
multi-staff
and single
staff views

e quantize the
score display

@. without
affecting
. the notes in
the
Sequence
Piano/Bass .
e Insert or Edit
Time and
= 8333 2 Key Signa-
Style Bass tures
LJua 16 e change the
Interpretation [N : | T | Clef Type
Syncopation  oFFf — —
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Here are some important points to remember about the Score editor
window:

e The Score editor can display more than one Sequence at a time.

To view one Sequence, double-click directly on its staff lines. To view all
Sequences, double-click in the white background of the Score display. You
can limit what tracks are displayed by using Instrument Sets . (see below)

TI1P If you select sequences from several Tracks be-
fore opening the Score editor, Logic automatically
creates an Instrument Set containing just the Instru-
ments for those Tracks.

e Each Sequence has its own staff system.

This may contain one or more staves depending on the Score Style assigned
to the part.

Style Bass

106
ON

A Score Style is simply a collection of settings that control such elements of
the display as: clef type; staff size and style (standard, percussion, or guitar
tablature); # of staves, # of polyphonic voices, and display transposition. The
separate systems are in the same vertical order as their Tracks in the Arrange
window — unless an Instrument Set is being used that changes that order.

¢ There is a “View Button" to the left of the Bar Ruler

This button provides a quick way to toggle "Page
— @ View" on and off. In Page View, the score “wraps
@ around”, as it would when printing. If it is off, the
@l score runs continuously from left to right, just as it

does in the Arrange Window.

* The Instrument Set selection menu controls the order and selection of Instru-
ments being viewed
Below the buttons is the Instrument Set selection menu. This is where you tell

Logic what Instrument set you want displayed in the Score. An Instrument Set
filters the display based on the Instruments used in the song.

Logic Audio Guidebook 5-143



o

TIP If you hold the: Mac — Option key; Windows — Control key; while
opening this menu, you will see a list of the Instruments that are currently
used in the song. Selecting one of these will cause the Score to temporarily
only display tracks using that particular Instrument.

e The Display Parameter box settings control how notation is displayed

The Display Parameter box is just below the Instrument Set pop-up menu. It
contains some very important settings which effect how notes in a Sequence
are displayed. This is where you select the Score Style and Display Quantiza-
tion values for example.

\

Style  Plano
Glua default

Interpretation

Syncopation

Mo Cwerlap
Flax. Oots

e The Event Parameter box displays current values for selected events
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= Piano
The Event parameter box is
just below the Display Param- < Inzert Defaults
eter Box and contains values
for the currently selected
event or events. The type and .
number of parameters will Test Plain Text P
change to reflect the type of Lyrie: off :
event selected.

LI

Weloity b4

ﬁ%m Ffpls o[ SH=h

e The Parts boxes contain notes, symbols, E I| |||EE| S |A| % |'|=|

etc. that can be dragged onto the score = r, rg E gg

The Parts boxes are just below the = r’ r F
Toolbox. They are used for selecting notes g E g

and other score symbols for insertion in 3

the score.

ﬂ;a &
Y Py P e
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Controlling note display

If Logic represented your MIDI performances on the staff with perfect accuracy, the
resulting score would probably be unreadable. That is because standard notation is
actually a somewhat crude system which conveys only the most basic information
about the music it represents. Even with the various symbols and standardized
descriptive text options, much of the musical nuance is left to the performer’s inter-
pretation. Here is a brief summary of how each of these settings effect how Logic
renders MIDI events as notes on a staff.

e Display Quantization ( Qua)

This is probably the most important of all the
settings in this box. Just like normal quantiza-
tion, display quantization snaps the position St Piann

of notes to a definable grid. The difference is Qua default
that this setting is for display purposes only (as
the name implies), i.e., it has no effect on how
the music is played back. The range of options
are exactly the same as the other Quantize
menus available throughout the program. A
setting of oDefault means the value is deter-
mined by the Display Format Value.

nEerpretation iy

Syncopation off
Mo Cerlap ON
Maz. Dot= 1

* Interpretation ( Int)

This setting functions somewhat like a display-
only length quantize. Depending on the notes
surrounding a note, its displayed length is Stgle  Piano
changed to make it more readable. For

example, imagine that you played a series of
very staccato 8th notes. Without Interpreta-

tion, these would likely be displayed as very
small note values, say 1/64th notes,
surrounded by a clutter of small rests.

yrcopation
Mo Overlap
Plan. Oots

TIP It is generally best to leave Interpretation and Display Quantization
OFF for sequences that have been step entered. That is because, in that case,
the note values are the perfect length and at exact positions so there is no
need for Logic to "interpret" the notes for score display. In fact, the these
features may actually cause the score display to look like something other
than what was intended.
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e Syncopation ( Sync)

This setting controls how syncopated rhythms
are displayed. An example would be a figure
involving an eighth note on the down beat,
followed by a quarter note on the “and” of
the same beat. If Syncopation is off, the first
eighth note would be beamed to an eighth
note tied which is to an eighth note on the
next downbeat. If it is on, the starting eighth
note would not be beamed and the quarter
note would be notated as a quarter note and
not tied to anything.

No Overlap

This option examines the lengths of notes and
suppresses ties when notes overlap. This is
especially useful for legato passages where
notes might overlap one another just for a few
ticks.

Maximum Dots ( Max. Dots )

This setting limits the amount of dots allowed
when notating dotted note values. If you
don’t like triple dotted notes gracing your
staff, this option is for you.

Inserting Event

Inserting notes onto a staff in the Score window is

easy.
Select the Sequence into which you wish to insert the notes

To select a Sequence in the Score window, click once on the staff lines of the
Sequence. Staves that are selected have solid black staff lines, those that

1.

aren’t have grayed-out ones.

Piano
default

Sthyle

Syncopation
wJo Liverlap
Maz Dot

Piano
default

Style
Glua
Interpretation

Mo Overlap

Piano
default
ON
off

i CIye il

Style
Clua
Interpretation

Syncopation
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N O T E There must be at least one Sequence in the Song before you can enter
anything in the Score window. If there isn’t, the score will simply display the text —
Nothing to Display . You can create a blank Sequence in the Arrange window by
clicking once with the Pencil tool in the main, gray-background area of the Arrange
Window.

2. Select the note value

Select the note value, i.e. eighth, quarter, etc., that you wish to insert from
the Part box in the left hand column

3. Insert the note

Drag the note from the part box over to the staff onto which you are inserting
the note OR, select the Pencil tool and click on the staff where you wish to
insert the note. In either case, use the Control Line described in the Arrange
window section

T1P There are a series of definable key commands for selecting note values

TIP The smaller part box at the top can be used to bring a specific category
of note values or symbols to the top of the main part box below it. In the
case of note values, the box actually has three hot spots, one for each of the
note value types available. Click on the note symbol to bring up all duple
note values, the “3“, to bring up triplet note values, and the “ . “(dot), to
bring up dotted note values.

¥fplsalts

= ey

You can use the procedures described for MIDI Step Input to insert notes in the Score
window.
Copying/Moving Events

You can copy or move notes in the Score window using the same facilities already
described for other windows including: standard Copy/Paste functions, Copy MIDI
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Events, and Repeat Objects.

the Score window it is important to understand that rests (accept for User
Rests — see your User’s Manual) are not actual events and so cannot be
pasted. Therefore, you must be careful Paste events at the correct starting
position. For example, imagine you are Copy/Pasting a 4/4 measure that starts with
a rest. Even if you highlight the whole measure before copying, the only events
copied will be those starting at beat 2. When you Paste the events you must there-
fore start at beat 2 of a particular measure. (i.e., X2 1 1)

@ W ARNING When you are using standard Copy/Paste procedures in

Logic also has two special paste options yet to be discussed that may be of special
interest when working in the Score window.

Paste at Original Position

This option is tailor made for copying phrases from one part to another because you
can do so without paying attention to the Song Position.

1. Copy the Notes you wish to paste

Highlight the notes to copy, then choose Copy from the Edit menu ( or use the
familiar key command).

2. Select the destination Sequence

Select the Sequence to which you wish to paste the events by clicking once on
the staff lines of that part

3. Select Score -> Edit -> Paste at Original Position (or use the definable key
command for this function)
Paste Multiple
This options allows you to paste events into multiple Sequences with one command.
1. Copy the Notes you wish to paste

Highlight the notes to copy, then choose Copy from the Edit menu or use the
familiar key command

2. Move the song position to the location at which the notes are to be pasted.
The Goto Position... key command is ideal for this purpose
3. Select the staves to which the events are to be pasted

4. Select multiple staves by holding down the Shift key while clicking on the
staff lines of each of the staves to be selected

5. Select Score -> Edit -> Paste Multiple
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TIP This option can be used effectively to Copy/Paste dynamic markings
and symbols that need to reside on multiple parts.

Changing the Clef type

As mentioned earlier, the clef type is part of a group of score display parameters that
are saved collectively as a Score Style. Logic’s default song contains a basic collection
of Score Styles which cover the majority of circumstances. Many of these basic Styles
are named based on their clef type, so selection for this purpose is easy.

To select a Score Style:
1. Make sure the Sequence (Staff) you want to apply the Style to is selected

2. Click-hold your mouse to the right of the word Style in the Display
Parameter Box

3. Choose an appropriate Style from the flip-up menu

itself, then selecting from the resulting selection box, BUT, this necessarily
changes the clef used for the currently assigned Style which creates two
potential problems: a Style called “Treble” might end up with a Tenor clef,
and; other Sequences using that Style will be changed unintentionally.

E N O T E You can also change the clef type by double-clicking on the clef

E[I=———— ClefT Selector §—|

S
Treble

Time and Key Signatures

Changing or inserting Time Signatures was already covered in the Recording chapter.
Changing or inserting Key signatures is handled in very much the same way.

To change an existing key signature

1. Double-click on the Key Signature
2. Select the desired key and mode (major or minor) in the resulting window
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To insert a key signature

1. Click on the key signature symbol in the top part box

PHEZ Xl o35
B[ A% |
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This brings the palette of key signature options to the top of the main part

box

-7

Drag the Key Signature to the staff

Click-drag the key signature from the part box to the desired destination on

any staff.

ey o Ve lfpﬁt';‘*;

&I A% |J-|

H £

Ck Gk OF AF E

Di#m A#m

Abm Ebm Bbm Fra

m Em Bm F#m CH#mn Gmn

N O T E Since time and key signatures are global objects it doesn’t matter
ﬁ what staff you perform the edit on
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5.6 Mix Automation

Automated mixing is relatively easy in Logic. The process is much

the same as for recording and playing back all other types of  how to:
MIDI data. This is because the the on-screen faders and knobs

generate and respond to MIDI data much like your “real” MID| ~ ® record and
devices. The essential step is to make sure the the MIDI data is playbackiihne

recorded and played back on a track assigned to an appropriate :‘:‘is;'ts of a
instrument. There are essentially three “appropriate” instru-
ments to use: ¢ have your
mixer
respond to
e The MIDI Instrument that is being automated an auto-
mated mix

This could be any type of Instrument (Multi, Mapped, etc.).
While this will cause the instrument’s Volume or Pan
settings to change, the drawback is that the fader itself will
not update in response to the automation.

The other limitation of this option is that you cannot record multiple channels
of automation of one track. That is because MIDI data in a sequence is always
"re-channelized" by the channel of the Instrument assigned to the track on
which it is playing. So, for example, if you recorded fader movements for
channel 1 and 2 on a track assigned to an Instrument set to channel 1, the
channel 1 fader would respond to both channels of data, and fader 2 would
not respond at all.

e The fader or GM Mixer that generated the data

This is generally a better method than the first because it causes the on-screen
faders to move in response to the automated changes. If you're using the GM
Mixer, then you can record multiple channels of automation on a single track.
The mix data will be sent to the channel it is intended, for because each event
is distributed according to its “event channel”.

e A Cable Splitter that is cabled to the faders or Audio objects generating the
data

This method uses an Environment Cable Splitter object as a pipeline to
distribute the data to the faders being automated. A good example of this is
the A-Playback object that Logic Audio creates in its default song. This object
is a Channel Splitter cabled to all of the Audio Objects. If you're using single
fader objects or the Audio Objects, this is generally the best option.
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N OTE Logic has three useful mixer automation modes: "Merge",
"Replace" and "Update". For complete details on how to use these automa-
tion modes, consult your Logic manual.

HyperDraw—Another Mixing Tool

Guitar 1

-

On-screen mixing consoles are great for real-time mixing, and displaying or modi-
fying mixes created with with external hardware controller surfaces. However, Logic
offers another approach to entering, editing and recording MIDI mixing information
that you should also explore — it's called HyperDraw. (A Logic Editor called the
Hyper Edit Windows is also available for manipulating this data—consult your Logic
manual for details.)

HyperDraw provides a graph-like interface for inputting and modifying controller
data. It allows you to draw controller data patterns directly into Logic Sequences in
the Arrange window. It is also available in all Logic Editor windows.

The types of information HyperDraw will allow you to create and edit include all
controller information, pitch bend, note velocities, channel pressure (a.k.a. after-
touch) and program changes. You select exactly which information you wish to work
on (one at a time, please) when you enable the HyperDraw view for a sequence or
Audio region.

Here are the steps to create or edit MIDI volume information for a Sequence (or
Audio Region) in the Arrange window using HyperDraw:

1. Select a Sequence (or Audio Region)

You use HyperDraw on one Sequence at a time. It also necessary to be at a
relatively high zoom level to view and edit comfortably. So, the first step is to
select a Sequence (or Audio Region) in the Arrange window into which you
wish to enter (or edit) volume information using HyperDraw. Use the
Arrange window's Zoom Tools (or the Toolbox's Magnifier Tool) to Zoom the
sequence to a large size in both the horizontal and vertical directions.
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2. Activate HyperDraw for Volume
Activate HyperDraw for the selected Sequence by choosing:

Arrange > Options > HyperDraw > Volume

Logic will activate HyperDraw for MIDI controller #7 (volume) an the same
channel as the Track's Instrument uses.

you to specify HyperDraw choices—Autodefine tries to match other
controller data in the same Sequence and Channel selects a specific channel
number.

E N O T E Two other choices from this menu, Autodefine and Channel allow

If you wish to manually select a controller number and channel, choose:
Arrange > Options > HyperDraw > Other

3. Draw in the Controller Information

You enter controller data in HyperDraw by clicking (and dragging) with the
mouse. A click enters a single data point. Clicking on an existing data point
deletes it. A click and drag enters a straight line of data points between the
mouse-down and mouse-up locations.

T1P Dragging with the;
Windows — Alt Mac — Control

key held down restricts dragging to the vertical—very handy for changing a
single data point's value. Dragging with the;

Windows — Control Mac — Option

key held down causes the selected data point and all later data points to follow the
dragging. (i.e., you can move a whole data curve up and down this way.)

4. Deactivate HyperDraw

When you're finished, deactivate HyperDraw by choosing:
Arrange > Options > HyperDraw > Disable

This is a good habit to get into. Otherwise, you may accidentally change
controller data in a Sequence when you only intend to select or move the
Sequence around in the Arrange window.
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5.7 Other Useful Editing Tools

The following features can be very handy when you are in the
process of editing.

Markers

When working on a Song, it's often convenient to be able to
"mark off" sections for future reference. For example, you
might mark the three choruses of your song to provide visual
cues and/or as a way to locate to their beginning quickly and
easily. Logic's Markers are designed specifically for this purpose.
These markers also can function as a sort of "timed notepad"
because you are able to type in up to 20,000 characters of text
into each Marker.

N O TE While markers are not an editing feature per se, it
certainly facilitates the process of editing. That is why it is
included in this chapter.

Let's create markers for the three choruses of your Song:
1. Create a marker for the first chorus
Move the SPL to the beginning of the first chorus then

how to:

create
markers

create sepa-
rate tracks
after
recording
from
external
sequencer

de-mix a

sequence
based on
pitch

nudge
Sequence or
MIDI events

keep written

choose: Arrange -> Options -> Marker -> Create ?;’rfgs i
e cut/copy/past
Marker e Key and
IIIIIIIIIIIIIIIIIIIIIIIIII TimeSigna-
tures
This inserts a marker at the current Song Positions. It willbe  « time lock
visible in the Arrange window's Bar Ruler as a white box some or all
with the label "Marker 1" in it. Note that the box extends notes in a
the full length of the Song. Sequence
2. Create a marker for the second chorus e conform
Move the SPL to the beginning of the second chorus and Logic’s
create another marker. This Marker will be labeled "Marker tempos to
2". It will terminate "Marker 1" and extend to the end of ff;atd][ a
the Song. €gato
perfor-
mance.
Marker 2 (Reclock)
I L1 | I L1 | 11 I 11 I 11 I 11 11 I 11 I 11 I
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3. Create a marker for the third chorus using "Create by Objects" method
Select the Sequence that plays only in the third chorus of your Song.

Marker 2

This time, create the Marker by choosing:
Arrange -> Options -> Marker -> Create by Objects

Marker 2 Melady 3 |

Notice that this time, the Marker is the same length as the selected Sequence
it was created from and that it is named after this Sequence.

TI1P If you click on a Marker, then drag upward until the pointer turns into
a finger pointing up, releasing the mouse will set Logic's Cycle to the marker
and turn Cycle Mode on. If you drag downward until the pointer turns into
a down-pointing thumb, releasing the mouse will delete the marker.

Logic keeps a list of your Markers in a special Marker list window. To see and use this
list, choose: Arrange -> Options -> Marker -> Open List
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S[I=————— Marker List g@gl
Edit Options =
ﬁﬁnn MARKER _HAME LENGTH R
| m IE ------------- Startof List -------------
2 1 1 1 Marker 1 - 1
| 13 1 1 | Marker 2. _ _ __ 1
171 1 1 Melady 3 & 0 0 0 |
------------- End of Ligt - --------------- 7
| i

Three useful things to remember about the Marker list :
e Clicking on an item in the list moves the SPL to the beginning of that Marker

e You can edit the Markers position and length in the list.

If you change the length to anything but "- - - 1" you will set an "absolute"
length for the Marker. "--- 1" indicates the Marker extends to the next
Marker.

e Double-clicking on an item in the list opens the Marker's text window.

Here you can type in any text you wish. The top line of text is what appears
in the marker on the Bar Ruler. You get back to the list by clicking the book
icon at the left.

The Event Float

One very useful feature in Logic is a special little device called the Event Float. The
Event float can be opened from any of the edit windows and functions like a single
line of the Event list. The event (or object) displayed is always the last one selected
in any of the open edit windows You can edit its parameters by scrolling them with
the mouse, or by double-clicking and typing in the a value. It thereby provides the
same facility as the Event list editor but without taking up nearly as much screen real
estate.

Open the Event Float from the Matrix editor by choosing:
Matrix -> View -> Event Float ...

# acoustic loop

1 Melody 3
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TI1P If you scroll a parameter for a note event you will hear the note sound
over and over—once for each step in the parameter. To turn this off, hold
the Mac Only —Command key and click the little "film" icon at the left edge
of the Event Float. (Clicking here without using a modifier changes the time
display between SMPTE and the usual format.)

As an example, let's use the Event Float to increase the velocities of the notes that
make up the melody in the Sequence we are viewing in the Matrix editor.

1. Select the top line of the Sequence in the Matrix editor by choosing:

Matrix -> Functions -> Note Events -> Select Top Line

2. Click on the velocity of the displayed note in the Event Float and scroll the
value up and down.

3. Observe the colors of the selected (top line) notes change as you scroll.

This indicates that the velocities of all selected notes are increasing (hotter
colors) and decreasing (cooler colors).

N O T E Changes you make with the Event Float apply to ALL selected
events—not just the single event displayed in the Event Float.

T1P Using the Event Float in the Arrange window is a great way to numer-
ically change the position and/or length of Sequences and Folders.

Global Editing

Most of the editing discussed up to this point effects only a songs MIDI events and
not the global events which are an important part of a song’s structure. Global
events include the Time and Key Signatures, the Tempo events as well as any other
Score elements which automatically appear on all staves when inserted on one.
While these events can be edited directly, Logic has a few special features for editing
MIDI and global events simultaneously.

All of these features are accessed from the Arrange Window

To Insert blank measures in the middle of a Song (Insert)

1. Set the Left locator at the position at which the new blank section is to begin.
2. Set the Right locator to the position at which the new blank section is to end.
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TI1P A convenient way to perform these first two steps is to highlight the
area in the Bar Ruler, the same way you do when defining the start and end
points of a Cycle.

3. Select all objects in the Arrange window.

(If you wish to edit only the Global events, then don’t select any objects in the
Arrange window. )

4. Select Arrange -> Structure -> Cutl/insert time -> Insert Time and Move by
Locators

To Remove measures in the middle of the Song (Snip)
Perform the same three steps as the previous procedure then,

1. Select Arrange -> Structure -> Cutl/insert time -> Snip: Cut time and move by
locators

To Remove measures and Insert them elsewhere (Splice)
Perform all the steps as the previous exercise then,
1. Move the song position to the place where you wish to insert the measures

2. Select Arrange -> Structure -> Cutlinsert time -> Splice: Insert Snipped part
at Song Position

TI1P You can use the previous operation to copy a section and move it else-
where. Just select Edit -> Undo (or use the keyboard equivalent) after Step
4. This reverses the Snip process, but, since the material is still in the clip-
board, you are still able to Splice it.

Demixing

Logic has two useful features which allow you to split up the events in a sequence
into separate sequences based on either on Note pitch or by event MIDI channel.
The most common use for the first option is to convert a composite percussion track
into separate tracks for each instrument, i.e., one for Kick, one for Snare, etc. The
second option is often used after recording a track from an external sequencer which
has transmitted separate parts on different MIDI channels.

option so multiple tracks must first be recorded on one track then de-mixed.
This applies when recording from an external sequencer (as just mentioned)
or when recording the output of multiple MIDI controllersiplayers. In the
latter case, you simply need to make sure each controller is transmitting on a sepa-

E N O TE Logic does not currently have a "multi-track" MIDI recording
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rate channel.

De-Mixing by Event Channel

1. From the Arrange window, select the Sequence to be De-Mixed
2. Select Arrange -> Structure -> SplitIDemix -> Demix by Event Channel

Logic attempts to place the de-mixed sequences on tracks assigned to Instru-

ments whose MIDI channels are equal to the de-mixed event's event channel.
Whew!

In other words, events that were originally on Channel 1, will be placed on the

next available track that has an Instrument assigned to channel 1, etc.. If

Logic cannot find such a track, it will create new track to accomadate the new

sequences.

De-Mixing by Pitch
1. From the Arrange window, select the Sequence to be De-Mixed
2. Select Arrange -> Structure -> SplitiDemix -> Demix by Pitch
LOGIC pastes the new Sequences consecutively into newly created tracks

Using the Computer Keyboard to "nudge” values

In the Event List we changed MIDI event parameters by either scrolling the numerical
display or double-clicking and typing in values. In the graphic editors (Matrix and
Score) we also grabbed notes and dragged them to different locations or pitches.
You can also do many of these things from your computer keyboard. There are two
ways:

e Assign and use the "Nudge” key commands.

These key commands which all appear in the "Arrange and Various Sequence
Editors" section of the Key Commands window allow you to "nudge" the
selected notes' position, length, pitch and channel. For position and length
there are separate commands for bar, beat, division (called "Format") and
tick.

e Use the "+" and "-" keys on the numeric keypad after first making an adjust-
ment with the mouse.
For example, after you've changed a note's pitch in the Event List using the

mouse, using the "+" or "-" key will again change the pitch by one increment.
(This only works with numerical displays, however.)
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Reclock

When you enter data using Step-time Recording, or by playing along with Logic's
metronome, your performance will fall suitably within the bars and beats structure
of the song. This insures that quantization will have appropriate musical results and
that the score window can properly notate the events. But what happens when you
record freely, without a metronome, or import a Sequence with unknown tempo
changes? If the music is of a particularly rubato character (i.e., has a lot of varying
tempi), any quantizing will likely lead to disaster, and the score could end up virtually
unreadable. To illustrate this, walk through the following steps.

1. Select all the Sequences in your current Song and mute them.

You may find it easiest to first pack them into a Folder and then mute the
Folder.

2. Select an empty Track and assign it a relatively percussive Instrument
Drums, bass or even piano is good—a string pad is not the best choice.
3. Record quarter notes without metronome

With the metronome off, record a series of quarter-notes as regularly as you
can.

4. Turn the metronome on and play the Sequence back.
5. Look at the Sequence in a Matrix editor.

Autoload:Reclock 1/4

nctions Wiew

Chances are the notes are nowhere near the quarter-note gridlines. (If they
are, do it over again trying harder to get it wrong.)

Fortunately, Logic provides a some useful tools for dealing with this scenario. The
primary one is called Reclock.

The function of Reclock is to adjust the position of the bars and beats so that they
conform with the intrinsic bar and beat positions of an existing music passage. It
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does this in the only way possible, by inserting a series of tempo events in between
those bars and beats where necessary.

There are two basic ways to use the Reclock function — with or without using a
Guide Sequence. The more tedious and ‘'manual’ approach is to use it without using
a Guide Sequence. With that method, you select a note or range of notes, manually
input their intended bar and beat position, then let Reclock calculate the correct
tempo value which forces them to those positions.

The Guide Sequence method automates much of the process by providing a grid
which Reclock can use to ascertain the intended bar and beat positions. This is the
option that we will use here. Please consult your user's manual for details on using
Reclock without the use of a Guide Sequence.

1. Select the Sequence in the Arrange window and choose: Arrange -> Func-
tions -> Reclock Song

This opens the Reclock Song window which can which is where all the perti-
nent settings for this feature are selected.

2. Make the following settings in the Reclock Song window:

= Recloctk Song =——————— |

[ Use Guide Sequence

(<] Create Tempo Changes to preseryve timing
[ Use only Selected Events as Source

(<] Reclock only within Left and Right Source

1 2 E s B B T E = 1@ (11 (12 [1= (14 [1E [1&

[ /S S

1 = 5 I3 E & T = £l 1 11 1= 1= 14 15 1&

—Source Terpo

03.80888
—1 &t Destination Step increment Deztination Termpo—
i 1 1 1| [/ 4 81.35114

(Reciock)
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e Enable "Use Guide Sequence"
This means that the selected Sequence will be used to decide the tempo changes.
e Enable "Create Tempo Changes to preserve timing"

This means that tempo events will be inserted between the notes in the guide
Sequence, so that they will line up with perfect bar and beat positions.

e De-select "Use only Selected Events as Source"

When this option is selected, only the selected notes in the Sequence are consid-
ered during the process. This is useful when using an actual musical passage for
your guide, because you are able to carefully select only those notes that are
supposed to be at the Step Increment (see below) positions. In our case, all notes
are to be considered, so the option should be disabled.

e Enable "Reclock only within Left and Right Source"
e Set the Left Destinationto "111 1"

This is where the reclocking begins and where we wish the first quarter note in
the Guide Sequence to be at the end of the procedure.

e Set Step Increment" to " /14"

Since the notes in our Guide Sequence are intended to be quarter-notes, we set
this value to "/4". If the Guide Sequence notes were whole notes, you'd select,
"/1": half notes, "/2", etc.

3. Click the "Reclock" button.

If you look in the Matrix Editor now, you will see that each note is exactly on
a quarter-note gridline.

Autoload:Reclock 1/4

nctions Wiesw
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If you look at the Tempo List, you will see tempo changes at each quarter-note

position.
| Edit Option| | C= =
EAF FOSTITION — — TEHMFEO AT SHMFETE FOSITIOH Ii
1 1 1 1 Tempo 93.0000 at 00:00:00:16.10
1 2 1 1 Tempo §1.4595 at 00:00:01:05.35
1 3 1 1 Tempo §4.3059 at 00:00:01:27.46
1 4 1 1 Tempo §2.5135 at 00:00:02:18.74
2 1 1 1 Tempo §3.0511 at 00:00:03:10.59
s 2 2 1 1 Tempo 536733 at 00:00:04:02.33 O

what you expected or desire, then immediately Undo the operation before
trying again. DO NOT simply delete the Tempo events that were created.
This will cause you to irretrievably lose the original timing of the perfor-
mance.

& W A R NI N G Ifafter performing a Reclock function, the results are not

TIP When necessary, Reclock can be used effectively to create a tempo map
based on an imported audio file. Start by recording a track of even whole,
half, or quarter notes which follow the tempo contour of the audio file.
Next, use that track as your Guide Sequence when performing the Reclock
function. Depending on the material, you can also experiment with creating
your Guide Sequence using the Digital Factory's "Audio to Groove" or
"Audio to Score" options.
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Using Lock to SMPTE Position as a method of reclocking

If you're having a hard time grasping exactly what Reclock is doing, running through
the following exercise might help you to understand. It uses a feature we haven't
covered in this guidebook — Lock to SMPTE Position — to help illustrate Reclock’s
function. Lock to SMPTE Position locks events or objects to SMPTE positions so that
tempo changes will not change their SMPTE position. This is an indispensable tool
for film composers and foley artists. Here, we'll show how the feature can be used
to move the bar and beat grid "underneath"” the notes, without changing the actual
time distance between them. (their rhythm)

Before beginning this exercise, you will need to have a Sequence containing freely
played quarter notes such as the one that was created at the beginning of the reclock
section.

1. Create a screenset with the following configuration:
e An open Arrange window
e An Open Matrix editor with Show Contents turned ON

It should also be set to view the quarter-note Sequence you just recorded. Also,
turn on the Ruler Bar's SMPTE view by choosing: Matrix -> View -> Hide/Show
SMPTE Time Ruler

e An open Event List showing the contents of the quarter-note Sequence

Make sure the Event List is NOT showing the position in SMPTE. (If itis, use the
View menu to change it.)

e An open Tempo List

Open this by choosing: Arrange -> Options -> Tempo & Synchronization -> Tempo
List Editor. Make sure that there is only one tempo event in the list at position
"1111", with a tempo setting of 120.

2. Move the Sequencetobar1111

Move the Sequence in the Arrange window until its left edge is at the begin-
ning of the Song (position 111 1).
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When you're through, it should something like this:

IE_|_IE Global Tempo Ewgi
Edit Option| | el

I EEEEEE——S— —
_IH ERFE FOSTITICOH TEMFC AT SEHMFTE FOEITIO
E Z0.0000 at Q0:00:16:29 17

Create |

=il
= | Edit Functions Yiew | C== ==
) B ot L i O | O 0
: | | | | | | | |
'ﬁl SLUE-E BRI pEscmemmm
_— i i i S
el
= | Edit Functions Wiew| E= =
FOSTITION SETATUS CHA MUM  L'AL  LEMGTH/IHMFO
o fer-
< E ————————————— Startof List -------------
00:00:00:13.61 J4 BZ 78 00:00:00:01.64
s 00:00:00:20.59 J4 BZ g5 00:00:00:04.72
IH 00:00:00:29.35 J4 BZ 75 00:00:00:04.76

3. Change the position of the first noteto 1111

Select all notes in the Event List and change the the first note's position to "1
111". (All other note positions will be shifted the same amount so that the
sound doesn't change.)

4. Take note of 2nd bar's SMPTE Position

Top the Matrix window and notice that the second bar starts at the 2 second
SMPTE mark. (120 quarter-notes per minute = 2 quarter-notes per second so
that one measure takes 2 seconds.)
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5. Notice how tempo changes effect SMPTE and Bar/Beat values

Change the tempo in the Tempo List and notice that only the SMPTE markings
move. The notes maintain their relationship to the barlines but changing the
tempo changes the time-length of a bar. After you've experimented with
this, return the tempo to 120.

6. Lock the SMPTE Position of notes

Select all notes then choose: Matrix (or Event) -> Functions -> Lock SMPTE
Position

7. Adjust the Tempo

Now change the tempo again as in step 5 and notice that the notes move
along with the SMPTE markings. The notes are locked to their position in time
and the Sequence will sound the same no matter what tempo changes you
make in Logic. (If you look at the Sequence in the Event List, you will see a
little lock icon next to each note.)

8. Adjust first tempo event until fifth quarterisat2 111

Change the tempo at position "1 1 1 1" so that the fifth quarter-note is
exactly at position "2 11 1". The easiest way to do this is to change one digit
in the Tempo List then use the "+" and "-" keys to nudge that digit until the
noteisascloseto "2 111" as possible. Then change the next digit to the right
and nudge again, etc.

9. Input new tempo eventat2 111

Set Logic's Song Positionto "2 1 1 1" and create a tempo event in the Tempo
List at this position. Do this by clicking the "Create" button in the Tempo List
window.

10. Adjust second tempo event until ninth quarterisat3 11 1

Change the tempo event at position "2 1 1 1" until the 9th quarter-note's
positionis "3 111",

11. Input new tempo event at 3 1 1 1 and adjust tempo

Insert at tempo event at position "3 11 1" and change its value until the 13th
quarter-note's positionis "4 11 1".

12. Unlock all notes
13. Select all the notes and unlock them by choosing:

Matrix (or Event) -> Functions -> Unlock SMPTE Position

Your Sequence of 16 quarter-notes will now be pretty much in line with
Logic's barlines. Most likely the notes not on downbeats will be a little off,
reflecting the "groove" or your playing.
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What You Have Learned in This Section

In this section you have seen how to select and move Sequences around in Logic's
Arrange window. You have learned how to pack Sequences into Folders and to use
Folders to create and repeat structures within Songs. You have seen how to make
three kinds of copies—real copies, Aliases and Loops—and how to use each of them
for specific tasks. You have learned how to add controller data to the notes in
Sequences and how to combine several Sequences on the same Track and or different
Tracks. You have explored Logics three primary editors, the Event List, the Matrix
editor and the Score editor, and saw how to use the Event Float in conjunction with
any of these Editors. Finally, you learned how to make Logic's bars & beats grid
conform to freely recorded Sequences without changing the sound of the Sequences.
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Working with Audio

What You Will Learn

This chapter covers the basics of using Logic Audio for hard disk recording. You will
learn everything from how to specify what audio hardware you're using, to how to
properly manage your audio files. We will also spend some time examining the avail-
able real-time and destructive DSP options.

The information is organized into the following sections:

(@ Audio Hardware Selection
(@ Setting the Record Path

(@ Recording Audio

(i Editing Regions

(. Useful Audio File features

(@, Destructive Audio Processing
(i Real-time DSP

(i Audio File Utilities
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Working with Audio

6.1 Audio Hardware Selection

LOGIC Audio is able to address various types of audio hardware. It can even record
and playback through multiple systems simultaneously. The first task is therefore to
tell Logic Audio what type of system(s) you own.

Before proceeding, check that your audio system is listed in the following compati-
bility table.

‘: MacOS E Windows95
AudioWerk 8 AudioWerk 8

All DAE supported Digidesign systems | Digidesign’s AMIII

including ProTools 1ll, Pro Tools

Project, Session 8, AMII and AMIII

Apple’s Sound Manager 3.2 MME compatible sound card
Yamaha CBX-D3 or D5 Soundscape SSHDR

Korg 1212 1/0 Korg 1212 1/0

If your hardware is listed in the table then you are ready to begin.

1. Open File -> Preferences -> Audio Extensions

This opens the Audio Extensions Preference window which is where you
enable Logic Audio to communicate with the audio hardware you are using.

2. Select the options that correspond to your hardware

Under normal circumstances, Logic automatically recognizes the hardware
installed in your system and makes the necessary settings in this window. If
for some reason that automatic system has failed, select the box to the left of
the hardware that you own. Deselect any boxes that are checked next to hard-
ware you don’t own or don’t wish to use currently.

In the MacOS example below, Logic Audio is setup to use a TDM capable DAE
system (such as Pro Tools Ill), and an AudioWerk8 card. There are other
settings here that will be covered later where necessary.
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SlI=————————— Preferences §_I
| Audio Extensions 'l
[ [ |™Mac AW Deinstall
= [ DAE

[+ TDM Deinstall

DAE Fileselector for "&dd dudia File. "
|:| Use "Project” driver mode for Session 2 systern

Scrub Response Mormal ™ E TOM Setup Indicator

Max. Scrub Speed MNormal ™

[ [ ] CBH Deinstall

[ [ |DRB/16 Deinstall
— [*] Audiowerk

Input | dnalog ™

[ ]J1212 1/0

i

Windows Only

If you are using an MME compatible sound card, then select the option marked “PC”.
You must also then select both the input and output driver that corresponds to your
card in the flip menu selection boxes provided. For now, you can ignore the “Force
Half Duplex”, “Use Old 2.5 Driver Model” and the “Delay” settings boxes.
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6.2 Setting the Record Path

Before recording audio, you must specify where the resulting
audio files are to be stored and what they will be named. This
process is commonly referred to as the setting the “Record Path”.

Version 3.0 now allows you to define a Record Path on a global
or per song basis. Furthermore, files can be named according to
a pre-defined default name, or the name of the Audio Object
assigned to the track you are recording on. All of these options
are set in the Record Path window.

1. Select Windows-> Audio Window-> File-> Set Record Path

[[I==——-— Set Record Path ...

P

E E Use dgudioobject Mame for Filenarne

| _9;:'
":l Fre-allocate Recording Files

E Mazximum Recording Time (Recommended) ; | 1 Min

Global Becording Fath
Song Fecording Path

Set Mo Record path

e

2. Select the “Global” or “Song” Record Path option

how to:

control the
directory to
which your
audio files
are recorded

set a record
path that is
global for all
songs

set a record
path that is
different for
each song

control how
audio files
are named

use folders
on your hard
drive to
organize
your audio
files

Click hold in the area that now says either Global Recording Path or Song
Recording Path and select the option that best suits you. The most common
choice is probably song Recording Path, as this option allows you to easily orga-

nize your audio files on a per song basis.

3. Choose whether you want to Use Audio Object Name for File name

If this option is selected, new audio files will be named based on the name of the Audio object
assigned to the track you are recording on. Otherwise, they are named according to the default

name defined in step 4.
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$et Record Path ... §_|

4. Set the Record Path for each Audio system

There is now a Set button for each of the audio systems available and activated. Clicking this
button opens a typical File Selector window. Choose the directory to which your recorded audio
files are to be stored and type in a default audio file name. This is the name that will be given to
each new audio file, unless you have chosen to have your audio files named by the
Audio object name in step number 3. The number in the far right of the box indicates the avail-
able drive space.

;a:.gi.udin:nwerk
| St h‘ "Mew Audio” PowrerHD 269 4 MB

N O T E Ineither case, “.n+1" is appended to each new audio file to distin-
guish between new recordings. For example, if you choose the name “new
audio”, the first recording will be called “new audio”; the second,
“newaudio.1”; the third, “new audio.2”; etc.
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what’s an “Audio object”

All audio input and output is controlled via a special Environment
object called the “Audio object”. These “objects” show up as
fader strips in the Environment window and can be assigned to
tracks in the Arrange window just like other Environment objects.
(instruments, MIDI faders, etc.)

Depending on the audio system you are using, Audio objects can
be defined as “Track”, “Bus”, “Auxiliary”, “Input” or “Output”
objects; each type having it's own special function. The type that
all systems have in common is the “Track” Audio object. This is the
type that you will most often interact with, as it is the type that
you assign to a track for recording and playback of your audio.

A very special attribute of an Audio object is it's ability to automat-
ically reconfigure itself to conform to the capabilities of the partic-
ular audio system currently in use. The beauty of this design is that
it is very easy to load and play your song files on different
computers with various audio system configurations.

If you don’t grasp all of this right now, don’t worry. It's not too
important that you understand this in the beginning, because all
the objects that your system supports are automatically created for
you when you first start Logic Audio. Once you've used the
program for a while and wish to know more about these different
types of audio objects, consult the relevant portions of the Logic
Audio manual for details.
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6.3 Recording Audio

Once you've defined the Record path, you are ready to record. how to:

Selecting an audio track « prepare a

An "audio track” is any track in the Arrange window which hasan ~ track for
Audio object assigned to it. When you first load Logic Audio, the recording
first 4 - 8 tracks (depending on your system), will already be set up + (ecord

in thiS Way. enable a
track
Select one of those tracks or assign an Audio object to a separate , (.t the e
track by: source for
e Click-holding in the track recording
e Selecting an audio object from the flip-up menu e record from
digital
] ) ) source
In a default song, these audio objects are named “Audio 1",
“Audio 2", etc. * set Sample
Rate

N O T E Ifyou are recording a stereo audio file, click on

the button with the circle icon in the lower left hand corner of the Audio
object. The recorded audio files will then be'linked', meaning that editing
one side of the stereo pair will always affect the opposite side as well.

Selecting the Input

Before record enabling the track, you must check that the input source
for the Audio object matches the input to which you are feeding signal.
On systems that allow for this, the input is selected in the second box
above the fader knob on the Audio object under the figure “1/0".

If you don’t have this option, it simply means that your inputs are “hardwired”, i.e.,
input 1 always goes to 1, input 2 to 2, etc. If you have only two inputs, then input 1
feeds all the odd numbered tracks and input two feeds all the even numbered tracks.

If you are recording digitally, then you must use inputs 1 and 2. (Unless you have a
Digidesign Pro Tools hardware with an 888 i/o interface. In this case, please consult
the user’s manual for details concerning your system’s inputs)
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Recording from digital input

If you are going to record via the digital inputs on your hardware, you must set you
must set your digital sync and input options accordingly. This may be accessed in a
few different places, depending on your audio hardware.

If you are using an AudioWerk8 card

1.
2.

Open File -> Preferences -> Audio Extensions

Under Audiowerk, click-hold on ]
the flip-menu to the right of Input = [ Audiowerk
and choose Digital Input Digital [

Close the Preference Window

Click-hold on the Synchronization button on the Transport Panel KT
and choose Synchronization

s[M=-= Synchronisation
Click on the Audio tab o

‘|General

Audio h_. MIDI Unitor

Select Digital-In (SIPDIF) to the fudio bevice | Audiowerk ~

right of Sync Mode Syne Mode | Digital (5/P DIF) N

If you are using a DAE based system

1.

2.

3.

—
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If you own a system other than the two described here, please consult the user
manual for the procedural details on.

Setting the Sample Rate

Logic defaults to recording and playing back audio files at a sample rate of 44.1khz.
If you wish to change this to 48khz, select Audio Window -> Options -> 48000. If
you have imported audio, be sure that this setting matches the inherent sample rate
of the files you are playing back, otherwise they will play back at the wrong speed.
Also, if you are recording digitally, check that this setting matches the setting on the
machine that is your digital source.

Record enabling the track
To record enable the audio track either:

e C(lick the Audio object Rec button or,

e Click the record enable button on the track f ﬂ}ﬂ Audio 1

audio object should respond to incoming signal. If they don’t, double check

ﬁ N O T E Once the audio object is Record enabled, the level meters on the
that all of your hardware connections are correct and intact.

Starting Record

Once you're ready to perform, just hit Record -- via transport or key command -- and
play away. Most record functions behave exactly as they do for MIDI, so if you've read
through the previous chapter on MIDI recording, you should already know your way
around the Arrange and Transport windows. (if you didn’t, then perhaps you should
review that section now)

When Logic Audio begins recording you should see the following window pop up.
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Recarding Audio ...

Reraining Tirme: 438

The progress bar and time counter display the remaining recording time. The time is
determined either by the Maximum Recording Time value you have pre-defined
or, (if you have disabled that option) the available drive space.

Differences between Audio and MIDI recording options

While most of Logic Audio’s record options are functionally identically for MIDI
and audio recording, there are a few important differences.

The Merge New Recordings with Selected Objects option does not work
for audio recording

Logic Audio always creates a new audio file every time you record, so it is not
possible to “destructively replace” material in an existing audio file.

The Replace Mode option is non-destructive for audio

Functionally, Replace mode is the same for audio as it is for MIDI. The difference
is that it is non-destructive, i.e, the original audio file being recorded over is left
intact. The only thing “replaced” is the original audio Region. (Remember, with
MIDI recording, Replace mode permanently erases the old data.)

N O T E Thisis not how it may appear in the Arrange window -- when

you drop in and out of record on an existing track, the area recorded

over looks as though it has been erased. What in fact has happened, is

that two new audio regions have been created -- one before and one
after the newly recorded material. Always remember - edits performed in the
Arrange window are always non-destructive, because it is the audio regions
which are edited, not the audio files themselves.
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Cycle Record option differences

The recording option Auto create tracks in Cycle Record is now available for
audio in version 3.0. The only difference from using it with MIDI recording is
that Logic will always mute the previous audio regions, even if the Auto Mute
in Cycle Recording option is disabled. This is because only one audio region
can play at a time out the same Audio Obiject.

audio. That way, when you finish, you’ll have only the last “punched in”

T1P Use the Replace mode when doing Punch-in and out recording of
gﬁE region, rather than multiple takes stacked one on the other.

Punch Mode

Logic Audio now has a special mode for Punch-in recording of audio. The option
is enabled/disabled by click-holding on the Record button on the Transport
Panel. When this mode is enabled your punch-in and out points will be seam-
less, and the playback of audio up to and after your punch points should be
smooth and continuous.

N OTE When Punch-in mode is enabled, Logic temporarily

“borrows” one additional audio channel for every one being recorded.

This means you can only use this feature with up to half the number of

available tracks. For example, if Logic Audio is used with a single Pro
Tools Il system supporting 16 tracks, you can punch-in up to 8 tracks simulta-
neously when Punch-In mode is enabled.
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6.4 Editing Regions

Regions can be manipulated in the Arrange window in the same

manner as MIDI sequences. Furthermore, almost all of the how to:
Arrange window tools that function for MIDI perform the equiv- _
alent function for audio. This includes the Selector, Eraser, Text, * adjust

Scissors, Glue, Solo, Mute and Zoom Tools. The only one not zﬁg'zrr':a': .
available is the Pencil tool. Window °

Most of the Playback Parameter box options are unavailable for ~ * make copies

audio, as the majority of them pertain to MIDI specific functions. ol gl
Those that are available -- the Name, Loop and Delay options -- e change the
function just as they do for MIDI sequences. size of
Regions
TIP You can use the Parameter Box's Delay parameter e adjust a
to'push' or'pull* all the audio files in a track. To view the Region’s
values in milliseconds select Arrange Window -> View -> Anchor Point
Delay in ms ® re-position
regions that
have been
. - - moved unin-
Making copies of Regions e e

You can used most of the same methods available for copying
MIDI events for copying Regions as well. These include using
standard Copy / Paste functions, the Repeat Objects window
and Splice. You can also use the customary

Mac — Option - drag Windows — Control-drag

methods, but there are two variations for using this operation on Audio.
Variation 1

To make a copy of a region that is independent, i.e., can be manipulated without
affecting the original:

e Select the region to be copied
¢ Hold the Option key (Mac) down and drag it to a new location

This is useful when you wish to manipulate the copy without affecting the original
or vice versa.
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TIP Logic defaults to'snapping' your movements to the nearest beat. (at
extremely low zoom levels, the grid becomes the bar.) To force the grid to
the subdivision of the beat — hold the Control key down after click-holding
the mouse. To force it to the tick — hold the Control and the Shift key

Variation 2

To create a copy of a Region which is just a new instance of the same Region, i.e., any
alterations affect both the original and'copied' regions.

¢ Select the region to be copied

e Hold Shift + Option (Mac) down and drag the Region to a new location

TIP If you wish to do any Sample based editing (i.e. Gain Change, Pitch
Shifting, etc.) on a file without altering the original create an independent
copy using the Option-drag method just described then select Arrange
Window-> Functions-> Convert Regions to Individual audio file. You can
now work with the new file without affecting the original.

——  Regions vs. Audio Files

j It won't be long before you’ll want to get down to the business of
v || editing your recordings, but before doing so, it is important that
you understand the difference between Regions and Audio Files.

The term Audio File refers to the actual file that resides on your hard drive. Any
editing that effects an audio file is destructive, i.e., the file itself is altered.

The term Region refers to a portion of an audio file. Whenever you manipulate
audio in the Arrange window, you are working with regions. All edits to regions
are non-destructive, i.e., they do not modify the actual audio file on your hard
drive. Essentially, a region is nothing more than a set of instructions which tell
Logic what portion of an audio file to play.

The Audio window functions as a complete catalog of the audio files, and their
associated Regions, which have been created or added within a song.

Adjusting Region boundaries
|W ARNIN G The Arrange window is the only window in which you can
& manipulate a Region's boundaries without the possibility of moving the
relative position of the audio in the song. In all other edit windows, be very
careful not to unintentionally move a region's Anchor point while moving it's Start
and End points, because if you do, it will change the relative position of the audio in
the song.
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In the Arrange window...

¢ Click-drag the lower left or right hand corners of the region

The mouse turns to a pointing finger (as opposed to a grabbing hand) when you've
clicked the correct “hot spot”.

N O T E Logic's zoom tool is an indispensable utility during this process. It
allows you to temporarily zoom in and see the region's waveform while
you're editing.

Here's how it works:

While holding the Control key, click-drag a box around a small portion of the
region. (Be careful that you start your'lasso' in the grey area of the Arrange
Window.) When you let go of the mouse, the area you selected will fill the whole of
the Arrange view. Once you've made your edit, you can return to the previous zoom
level by simply holding the Control key and clicking once in the gray background of
the window.

In the Audio Window...

e Click-drag the lower left and right hand corners of the region
The mouse turns to a pointing finger (as opposed to a grabbing hand) when you've

clicked the correct “hot spot”. ﬁ

You can also move both the Start and End points simultaneously by click-dragging
in the lower half of the region's overview. The mouse turns into a pair of left-right
pointing triangles when you've clicked the correct hot spot.

3 3 3154
Y act Gir 1
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T 1P Click-hold on the Region's overview turns the mouse to a speaker icon
; and begins playing audio from that point.

left column that looks like the Cycle button on the Transport; then click the
Speaker icon

ﬁ& TI1P To play the region repeatedly while you edit it: click the button in the

In the Sample Edit window...

Fine adjustments to a Region's boundaries are best performed in the Sample Edit
Window. To open the Sample Edit window:

e Window -> Sample Edit or;

e Double click on an Audio region

Once you're in the Sample Edit Window, look for the two flag shaped handles
labeled “S"” and “E".

T
||

JEF

i

These mark the Start and End points of the selected audio region. You can click drag
these handles to edit the size of the Region or, alternatively;

e Make a new selection by click-dragging over the waveform

e Select Sample Edit -> Functions -> Set Region by Selection
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Q& TIP If Link Mode is enabled @ in a Sample Editor, the audio file its

display will change as you select different regions in the Audio, Arrange or
Event Edit Windows.

In the Event Window...

Audio regions can also be edited in the Event Edit window. It simply needs to set to
a hierachical level at which it is viewing the objects in the Arrange window, as
opposed to the data those objects contain. (Please review the section discussing the
Link modes and levels if that doesn’t make sense to you) The start of the Regions can
easily be manipulated via the numbers in the left hand column. Changing the values
in the right hand column (under’Length') changes the region's length by changing
it's end point.

SlI=——-——"———— Epent List HEgiun#E EEEI
= |Structure Edit Functions Yiew Options — == ===}

'@4 5 6 7 g 10 |11 12 |8

£
1=

B E"'E“t I_'iSt Regin“ B i

E#t Functions Wiew
I —
FR=TTICOHN FMAME TEACE EHD FOSITIOH

1 bass1.2 | =
Juitar i

L

select Event Window -> View -> Length as absolute position. (This is how it

TIP To view the ending position of the region (as opposed to its Length)
;;E is set in the figure above)

E TI1P Toview all values as SMPTE values select Event Window -> View -> Posi-
tion & Length in SMPTE Units
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In the Event Float Window...

The Event float can be very handy for quickly’touching up' a region's boundaries. To
open it in the Arrange window select Options -> Event Float. Click the small “film-
strip” icon at the left edge of the window to view the Position and length values in
SMPTE units.

the Event list. When you do so, the entry box for the region's position auto-

TI1P You can drag and drop audio files from the Audio window directly into
§ matically opens, allowing you to quickly “spot” cues to the desired location.

what’s the “Anchor Point”?

The point at which a Region is tied to its position in the song is called the Anchor
Point. Newly recorded files always have their anchor point at the beginning of
the region, but it can in fact be at any position. You can move the Anchor point
from within the Sample Edit window but BE CAREFUL -- moving this point
moves the region's relative position in the song. That is because the Anchor
point’s position in the song is stationary --anchored --, so moving it causes the
Region to move a relative amount.

Fegion 1: Spraing
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Fixing Regions which have been unintentionally moved

If you inadvertently move a region's relative position in the song, you can usually
correct the mistake simply by:

¢ Selecting the region (or regions) in question.
e Choosing Arrange Window -> Functions -> Regions to original Record Posi-
tion
Be aware that this feature will only work on regions that were originally recorded
within that song.

TIP If you've got audio files that start at some odd numbered tick before a
beat, you might want to move the anchor point to a nice even beat position
to make it easier to keep track of a region’s position. Here’s a way to do this
without disturbing the Regions relative position in the song.

1 Click-drag the lower left hand corner of the Region to the right until it
lines up with the nearest beat. (you'll have to hold the Control + Shift
keys down after clicking initially with the mouse so you can move in tick
increments)

2 Open the Sample Edit window by double clicking the region.

3 Click-drag the Start position of the audio file to the left while holding
down the Option key to “uncover” the portion of the audio file that was
covered up when you shortened the Region from the left.

Holding the Option key allows you to move the beginning of the region w/o moving
the Anchor point which otherwise always snaps to the Region Start point.
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6.5 Useful Audio File features

Adding audio files
# Adding audio files is done via the Audio Window
-

1. Select Window -> Audio Window -> Add Audio File
2. Select the audio file from the resulting File Selector window

The file, is then added to the list of files and regions in the Audio Window.
If you wish for it to be placed in the song:

3. Click-hold on the Region name and drag it into Arrange window.

The Region will be placed at the position of your cursor when you release the
mouse button, so watch the’Control Line' as you drag it in to see where you're
placing it.

N O T E Remember that if you're using a Digidesign system with it's own
SCSI chain, you must add audio files from a drive that's on that chain.

Audio Window basics

The Audio window serves as a running catalog of all of the audio files that
have been created or added in a song. The Audio files are listed in bold
type with their associated Regions listed just below in normal type Clicking
the small triangle to the left of each file'opens' and’closes’ this Region
view for that particular audio file. Command clicking the triangle performs
the same function for all Audio files in the Audio Window.

The primary functions performed in this window include: Importing,
exporting and moving audio files, accessing audio hardware settings, audi-
tioning audio regions, checking the drive path, file size, and sample rate
specifications for audio files, launching the Sample editor, and launching
the Strip Silence feature.

Matching song and audio file tempos

# A lot of dance music involves importing drum loops or musical samples
v || which have their own inherent tempo. This necessitates matching the
tempo of the audio file with the tempo of the song. This can be achieved

Logic Audio Guidebook 6 - 187



Working with Audio

in one of two ways: changing the tempo of the sequence to match the audio file's
tempo or; changing the tempo of the audio file to match the tempo of the song.

Changing the tempo of the song to match the audio file’s tempo

Setting the song’s tempo to match the audio file is the easiest option because it does
not involve any processing of the audio file. Logic has very simple method for deter-
mining the tempo of the audio file.

1. Select the region for the audio file you wish to determine the tempo of

If you haven't done so already, import the audio file you wish to work and
drag it into the Arrange window to the desired start location, as per the
instructions the previous section, "Adding audio files".

N O T E For this example we are assuming that the audio file in question
is already trimmed so that it loops perfectly after an even number of beats.
Furthermore, you should know how many beats long the audio loop is. If the
audio file is not in this state, follow the instructions under “Setting loop
points” before proceeding with this exercise.

2. Set Cycle to the desired number of beats

Starting at the beginning of the audio region, define a Cycle region that has
the same number of beats as the audio file does inherently. For example, if

you placed an 8 bar loop at bar 5, click-drag in the upper portion of the Bar
Ruler to create a Cycle that starts at bar 5 and ends at bar 13. (It's not impor-
tant that Cycle be on, we're only using this as an easy method for setting the
left and right locators)

3. Arrange Window -> Functions -> Adjust Tempo using object length and
Locators

Make sure that the Region in question is still selected then choose the option

4. Choose to insert the tempo change globally or locally
e Choose Global if you want the whole song to be set to the new tempo

e Choose Create if you want to insert a new tempo event at the beginning
of the Region

Changing the tempo of the audio file to match the sequence tempo

Changing the tempo of the audio file means destructively modifying the sample
using the Digital Factory's Time Machine. The Digital Factory and other Sample Edit
operations are covered in greater detail in the following section, "Destructive Audio
Processing”. Please read through that section if you have any trouble working
through this exercise.
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1. Select the region/audio file you wish to adjust the tempo of

If you haven't done so already, import the audio file you wish to work with
and drag it into the Arrange window to the desired start location as per the
instructions in the previous section, "Adding audio files".

2. Open the Sample Edit Window

Double-click the Region to bring up the Sample Edit window (Better yet, go
to or create a Screenset set up optimally for this task)

3. Select Ssample Edit Window -> Digital Factory -> Time Machine

4. Set the bar/beat value you wish the audio file to be

Under the “Destination column”, and to the right of where it says
“Bars/Beats”, input the correct length of the audio file (in bars and beats).
LOGIC will automatically calculate how much it must speed up or slow down
the audio file in order for it to be “x” number of beats at the songs current
tempo

5. Click Process

6. Choose whether or not you wish to create a backup file

It is advisable to select “Make Backup” when prompted. If you do, then Logic
Audio will create a backup to which you can “revert” at any time in the
future.

N O T E The Time Machine attempts to streamline the process of altering
the tempo of files by automatically setting the Source Tempo based on the
tempo of the song at the current song position. This means that if there are
multiple tempos in the song, it is necessary to make sure that the SPL is
located within an area that has the desired Source tempo.

Strip Silence

Strip Silence is a simple but incredibly useful feature which cuts away the silent
portions of an Audio region. To perform Strip Silence on an audio region:

1. Select the Audio region you wish to process from within the Audio window.
2. Open Audio Window -> Functions -> Strip to Silence
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3. Adjust the Parameters until the graphic displays the desired results

The parameters in the Strip Silence window are quite similar to those in a
standard Noise gate or Limiter processor and should be familiar to anyone
with experience with those types of devices. The primary difference is the
addition of two “non-real-time” parameters: Minimal time to accept as
Silence; and Pre-attack time. Logic Audio takes much of the guess work out of
setting these parameters by displaying a graphic preview based on the
current settings. For a detailed description for each of the parameters, refer
to the appropriate sections in your owners manual.

4. Click "Process”

If the Audio region is being used somewhere in the Arrange Window, Logic
will prompt you at the end of the process, asking whether you wish to replace
the original region with the new, segmented equivalents. Normally, that is

the intention, so answer “Yes” (replace?)

why should I use “Strip Silence”?
There are three primary reasons for using this feature:

e To “Clean up” your mix

Removing the “silent” portions of an audio track means removing any hum or
other unwanted low-level noise that usually exists in those sections. In the “old
days” a similar result was sometimes achieved by “riding the mutes”, i.e., muting
a track in the silent portions during mix-down.

e To Reduce the amount of drive space used for a song

Silent portions in an audio file take up just as much drive space as those portions
that aren't. While Strip to Silence alone does not remove these “unused”
portions from your hard drive, it is the first in a series of steps that will. See the
relevant section under “Audio File Utilities”

e To improve the timing between audio and MIDI playback

With Logic Audio’s unique “trigger-sync” system, multiple smaller audio regions
generally stay locked tighter to the MIDI playback than single long ones; simply
put: because they have less time to potentially “drift”. There is no need to go to
the extreme with this concept -- we're not recommending that you slice up your
regions into 1 beat increments to keep things tight! Under normal conditions,
noticeable drift should not occur in Logic Audio, especially with regions that are
anything less than a minute long.
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Search for Zero Cross Points

If the beginning or end of a region occurs where the audio file is not at absolute zero
amplitude, it is likely that you will hear tiny pops or clicks at those points. This is a
natural occurrence which can only be avoided by adjusting a region’s boundaries so
that they are exactly at “zero cross points”. Fortunately, Logic Audio can do this
automatically in three places that you often work with Regions; the Arrange, Sample
Edit, and Strip to Silence windows.

In the Arrange window...

¢ Select Options->Search for Zero Cross Points

Logic will always move the region’s boundaries to the nearest zero cross point when
you either divide a region (using the Scissors tool or other method) or adjust a
regions start or end point by click dragging in the lower left or right hand corners
respectively.

In the Sample Edit window...

¢ Select Edit->Search for Zero Cross Points

Logic will always snap to the nearest zero cross point when you make any changes to
the region boundaries or current selection.

In the Strip Silence window...

e Check the box in the lower right hand corner

Logic will snap the boundaries of all newly created regions to the nearest zero cross
point.
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6.6 Destructive Audio Processing

Any edit which alters an audio file on your hard drive is referred to as a “destructive”
edit. Almost all destructive edit processes in Logic Audio are carried out from within
the Sample Edit Window. (The only exceptions are the file utilities such as Delete and
Optimizing files, which are accessed from the Audio window).

To open the Sample Editor:
¢ Windows ->0Open Sample Edit or,

¢ Double- click Region in Arrange window or,
¢ Double-click Region in Audio window or,

¢ Double-click Region in Edit window

N O TE If you open the Sample Editor from the Arrange or Event Edit
windows, the first position on the time ruler is equal to the regions start
point in the song. If you open it from the Audio window, the time ruler
begins at zero.

There are two different menus in the Sample edit window which access file editing
functions. The first -- Edit -- contains a a list of standard Sample edit features such as
Normalize, Gain Change, Reverse, etc. The second, -- Digital Factory -- accesses the
more advanced features such as the Time and Pitch Machine Il, the Groove Machine,
Audio to Score, Audio Energizer, etc.

Instead of duplicating material already covered in your owners manual, this section
simply runs through a series of short exercises demonstrating how these features are
generally accessed.

Basic editing of audio files

You follow the same basic steps to apply any of the edit operations listed under
Sample Edit->Edit. In this example we’'ll “Normalize” an audio file, a basic process
which increases the output level of a file until it's peak is at 100%.

To normalize an audio file:

1. Select the portion of the audio file you wish to process

When you first open the Sample Edit window, the portion selected is equal to
the Region’s boundaries. To process a different selection, click-drag your
mouse over the waveform in a manner similar to the way you highlight text
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in @ word processor. You may use the Shift key to increase the size of your
selection without moving the start position as follows:

* click once in the waveform area towards the beginning of the file
¢ use the windows scroll bar to move your view to the end of the file

e hold the shift key and click once in the waveform

The result should be that the whole of the area between your two ‘click
points’ becomes selected.

T 1P Hold the Shift + Option keys to reset the Right locator when you are in
an area to the left of the mid-way point of the selection. (Using Shift alone
in this instance would reset the Left locator, not the Right) This process works
in the opposite direction as well, i.e., resetting the Left locator when you are

to the right of the mid-point of the selection.

2. Select Edit -> Normalize

3. Choose whether you wish to make a backup file

When the process is over, a dialog asks whether you wish to make a backup
of the audio file you have edited. If you choose yes, then you will be able to
take advantage of the Audio window->File->Revert to Backup option and
retrieve this original, unaltered version of the file at any time.

Creating new Regions in the Sample Editor

You can easily re-define the boundaries of an existing region or create a completely
new one without ever leaving the Sample Editor.

To re-define an existing region:

1. Double-click a region to open Sample Edit Window
2. Click-drag over waveform to make new selection
3. Select Edit->Selection to Region

N O T E The menu option Region to Selection does just the opposite,i.e.,
it transfers the currently selected region’s boundaries to the selection in the
Sample Editor

To create a new region:

1. Double-click an region to open Sample Edit Window
2. Click-drag over waveform to make new selection
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3. Select Edit-> Create New Region

Creating a new audio files from sections of existing ones

At some point, you may wish to create a new audio file out of a portion of an existing
one. You can perform this function from either the Arrange or Sample Edit windows.

From the Arrange window....
1. Select a region or regions which you wish to “convert” to new audio file

2. Select Functions->Convert Regions to Individual Audio files

The following dialog will tell you how much disk space is required and prompt
you to confirm your action. Click Create to follow to begin the process or
Cancel to abort it.

ﬁ 1 audiofile(s) tobe
created, This requires

238 K of disk space.

|| Create “ [ Cancel

3. Choose where the new file will be stored

In the following dialog, choose Original if you wish to place the file in the
same directory as the file you're creating the new file from or choose New to
place it in a new directory

The new file(sy are saved to
the original file location,
The file(sy can be saved to a

different, new loation chosen
in follewing fileselecor,

Cancel I || Original “ [ Pl e
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From the Sample Edit Window...

1. Click-drag over waveform to select portion of sample that you wish to make
new audio file out of

2. Select File->Save Selection As....
Name the new file and select the directory in which it is to reside

4. Choose whether or not you want the new audio file to be added to the
available files in the song.

Once you choose the directory and name and click OK, you will be prompted
by the following dialog to choose whether or not to add the audio file to the
files in the Audio window

Add audiofile
"resay file"

tolist of Audiowindow?

e

[ No | Add
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6.7 Real-time DSP

This section describes the standard procedures for accessing Logic Audio’s real-time
DSP functions. The type and amount of real-time DSP available to you depends on
your particular hardware setup and can vary from a single parametric EQ per channel
to a fully expandable system built around a plug-in architecture.

EQ only systems (all DAE hardware except for Pro Tools w/TDM)

When Logic Audio “talks to” any Digidesign hardware, it does so via
Digidesign’s own driver software, commonly known as DAE (Digital
Audio Engine). This means that the only real-time DSP possible for
those systems, is the DSP provided via DAE. In all cases, accept for a Pro
Tools Il or Ill based system with TDM, that DSP is limited to one or two
parametric EQ’s per channel.

Using that EQ in Logic is quite easy and straightforward. The standard
parameters (Frequency, Gain, and Q) show up on the Audio object and
can by altered by simply click-hold-dragging your mouse up or down.
Alternatively, you can double-click on the value and input a number
directly from your computer’s numeric keypad.

User configured DSP systems

The term “user-configured” is used loosely here to describe those systems where you
can control the bussing of the audio signal and insert multiple effects into an Audio
object. Essentially, this covers all systems besides the “EQ only” ones just described;
this includes Logic Audio’s own host-based DSP, the Yamaha CBX’s on-board effects,
and Digidesign’s elaborate TDM plug-in system.

While each system has it's own specific set of limitations and capabili-
ties, the basic methods for inserting an effect or bussing an audio
signal are essentially the same for all setups.

Inserting an effect

If it is possible to insert an effect into the output path of an Audio
object there will be at least one blank rectangular box at the top
under the word Inserts. It should look something like this the figure to the right.
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To insert an effect:
e Click-hold your mouse in this box
e Make your choice from the resulting drop down menu

e Double-click the effect name to open the effect parameter box

N O T E The Link button in the effect parameter box works similarly to the
way it does for other windows. If it is selected then double-clicking on an
inserted effect will cause it to update to reflect the new selection. Otherwise,
the window will not update and double-clicking an effect will cause a new
parameter box window to open instead.

Inserting multiple effects

In most cases (the CBX-D5 being the exception) it is possible to insert multiple effects
into a single Audio object. The actual number is dependent on the system you are
using and is indicated by the number of rectangular boxes that appear at the top of
the Audio object. However, take note that the number of boxes is “dynamic”. This
means that more boxes will open up as you insert more effects. For example, you may
insert up to 8 effects using Logic’s own DSP but initially, only two boxes are visible.

Inserting a new effect is done just as with one:

¢ Click-hold your mouse in an available box
e Select from the drop down menu

e Double-click the effect name to open the effect parameter box

When you insert multiple effects, the audio passes through them in series starting at
the top. So, for example, if you wish to EQ the signal before it goes through a delay,
insert the EQ first, then the Delay.

Mono and Stereo effects

If you insert an effect on a mono Audio object you may find that there are two group
of effects available in the selection menu. These groups are delineated by a dividing
line in the menu with the first group having the letters “m/m” after the effect name,
and the second group have the letters “m/s”. These letters stand for “mono/mono”
and “mono/stereo” respectively, indicating whether the effect is mono or stereo.
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If you choose a stereo effect, the output of the object will be stereo and the Audio
object will change to a stereo object to reflect this. (as indicated by the two concen-
tric circles on the button in the lower left of the object as well as the dual set of LED's)

Bussing audio signals

If you have any experience using even a basic mixer you are probably already familiar
with the concept of “bussing”. The term simply refers to the ability to route an audio
signal from one place to another.

Perhaps the most common use for this function is to send some or all of an audio
channels signal to a Bus or Auxiliary output which in turn is sending its signal
through an effect such as a Reverb. This type of setup, in contrast to inserting the
effect on a single output, allows you to use the same effect on more than one signal.

Here’s is how you would perform this task in Logic Audio.

Using Audiowerk8, Sound Manager, a standard MME soundcard, or any
other system where you’re using Logic’s host-based DSP:

1. Select the bus to use for the Send

Click-hold in the box under the word Sends on the
Track object that is the source of the signal you
which to bus. Select a Bus from the flip menu. In the
figure to the right, Bus 1 is being used.

2. Insert the desired effect on the corresponding Bus
object

Find the number bus object that corresponds to the
bus you selected in step 1. (If you don’t find one, you
may need to create one. Please refer to the relevant
section in your user’s manual). Insert the desired
effect on the Bus object as described in the previous
section, "Inserting an effect". In the figure to the
right, a DaD Valve effect has been inserted into the
Bus 1 object.

3. Set the Bus object to the desired pair of outputs

Click hold in the second box below the letters “1/0"
to select the desired output for the bus object. In the
figure to the right, Bus 1 is set to Output 1-2

4. Adjust the Send level on Track object

Use the Send knob that is to the right of the place you selected the bus on the
original Track object to set the amount of signal you wish to “send” to the
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Bus object for processing. In the figure, the Track 1 object’s send is set to the
1 o’clock position.

Using TDM:

. Select the bus to use for the Send

Click-hold in the box under the word Sends on the Track object that is the
source of the signal you which to bus. Select a Bus from the flip menu

Set an Auxiliary to receive signal from the corresponding Bus

Find or create an Auxiliary object and set it's input to the same Bus selection
you made in step two. The input is selected in the first box under the charac-
ters I/0 (If you need to create an Auxiliary object but don’t know how to,
please refer to the relevant portions of your user’s manual)

Insert the desired effect on the Auxiliary object

Insert the desired effect on the Bus object as described in the previous section,
"Inserting an effect"

Set the Auxiliary object to the desired pair of outputs

Click-hold in the second box below the letters 1/0 to select the desired output
for the Auxiliary object

Adjust the Send level on Track object

Use the Send knob that is to the right of the place you selected the bus on the
original Track object to set the amount of signal you wish to “send” to the
Bus object for processing.

TIP A TDM based system allows you to set the input of a Track object to be
a bus allowing you to re-record the outputs of one or more tracks - a useful
option for mixing down multiple tracks while printing their effects and auto-
mation.

Using Yamaha CBX-D5:

1.

Select the bus to use for the Send

Click-hold in the box under the word Sends on the Track object that is the
source of the signal you which to bus. Select a Bus from the flip menu

Select the desired effect on the corresponding Return object

Find the number bus object that corresponds to the bus you selected in step
1. (If you don’t find one, you may need to create one. Please refer to the rele-
vant section in your user’s manual). Select the desired effect on the Return
object.

3. Adjust the Send level on Track object
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Use the Send knob that is to the right of the place you selected the bus on the
original Track object to set the amount of signal you wish to “send” to the
Bus object for processing.
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6.8 Audio File Utilities

An inevitable task involved with hard disk recording is managing all of the audio files
which so quickly fill even the largest of hard drives. Eventually, you will need to copy,
delete, move, or otherwise manipulate these files, either to make more space on a
drive, or to export them for use in other programs. Fortunately, Logic Audio has
some very useful utility features which help you accomplish these goals with the
minimum of strain.

Copy, Moving and Deleting files

Logic has dedicated options for copy, moving and deleting files. While these func-
tions can be performed from within your computers OS, performing the functions
within Logic Audio has its advantages:

e The song file is kept up to date regarding the locations of the files in use
e Logic's performs these functions much faster than your computers 0S

* It is more convenient to perform these functions from within the program

To Delete a file from a Song
From the Audio window,

1. Select the Audio file or files you wish to delete

Remember, the audio file is listed in bold with a triangle to its left and the
Regions are listed below that. If you only select the Region, you'll delete the
region only and not the whole audio file. (If there is one region, deleting it
will in fact delete the audio file from that song as well; every audio file must
have at least one region associated with it)

2. Hit the Delete key
This deletes the file from the song but leaves the file on our hard drive.

To Delete files from your hard drive

1. From the Audio window, select the Audio file or files you wish to delete
2. Select Audio Window->File->Delete file
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N O T E You can also delete files from the Arrange window if the region

you delete is the only one associated with that audio file. In that case, when

you select the region and hit the delete key, you will be prompted with a

dialog which asks whether you wish to delete the file from the hard disk or
only from the song.

Copy or Moving files on your hard drive

1. From the Audio window, select the Audio file or files you wish to copy or
move

2. Select Audio Window->File->Copy file or Move file
3. Select the new location
to which you wish to copy/move the file in the resulting File Selector window

4. Choose whether you want the current song to look for the audio file in the
new location

When the process finishes, a dialog asks whether or not to update the direc-
tory information for the file in the current song. Select “Yes” if you want the
song to look for the file in its new location the next time you load it.

Importing/Exporting files

“_ Mac

While Logic records and plays back only monophonic Sound Designer Il files it can
also import and export SDII Stereo, AIFF, and WAV files

ﬁ Windows

While Logic records and plays back only monophonic WAV files it can also import and
export SDII and AIFF.

To import a an audio file: E
1. Select Audio Window->File->Import File
2. Select the type of file you wish to import from the hierarchical flip menu
3. Select the file from the resulting File Selector window
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4. Click oK

Once you've selected the file you wish to import, Logic will copy and convert the file
on your hard disk, leaving the original intact. In the case of a SDII Stereo file, Logic
will create two new monophonic files which are “linked” when used by Logic.

To export an audio file

1. Select Audio Window->File->Export File->AIFF/Wav/SDII Stereo
2. Select the type of file you wish to export from the hierarchical flip menu

3. Type in an appropriate name for the new file in the resulting File Selector
window

4. Click OK

To export Sound Designer Il regions:

Sound Designer Il files can store region data but Logic does not do this by default.
(That information is normally stored only in the song file) This is a useful feature
when you want to load the files into programs such as Pro Tools ©, Sound Designer
© or Bias's Peak © sample editor, which can recognize Sound Designer Il files and
their associated regions.

1. From the Audio window, select the audio file or files whose regions you wish
to export

2. Select Audio Window->File->Export SDII regions

Optimizing files

A good way to free up space on your drive is to use Logic's Optimization function.
This option deletes those portions of an audio file that aren't being used in the song.

For example, imagine that you recorded a one minute long audio file but then ended
up using only the first half of that recording in the arrangement. Or, perhaps a
guitar solo you recorded contains multiple silent sections that you stripped away
using the Strip to Silence option. In either case, there are unused portions of the
audio file which are taking up valuable hard disk space. Optimization cleanly
deletes those unused portions.

Logic Audio Guidebook 6 - 203



Working with Audio

W A R N I N G Thisis a destructive edit process, so any other song files

' | which access the affected files will no longer playback the audio correctly.
Therefore, only optimize the audio files which are NOT being used by other
song files you wish to keep intact.

To Optimize a file or files:
1. From the Audio window, select the audio file or files you wish to Optimize
2. Select File->Optimize File(s)

The following dialog will tell you how many samples are going to be deleted
and warn you to be careful with the operation. Click Do It when you are sure
you want to proceed.

Joro unused Samples
toremove ind1 audio filels),
Can't UMDO this operation!

Keep in mind other songs
tnay also use these fileds)!

|| Cancel “ [ Do it I
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What You Will Learn

This brief chapter will describe the basic steps necessary to enable Logic to Sync to
external sources, as well as how to use MIDI Machine Control (MMC). It will also
explain how to transmit sync in cases where you wish to use Logic as the master.

The information is organized into the following sections:

(@ Syncing to an external source

(& Logic as the Sync source

(@ Setting Logic to transmit MMC
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4.1 Syncing to an external source

To set Logic to sync to either MIDI Clock or MTC:

how to:
1. Open the Synchronisation window e set Logic to
Transport -> Sync Button -> Synchronisation sync to an
external
source.

2. Go to General settings window
Click on the tab at the top of the window labeled General.  * f;l';;to;he
synchronisa-

EI tlc_>n Logic
will use

e selecta
SMPTE frame
rate.

Sync Mode | Intern
* set the

SMPTE

External Stop ends Record Maode offset.

BAuto enable external Sync

e set Logicto

Frame FRate [fps] 30 send sync to
an external

Auto Detect Farmat of MTC device
Ear Position | 1 1 1 1
plays at SMPTE I01: 00: 00: 00. 0D

Enable Separate SMPTE Yiew Offzet
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3. Select the type of sync you wish to use

You may set Logic to sync to MIDI Clock, MTC (SMPTE) or the internal clock
from the Sync Mode window.

MIDI Clock Sync

If you select MIDI Clock Sync, then Logic will follow incoming MIDI clock from
external devices such as drum machines or other sequencers.

MTC

To set Logic to follow MTC (SMPTE), select “MTC"” from the Sync Mode
window.

4. Auto enable external Sync

Engaging the Auto enable external Sync button allows Logic to sense
incoming MTC or MIDI Clock, and to automatically switch to it.

5. Setting the SMPTE Frame Rate

If you are usng MTC, you'll need to set the correctframe rate. To set the SMPTE
frame rate, select the appropriate rate from the Frame Rate (fps) menu.

N OTE Auto Detect format of MTC

Logic has a unique feature that allows you to automatically detect the

format and rate of the incoming SMPTE timecode. This can be very useful if

for some reason you are unsure of the SMPTE frame rate you're trying to sync
to. (For example, if you are working with a tape which has been previously striped at
an unknown rate.) If you are sure of the incoming SMPTE rate, it is generally best to
leave this off and set the value manually.

Set the SMPTE Offset (not applicable for MIDI clock)

If your song starts at a SMPTE position other than the default of 01:00:00:00.00, then
you will need to adjust Logic’s offset to match.

1. Check Bar position

You will see a window labeled Bar Position, and below it another labeled
Plays at SMIPTE position. You will almost always leave the Bar Position set to
“1T111".

2. Set the SMPTE Offset value
Set the Plays at SMPTE window to the SMPTE time that you would like your
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song to start at.

SMPTE View Offset

In some cases you might wishto set Logic’s SMPTE display to start from a time other
than the SMPTE offset value. For example, when you want the SMPTE displays to
show time measured from “zero” rather than from an odd numbered offset value.
This the purpose of the SMPTE View Offset feature. To enable this option:

1. Open the Synchronisation window
Transport -> Sync Button -> Synchronisation

0o: 00: 00: 00, 00| (g [ 1200000 | 44 4| Man
11 1 (| s5204 ME | Mo Out
1 1 1 i [i ] [untitled]
z 11 i|gm| EMAagIc 201
2. Enable the Enable Separate SMPTE View Offset button.
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3. Set the SMPTE view offset value

Input the Bar and SMPTE values in the Bar Position and displayed as SMPTE
boxes provided.

Sync Mode | Intern

Auto enable external Sync

External Stop ends Record Mode

Frame Rate [Fps] 30

Auto Oetect Format of MTC
Bar Fosition | 1 1 1 1
plays at SMPTE 01: 00: 00: 00. 0O

Enable Separate SMPTE Yiew Offzet
Ear Paosition | 1 1 1 1

displayed as SMPTE  [00: 00: 00: 00. 00
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4.2 Logic as the Sync source

To set Logic to transmit MTC or MIDI clock to other devices
1. Open the Synchronisation window
Transport -> Sync Button -> Synchronisation

2. Click on the mMIDI tab at the top of the Synchronisation window

To send MIDI Clock:

1. Enable the Transmit MIDI Clock button

Transmit MTC [rtseF O
Transmit MTC Delay | 0

Send MMEC [MI0I Machine Contral]

2. Set the output port for MIDI Clock

You may specify the output on your system that clock will be sent on in the
port select window to the right of Transmit MIDI Clock. You may specify any
single port, or all ports.

3. Enable Allow Song Position Pointer while playing

To set Logic to send SPP while playing, engage the Allow Song Position
Pointer while playing button. Logic will send position cues along with the
clock data, so that the target device will follow position as well as tempo
information.
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To send MITC
1. Enable the Transmit MTC button.

2. Set the output port for MTC

You may specify the output port on your system that MTC will sent on in the
port select window to the right of Transmit MTC. You may specify any single
port, or all ports.
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4.3 Setting Logic to transmit MMC

There is some confusion on the subject of MIDI Machine Control (MMC). Some
people get confused and think of this as a form of sync. In fact MMC is simply the
MIDI version of a remote control. MMC provides a standard series of transport
commands to remotely control an external device. There is no actual synchronisation
involved. Therefore, the general practice is to to set Logic as the MMC master, but in
turn as the slave to incoming MTC (or potentially, MIDI Clock). Logic acts as a “remote
control”, sending transport commands to a tape deck, or other external device, and
then syncs to the MTC coming from that device when it starts.

To enable MMC:

1. Open the Synchronisation window
Transport -> Sync Button -> Synchronisation

2. Go to the MIDI settings window
Click on the MIDI tab at the top of the window.

Transrmit MIOI Clack [anFans

Allow Song Position Pointer while playing

Transmit MTC RETR
Tran=mit MTC Delay | 0

Send MIMC [MIDI Machine Control]

3. Engage the button labeled Send MMC (MIDI Machine Control)
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MIDI Studio Inventory Worksheet

The Table on the next page is provided as a tool to help you keep
track of your MIDI studio. It's advisable to fill it out before
proceeding through the procedures outlined in the MIDI Setup and
Configuration chapter.
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Device

Port

Listen Ch
(1-16)

Talk Ch
(1-16)

Local
/Thru

Map-

ped

GM
XG
GS

Cont.

Control-
lers

SysEx
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Here is a brief example of a completed table for a MIDI studio with 7 devices
sharing 4 interface "virtual" ports.

Device Port |Listen Ch |Talk Ch Local |Map- |GM Cont. SysEx
(1-16) (1-16) /Thru |ped |XG Control-
GS lers
XP-50 M1 1-16 1 4 4 v
D5 M2 10 v
DX-7 M2 1 local
PC-1600 M2 1-16

Ultra Proteus M3 [ 1-16 v
MPX-1 M4 v
PC200 M4 2

Description of Columns

e Device

Use one row for each MIDI device in your studio—name the device in this
column.

e Port

Indicate which port of your MIDI interface the device is connected to. Typi-
cally a MIDI device will be connected to the input and/or output of a single
interface port. If for some reason you use different input and output ports
for the same device, list the device in two separate rows—one for its input
function and the other for its output function.

¢ Listen Chans

Indicate the MIDI channels on which you will want the device to receive MIDI
data. This is a function of the devices capabilites and settings. For example,
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if two multi-timbral devices share the same port, you will most likely enable
some channels on one device and other (different) channels on the other
device. Fill out this column accordingly.

¢ Talk Chans

Indicate the MIDI channel(s) on which the device sends MIDI data. Stand-
alone MIDI sound modules typically do not send MIDI data. (Such devices
often will send SysEx preset information, however - see the "SysEx" column.)
Generally, you will use this column to indicate what channel your MIDI
controller(s) are set to. A MIDI controller might be the keyboard of a work-
station like the XP-50, a stand-alone keyboard like the PC 200 or a
fader/button controller like the PC 1600, for example. The channel numbers
you fill in here should be the channels you intend to use the controller on, not
all the ones it may be capable of.

e Mapped

Indicate whether the MIDI device is intended to play a different sound for
each MIDI note—drum synths are a typical example. Logic has special tools
for managing these devices.

e Local/Thru

Local If the device is both a MIDI controller and a MIDI sound device AND if
you have MIDI cables running both to and from the device then determine
whether the device offers a way to turn local (internal) control off. The point
is that you will not want the device both "talking to itself" and sending infor-
mation back to itself through Logic. The typical solution is to turn local
control off, but if this is not possible, Logic can prevent MIDI data that comes
from the device from being sent back to it. Enter "Local" in this column if
there the device DOES NOT allow you to turn local control off.

Thru If the device is both a listener and a talker (i.e. if you have MIDI cables
running both to and from the device) then determine whether the device
"echos" incoming MIDI data back thru its output. If it does, determine
whether there is a way to turn this off. The point is that you do not want to
create a MIDI loop by having data that Logic sends to the device returned to
Logic to be sent again to be returned again to be sent again ... Enter "Thru"
in this column if there the device DOES NOT allow you to turn MIDI Thru off.

e GM/GS/XG

GM is a format for numbering MIDI sound device presets. The sound devices
that feature it are typically multi-timbral synths. There are also other MIDI
enhancements like "GS" and "XG" which can be indicated in this column.
Logic has special "tools" that take advantage of these features when they are
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available.

e Continuous Controllers

These are also extended MIDI modes available on some MIDI devices. When
available they offer greatly expanded control of the device's internal settings.
You can use Logic to manipulate these parameters on devices that feature
RPN and NRPN.

e SysEx
SysEx is the most flexible method of getting at a MIDI device's unique
features. Not all MIDI devices implement Sysex. For those that do, some will
both send and receive this information and others will only receive it. Use this
column to indicate both the devices capabilities and your intention to use
them. (l.e. if you have no plans to use SysEx, you can ignore this column.)
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Quick Start

set Preferences that match your MIDI interface 18
select and define outputs from Arrange view using Instrument Parameter Box 18
check that MIDI thru is working 18
check that LOGIC's MIDI settings are set correctly for your MIDI system 18
create a new instrument from the Arrange window 18
test that Program change messages are being sent and received properly 29
select patches from the Arrange window 29
test that Program change messages are being sent and received properly 31
select patches from the Arrange window 31
test that Pan and Volume messages are being sent and recieved properly 32
adjust volume/pan from Instrument Parameter Box in Arrange Window 32
make the Transport play a select section repeatedly (Cycle Mode) 32
set Logic Audio’s Preferences so they match your audio hardware 34
select and Audio track 34
record enable an audio track 34
select the desired Audio input for recording(Cycle Mode) 34

MIDI Setup and Configuration

save your song 40
create an Instrument object in the Environment 41
find the Instrument Parameter Box 11
protect the Environment from accidental alterations 11
hide or show the parameter sections to the left of most windows 41
decide what Environment object to use for each of your MIDI devices. 41
access all channels of a multi-timbral instrument 46
connect a Multi-Instrument to the right MIDI port 46
select icons for the Multi-Instrument and its sub-channels 46
choose programs by name rather than by number 46
enter and edit program names 46
get Logic to send the correct bank select messages 46
open & close the Mapped Instrument window 53
set the Mapped Instruments parameters 53
re-map MIDI notes using a Mapped Instrument 53
name individual notes to match your drum synth 53
set a velocity offset for each note 53
control the destination of individual notes 53
control how notes appear in a drum score style 53
avoid doubled notes 58
avoid MIDI feedback loops 58
get Logic to communicate with an internal card or software 61
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set up Logic to use Apple's Quicktime Musical Instruments 61
Set up Logic to access a SampleCell card 61
decide when to use OMS 63
enable Logic to use OMS 63
set Logic up to switch automatically between OMS and non-OMS operation 63
set up Logic's OMS "map" to match your Environment setup 63
create an on-screen mixer for each port 66
set up the on-screen mixer 66
connect the mixer to your Instrument objects 66
use the on-screen mixer and record the results 66
move Environment objects between layers 66

What makes Logic Special

open & close windows 72
change active windows 72
open & use floating windows 72
work with Logic's Transport 72
use the Catch button 72
make your window display stay current with the current song position 72
open and close editor windows 78
view a sequence in several windows at once 78
create and move between screensetsalleviate screen clutter 78
lock/unlock Screensets 78
copy Screen Sets 78
link windows & keep the song position in view 80
force an edit window to follow the selections made in another edit windows 80
keep the view of an edit window fixed on a particular sequence 80
find out to what task a key is assigned 82
find out which key is assigned to a task 82
assign your on keys to tasks 82
trigger key commands from your MIDI keyboard 82
print a list of your key commands 82
Recording

set up the Metronome 86
make the Metronome click for recording, playback or both 86
set the count-in 86
make the Metronome click only during count-in 86
set & change Logic's time signature 86
set & change Logic's tempo 86
choose a Track and Instrument for recording 86
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make a single-pass recording 86
re-do a single-pass recording 86
prepare to record a second part 95
Create a new track 95
practice with the first part in Cycle Mode 95
record multiple takes in Cycle Mode without stopping 95
punch in a correction to a part 929
punch-in automatically 99
use Punch mode with or w/o Replace Mode on 99
create an empty sequence for Step-time Recording 102
start & stop Step-time Recording 102
control the size of the steps while entering notes 102
use Logic's special shortcut keys for Step-time Recording 102
Editing

use Sequence parameters to affect playback 108
lock in the Sequence parameters 108
quantize while recording 108
quantize multiple tracks/sequences at once 108
guantize non-destructively 108
combine Sequences in Folders 125
move in and out of Folders 125
use Folders to repeat song structures 125
open the Event List editor window 128
edit event parameters in the Event List 128
add events to the Event List 128
select events in the Event List 128
change the format of the Event List's position display 128
quantize selected events in the Event List 128
select events of just one type 128
open the Matrix editor window 137
view and edit note velocities in the Matrix editor 137
change the Matrix editor's display grid lines 137
select the top or bottom voice of a multi-voice Sequence 137
select notes by other criteria in the Matrix editor 137
quantize selected notes in the Matrix editor 137
open the Score editor 142
control what Sequences are displayed in the score 142
view the score a line or page at a time 142
move between multi-staff and single staff views 142
quantize the score display without affecting the notes in the Sequence 142
Insert or Edit Time and Key Signatures 142
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Change the Clef Type 142
record and playback the results of a mix 152
have your mixer respond to an automated mix 152
create markers 155
create separate tracks after recording from external sequencer 155
de-mix a sequence based on pitch 155
nudge Sequence or MIDI events 155
keep written notes with song 155
cut/copy/paste Key and Time Signatures 155
time lock some or all notes in a Sequence 155
conform Logic’s tempos to match a “legato” performance. (Reclock) 155
Working with Audio

control the directory to which your audio files are recorded 172
set a record path that is global for all songs 172
set a record path that is different for each song 172
control how audio files are named 172
use folders on your hard drive to organize your audio files 172
prepare a track for recording 175
record enable a track 175
set the input source for recording 175
record from digital source 175
set Sample Rate 175
adjust regions in the Arrange Window 180
make copies of Regions 180
change the size of Regions 180
adjust a Region’s Anchor Point 180
re-position Regions that have been moved unintentionally 180
Synchronisation

set Logic to sync to an external source. 208
select the type of synchronisation Logic will use 208
select a SMPTE frame rate. 208
set the SMPTE offset. 208
set Logic to send sync to an external device 208
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